CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In March 2019

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2019-1010257 200 +Info 2019-03-27 2019-08-03
7.5
None Remote Low Not required Partial Partial Partial
An Information Disclosure / Data Modification issue exists in article2pdf_getfile.php in the article2pdf Wordpress plugin 0.24, 0.25, 0.26, 0.27. A URL can be constructed which allows overriding the PDF file's path leading to any PDF whose path is known and which is readable to the web server can be downloaded. The file will be deleted after download if the web server has permission to do so. For PHP versions before 5.3, any file can be read by null terminating the string left of the file extension.
2 CVE-2019-1003048 255 2019-03-28 2019-10-09
2.1
None Local Low Not required Partial None None
A vulnerability in Jenkins PRQA Plugin 3.1.0 and earlier allows attackers with local file system access to the Jenkins home directory to obtain the unencrypted password from the plugin configuration.
3 CVE-2019-1003047 275 2019-03-28 2019-10-09
4.0
None Remote Low Single system None Partial None
A missing permission check in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.
4 CVE-2019-1003046 352 CSRF 2019-03-28 2019-10-09
4.3
None Remote Medium Not required None Partial None
A cross-site request forgery vulnerability in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers to initiate a connection to an attacker-specified server.
5 CVE-2019-1003045 200 +Info 2019-03-28 2019-10-09
4.0
None Remote Low Single system Partial None None
A vulnerability in Jenkins ECS Publisher Plugin 1.0.0 and earlier allows attackers with Item/Extended Read permission, or local file system access to the Jenkins home directory to obtain the API token configured in this plugin's configuration.
6 CVE-2019-1003044 352 CSRF 2019-03-28 2019-10-09
2.1
None Remote High Single system Partial None None
A cross-site request forgery vulnerability in Jenkins Slack Notification Plugin 2.19 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
7 CVE-2019-1003043 255 2019-03-28 2019-10-09
3.5
None Remote Medium Single system Partial None None
A missing permission check in Jenkins Slack Notification Plugin 2.19 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
8 CVE-2019-1003042 79 XSS 2019-03-28 2019-06-10
3.5
None Remote Medium Single system None Partial None
A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.
9 CVE-2019-1003041 254 Bypass 2019-03-28 2019-06-10
7.5
None Remote Low Not required Partial Partial Partial
A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.
10 CVE-2019-1003040 254 Bypass 2019-03-28 2019-06-10
7.5
None Remote Low Not required Partial Partial Partial
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.
11 CVE-2019-1003039 255 2019-03-08 2019-10-09
4.0
None Remote Low Single system Partial None None
An insufficiently protected credentials vulnerability exists in JenkinsAppDynamics Dashboard Plugin 1.0.14 and earlier in src/main/java/nl/codecentric/jenkins/appd/AppDynamicsResultsPublisher.java that allows attackers without permission to obtain passwords configured in jobs to obtain them.
12 CVE-2019-1003037 200 +Info 2019-03-08 2019-10-09
4.0
None Remote Low Single system Partial None None
An information exposure vulnerability exists in Jenkins Azure VM Agents Plugin 0.8.0 and earlier in src/main/java/com/microsoft/azure/vmagent/AzureVMCloud.java that allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
13 CVE-2019-1003034 254 Exec Code Bypass 2019-03-08 2019-04-10
6.5
None Remote Low Single system Partial Partial Partial
A sandbox bypass vulnerability exists in Jenkins Job DSL Plugin 1.71 and earlier in job-dsl-core/src/main/groovy/javaposse/jobdsl/dsl/AbstractDslScriptLoader.groovy, job-dsl-plugin/build.gradle, job-dsl-plugin/src/main/groovy/javaposse/jobdsl/plugin/JobDslWhitelist.groovy, job-dsl-plugin/src/main/groovy/javaposse/jobdsl/plugin/SandboxDslScriptLoader.groovy that allows attackers with control over Job DSL definitions to execute arbitrary code on the Jenkins master JVM.
14 CVE-2019-1003031 254 Exec Code Bypass 2019-03-08 2019-04-10
6.5
None Remote Low Single system Partial Partial Partial
A sandbox bypass vulnerability exists in Jenkins Matrix Project Plugin 1.13 and earlier in pom.xml, src/main/java/hudson/matrix/FilterScript.java that allows attackers with Job/Configure permission to execute arbitrary code on the Jenkins master JVM.
15 CVE-2019-1003030 254 Exec Code Bypass 2019-03-08 2019-04-10
6.5
None Remote Low Single system Partial Partial Partial
A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShell.java that allows attackers able to control pipeline scripts to execute arbitrary code on the Jenkins master JVM.
16 CVE-2019-1003029 254 Exec Code Bypass 2019-03-08 2019-04-10
6.5
None Remote Low Single system Partial Partial Partial
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.
17 CVE-2019-1000031 400 2019-03-27 2019-08-03
5.0
None Remote Low Not required None None Partial
A disk space or quota exhaustion issue exists in article2pdf_getfile.php in the article2pdf Wordpress plugin 0.24, 0.25, 0.26, 0.27. Visiting PDF generation link but not following the redirect will leave behind a PDF file on disk which will never be deleted by the plug-in.
18 CVE-2019-10678 93 2019-03-31 2019-05-03
5.0
None Remote Low Not required None Partial None
Domoticz before 4.10579 neglects to categorize \n and \r as insecure argument options.
19 CVE-2019-10672 20 2019-03-31 2019-06-24
7.5
None Remote Low Not required Partial Partial Partial
treeRead in hdf/btree.c in libmysofa before 0.7 does not properly validate multiplications and additions.
20 CVE-2019-10664 89 Sql 2019-03-31 2019-05-03
7.5
None Remote Low Not required Partial Partial Partial
Domoticz before 4.10578 allows SQL Injection via the idx parameter in CWebServer::GetFloorplanImage in WebServer.cpp.
21 CVE-2019-10663 89 Sql 2019-03-30 2019-04-01
6.5
None Remote Low Single system Partial Partial Partial
Grandstream UCM6204 before 1.0.19.20 devices allow remote authenticated users to conduct SQL injection attacks via the sord parameter in a listCodeblueGroup API call to the /cgi? URI.
22 CVE-2019-10662 77 Exec Code 2019-03-30 2019-04-12
9.0
None Remote Low Single system Complete Complete Complete
Grandstream UCM6204 before 1.0.19.20 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the backupUCMConfig file-backup parameter to the /cgi? URI.
23 CVE-2019-10661 255 2019-03-30 2019-04-12
10.0
None Remote Low Not required Complete Complete Complete
On Grandstream GXV3611IR_HD before 1.0.3.23 devices, the root account lacks a password.
24 CVE-2019-10660 77 Exec Code 2019-03-30 2019-04-12
6.5
None Remote Low Single system Partial Partial Partial
Grandstream GXV3611IR_HD before 1.0.3.23 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the /goform/systemlog?cmd=set logserver field.
25 CVE-2019-10659 77 Exec Code 2019-03-30 2019-04-12
6.5
None Remote Low Single system Partial Partial Partial
Grandstream GXV3370 before 1.0.1.41 and WP820 before 1.0.3.6 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in a /manager?action=getlogcat priority field.
26 CVE-2019-10658 77 Exec Code 2019-03-30 2019-04-12
6.5
None Remote Low Single system Partial Partial Partial
Grandstream GWN7610 before 1.0.8.18 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the filename in a /ubus/controller.icc.update_nds_webroot_from_tmp update_nds_webroot_from_tmp API call.
27 CVE-2019-10657 200 +Info 2019-03-30 2019-04-12
4.0
None Remote Low Single system Partial None None
Grandstream GWN7000 before 1.0.6.32 and GWN7610 before 1.0.8.18 devices allow remote authenticated users to discover passwords via a /ubus/uci.apply config request.
28 CVE-2019-10656 77 Exec Code 2019-03-30 2019-04-12
9.0
None Remote Low Single system Complete Complete Complete
Grandstream GWN7000 before 1.0.6.32 devices allow remote authenticated users to execute arbitrary code via shell metacharacters in the filename in a /ubus/uci.apply update_nds_webroot_from_tmp API call.
29 CVE-2019-10655 119 Exec Code Overflow Bypass CSRF 2019-03-30 2019-04-03
7.5
None Remote Low Not required Partial Partial Partial
Grandstream GAC2500 1.0.3.35, GXP2200 1.0.3.27, GVC3202 1.0.3.51, GXV3275 before 1.0.3.219 Beta, and GXV3240 before 1.0.3.219 Beta devices allow unauthenticated remote code execution via shell metacharacters in a /manager?action=getlogcat priority field, in conjunction with a buffer overflow (via the phonecookie cookie) to overwrite a data structure and consequently bypass authentication. This can be exploited remotely or via CSRF because the cookie can be placed in an Accept HTTP header in an XMLHttpRequest call to lighttpd.
30 CVE-2019-10654 125 DoS 2019-03-30 2019-04-04
4.3
None Remote Medium Not required None None Partial
The lzo1x_decompress function in liblzo2.so.2 in LZO 2.10, as used in Long Range Zip (aka lrzip) 0.631, allows remote attackers to cause a denial of service (invalid memory read and application crash) via a crafted archive, a different vulnerability than CVE-2017-8845.
31 CVE-2019-10652 434 2019-03-30 2019-04-01
6.5
None Remote Low Single system Partial Partial Partial
An issue was discovered in flatCore 1.4.7. acp/acp.php allows remote authenticated administrators to upload arbitrary .php files, related to the addons feature.
32 CVE-2019-10650 125 DoS 2019-03-30 2019-05-14
5.8
None Remote Medium Not required Partial None Partial
In ImageMagick 7.0.8-36 Q16, there is a heap-based buffer over-read in the function WriteTIFFImage of coders/tiff.c, which allows an attacker to cause a denial of service or information disclosure via a crafted image file.
33 CVE-2019-10649 399 DoS 2019-03-30 2019-06-25
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.8-36 Q16, there is a memory leak in the function SVGKeyValuePairs of coders/svg.c, which allows an attacker to cause a denial of service via a crafted image file.
34 CVE-2019-10648 20 2019-03-30 2019-04-01
7.5
None Remote Low Not required Partial Partial Partial
Robocode through 1.9.3.5 allows remote attackers to cause external service interaction (DNS), as demonstrated by a query for a unique subdomain name within an attacker-controlled DNS zone, because of a .openStream call within java.net.URL.
35 CVE-2019-10647 434 Exec Code 2019-03-30 2019-04-01
7.5
None Remote Low Not required Partial Partial Partial
ZZZCMS zzzphp v1.6.3 allows remote attackers to execute arbitrary PHP code via a .php URL in the plugins/ueditor/php/controller.php?action=catchimage source[] parameter because of a lack of inc/zzz_file.php restrictions. For example, source%5B%5D=http%3A%2F%2F192.168.0.1%2Ftest.php can be used if the 192.168.0.1 web server sends the contents of a .php file (i.e., it does not interpret a .php file).
36 CVE-2019-10646 79 XSS 2019-03-29 2019-04-01
4.3
None Remote Medium Not required None Partial None
Wolf CMS v0.8.3.1 is affected by cross site scripting (XSS) in the module Add Snippet (/?/admin/snippet/add). This allows an attacker to insert arbitrary JavaScript as user input, which will be executed whenever the affected snippet is loaded.
37 CVE-2019-10644 352 CSRF 2019-03-29 2019-04-01
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in HYBBS 2.2. /?admin/user.html has a CSRF vulnerability that can add an administrator account.
38 CVE-2019-10477 19 2019-03-29 2019-04-01
5.0
None Remote Low Not required None Partial None
The FusionInventory plugin before 1.4 for GLPI 9.3.x and before 1.1 for GLPI 9.4.x mishandles sendXML actions.
39 CVE-2019-10276 434 2019-03-29 2019-04-01
7.5
None Remote Low Not required Partial Partial Partial
Western Bridge Cobub Razor 0.8.0 has a file upload vulnerability via the web/assets/swf/uploadify.php URI, as demonstrated by a .php file with the image/jpeg content type.
40 CVE-2019-10269 119 Overflow 2019-03-29 2019-08-06
10.0
None Remote Low Not required Complete Complete Complete
BWA (aka Burrow-Wheeler Aligner) before 2019-01-23 has a stack-based buffer overflow in the bns_restore function in bntseq.c via a long sequence name in a .alt file.
41 CVE-2019-10262 89 Sql 2019-03-28 2019-03-29
7.5
None Remote Low Not required Partial Partial Partial
A SQL Injection issue was discovered in BlueCMS 1.6. The variable $ad_id is spliced directly in uploads/admin/ad.php in the admin folder, and is not wrapped in single quotes, resulting in injection around the escape of magic quotes.
42 CVE-2019-10260 79 XSS 2019-03-28 2019-03-29
4.3
None Remote Medium Not required None Partial None
Total.js CMS 12.0.0 has XSS related to themes/admin/views/index.html (item.message) and themes/admin/public/ui.js (column.format).
43 CVE-2019-10255 601 2019-03-28 2019-04-11
5.8
None Remote Medium Not required Partial Partial None
An Open Redirect vulnerability for all browsers in Jupyter Notebook before 5.7.7 and some browsers (Chrome, Firefox) in JupyterHub before 0.9.5 allows crafted links to the login page, which will redirect to a malicious site after successful login. Servers running on a base_url prefix are not affected.
44 CVE-2019-10254 79 XSS 2019-03-28 2019-03-28
4.3
None Remote Medium Not required None Partial None
In MISP before 2.4.105, the app/View/Layouts/default.ctp default layout template has a Reflected XSS vulnerability.
45 CVE-2019-10251 310 2019-03-28 2019-04-02
4.3
None Remote Medium Not required Partial None None
The UCWeb UC Browser application through 2019-03-26 for Android uses HTTP to download certain modules associated with PDF and Microsoft Office files (related to libpicsel), which allows MITM attacks.
46 CVE-2019-10250 310 2019-03-28 2019-04-01
4.3
None Remote Medium Not required Partial None None
UCWeb UC Browser 7.0.185.1002 on Windows uses HTTP for downloading certain PDF modules, which allows MITM attacks.
47 CVE-2019-10238 79 XSS 2019-03-27 2019-03-28
4.3
None Remote Medium Not required None Partial None
Sitemagic CMS v4.4 has XSS in SMFiles/FrmUpload.class.php via the filename parameter.
48 CVE-2019-10237 352 CSRF 2019-03-27 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
S-CMS PHP v1.0 has a CSRF vulnerability to add a new admin user via the 4.edu.php/admin/ajax.php?type=admin&action=add&lang=0 URI, a related issue to CVE-2019-9040.
49 CVE-2019-10233 362 2019-03-27 2019-09-11
6.8
None Remote Medium Not required Partial Partial Partial
Teclib GLPI before 9.4.1.1 is affected by a timing attack associated with a cookie.
50 CVE-2019-10232 89 Sql 2019-03-27 2019-03-28
7.5
None Remote Low Not required Partial Partial Partial
Teclib GLPI through 9.3.3 has SQL injection via the "cycle" parameter in /scripts/unlock_tasks.php.
Total number of vulnerabilities : 675   Page : 1 (This Page)2 3 4 5 6 7 8 9 10 11 12 13 14
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.