Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c calls sprintf to write to the error buffer that is passed down to the option callback functions.
Max CVSS
7.8
EPSS Score
0.04%
Published
2024-02-05
Updated
2024-02-23
Vim is a UNIX editor that, prior to version 9.0.2121, has a heap-use-after-free vulnerability. When executing a `:s` command for the very first time and using a sub-replace-special atom inside the substitution part, it is possible that the recursive `:s` call causes free-ing of memory which may later then be accessed by the initial `:s` command. The user must intentionally execute the payload and the whole process is a bit tricky to do since it seems to work only reliably for the very first :s command. It may also cause a crash of Vim. Version 9.0.2121 contains a fix for this issue.
Max CVSS
4.7
EPSS Score
0.05%
Published
2023-11-22
Updated
2024-01-05
Vim is an improved version of the good old UNIX editor Vi. Heap-use-after-free in memory allocated in the function `ga_grow_inner` in in the file `src/alloc.c` at line 748, which is freed in the file `src/ex_docmd.c` in the function `do_cmdline` at line 1010 and then used again in `src/cmdhist.c` at line 759. When using the `:history` command, it's possible that the provided argument overflows the accepted value. Causing an Integer Overflow and potentially later an use-after-free. This vulnerability has been patched in version 9.0.2068.
Max CVSS
5.5
EPSS Score
0.04%
Published
2023-10-27
Updated
2023-12-17
Use After Free in GitHub repository vim/vim prior to v9.0.2010.
Max CVSS
7.8
EPSS Score
0.05%
Published
2023-10-11
Updated
2023-11-15
NULL Pointer Dereference in GitHub repository vim/vim prior to 20d161ace307e28690229b68584f2d84556f8960.
Max CVSS
6.2
EPSS Score
0.04%
Published
2023-10-05
Updated
2023-11-15
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1969.
Max CVSS
7.5
EPSS Score
0.18%
Published
2023-10-02
Updated
2023-12-13
Use After Free in GitHub repository vim/vim prior to 9.0.1858.
Max CVSS
7.8
EPSS Score
0.06%
Published
2023-09-04
Updated
2024-02-01
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1331.
Max CVSS
7.8
EPSS Score
0.05%
Published
2023-09-03
Updated
2023-12-22
Use After Free in GitHub repository vim/vim prior to 9.0.1857.
Max CVSS
7.8
EPSS Score
0.06%
Published
2023-09-04
Updated
2024-02-01
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1848.
Max CVSS
7.8
EPSS Score
0.05%
Published
2023-09-02
Updated
2024-02-01
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1847.
Max CVSS
7.8
EPSS Score
0.05%
Published
2023-09-02
Updated
2023-12-22
Use After Free in GitHub repository vim/vim prior to 9.0.1840.
Max CVSS
7.8
EPSS Score
0.06%
Published
2023-09-04
Updated
2024-02-01
NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1531.
Max CVSS
7.8
EPSS Score
0.04%
Published
2023-05-09
Updated
2023-12-23
NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1402.
Max CVSS
8.4
EPSS Score
0.05%
Published
2023-03-11
Updated
2023-04-02
NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1392.
Max CVSS
6.6
EPSS Score
0.05%
Published
2023-03-07
Updated
2023-04-02
Out-of-bounds Write in GitHub repository vim/vim prior to 9.0.1145.
Max CVSS
7.8
EPSS Score
0.07%
Published
2023-01-04
Updated
2023-06-12
A null pointer dereference issue was discovered in function gui_x11_create_blank_mouse in gui_x11.c in vim 8.1.2269 thru 9.0.0339 allows attackers to cause denial of service or other unspecified impacts.
Max CVSS
7.8
EPSS Score
0.04%
Published
2023-01-20
Updated
2023-05-03
Use After Free in GitHub repository vim/vim prior to 9.0.0882.
Max CVSS
7.8
EPSS Score
0.07%
Published
2022-12-05
Updated
2023-05-03
Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the expression used in the RHS of the substitute command.
Max CVSS
7.8
EPSS Score
0.08%
Published
2022-11-25
Updated
2023-06-12
A vulnerability was found in vim and classified as problematic. Affected by this issue is the function qf_update_buffer of the file quickfix.c of the component autocmd Handler. The manipulation leads to use after free. The attack may be launched remotely. Upgrading to version 9.0.0805 is able to address this issue. The name of the patch is d0fab10ed2a86698937e3c3fed2f10bd9bb5e731. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-212324.
Max CVSS
7.5
EPSS Score
0.45%
Published
2022-10-26
Updated
2023-05-03
Use After Free in GitHub repository vim/vim prior to 9.0.0789.
Max CVSS
7.8
EPSS Score
0.06%
Published
2022-12-02
Updated
2023-05-03
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765.
Max CVSS
9.8
EPSS Score
0.13%
Published
2022-12-02
Updated
2023-05-03
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0742.
Max CVSS
7.8
EPSS Score
0.06%
Published
2022-12-03
Updated
2023-05-03
Use After Free in GitHub repository vim/vim prior to 9.0.0614.
Max CVSS
7.8
EPSS Score
0.09%
Published
2022-09-29
Updated
2023-05-03
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0598.
Max CVSS
7.8
EPSS Score
0.09%
Published
2022-09-27
Updated
2023-05-03
110 vulnerabilities found
1 2 3 4 5
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!