Mozilla » Firefox » 1.5 beta1 : Security Vulnerabilities

cpe:2.3:a:mozilla:firefox:1.5:beta1:*:*:*:*:*:*
Memory safety bugs present in Firefox 114. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 115.
Max Base Score
8.8
Published 2023-07-05
Updated 2023-07-11
EPSS 0.09%
Memory safety bugs present in Firefox 114, Firefox ESR 102.12, and Thunderbird 102.12. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 115, Firefox ESR < 102.13, and Thunderbird < 102.13.
Max Base Score
8.8
Published 2023-07-05
Updated 2023-07-12
EPSS 0.11%
A website could prevent a user from exiting full-screen mode via alert and prompt calls. This could lead to user confusion and possible spoofing attacks. This vulnerability affects Firefox < 115.
Max Base Score
6.5
Published 2023-07-05
Updated 2023-07-11
EPSS 0.05%
A use-after-free condition existed in `NotifyOnHistoryReload` where a `LoadingSessionHistoryEntry` object was freed and a reference to that object remained. This resulted in a potentially exploitable condition when the reference to that object was later reused. This vulnerability affects Firefox < 115.
Max Base Score
8.8
Published 2023-07-05
Updated 2023-07-11
EPSS 0.09%
When opening Diagcab files, Firefox did not warn the user that these files may contain malicious code. This vulnerability affects Firefox < 115, Firefox ESR < 102.13, and Thunderbird < 102.13.
Max Base Score
7.8
Published 2023-07-05
Updated 2023-07-12
EPSS 0.06%
A website could have obscured the fullscreen notification by using a URL with a scheme handled by an external program, such as a mailto URL. This could have led to user confusion and possible spoofing attacks. This vulnerability affects Firefox < 115, Firefox ESR < 102.13, and Thunderbird < 102.13.
Max Base Score
6.5
Published 2023-07-05
Updated 2023-07-12
EPSS 0.11%
Uploading files which contain symlinks may have allowed an attacker to trick a user into submitting sensitive data to a malicious website. This vulnerability affects Firefox < 115.
Max Base Score
6.5
Published 2023-07-05
Updated 2023-07-11
EPSS 0.08%
The use of RTL Arabic characters in the address bar may have allowed for URL spoofing. This vulnerability affects Firefox < 115.
Max Base Score
6.5
Published 2023-07-05
Updated 2023-07-11
EPSS 0.05%
A website could have obscured the fullscreen notification by using an option element by introducing lag via an expensive computational function. This could have led to user confusion and possible spoofing attacks. This vulnerability affects Firefox < 115.
Max Base Score
6.5
Published 2023-07-05
Updated 2023-07-11
EPSS 0.05%
Insufficient validation in the Drag and Drop API in conjunction with social engineering, may have allowed an attacker to trick end-users into creating a shortcut to local system files. This could have been leveraged to execute arbitrary code. This vulnerability affects Firefox < 115.
Max Base Score
7.8
Published 2023-07-05
Updated 2023-07-11
EPSS 0.06%
Cross-compartment wrappers wrapping a scripted proxy could have caused objects from other compartments to be stored in the main compartment resulting in a use-after-free. This vulnerability affects Firefox < 115, Firefox ESR < 102.13, and Thunderbird < 102.13.
Max Base Score
8.8
Published 2023-07-05
Updated 2023-07-12
EPSS 0.11%
An attacker could have triggered a use-after-free condition when creating a WebRTC connection over HTTPS. This vulnerability affects Firefox < 115, Firefox ESR < 102.13, and Thunderbird < 102.13.
Max Base Score
8.8
Published 2023-07-05
Updated 2023-07-12
EPSS 0.11%
Memory safety bugs present in Firefox 113. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 114.
Max Base Score
9.8
Published 2023-06-19
Updated 2023-06-27
EPSS 0.09%
Memory safety bugs present in Firefox 113, Firefox ESR 102.11, and Thunderbird 102.12. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox ESR < 102.12, Firefox < 114, and Thunderbird < 102.12.
Max Base Score
9.8
Published 2023-06-19
Updated 2023-06-27
EPSS 0.06%
When choosing a site-isolated process for a document loaded from a data: URL that was the result of a redirect, Firefox would load that document in the same process as the site that issued the redirect. This bypassed the site-isolation protections against Spectre-like attacks on sites that host an "open redirect". Firefox no longer follows HTTP redirects to data: URLs. This vulnerability affects Firefox < 114.
Max Base Score
6.1
Published 2023-06-19
Updated 2023-06-27
EPSS 0.05%
The error page for sites with invalid TLS certificates was missing the activation-delay Firefox uses to protect prompts and permission dialogs from attacks that exploit human response time delays. If a malicious page elicited user clicks in precise locations immediately before navigating to a site with a certificate error and made the renderer extremely busy at the same time, it could create a gap between when the error page was loaded and when the display actually refreshed. With the right timing the elicited clicks could land in that gap and activate the button that overrides the certificate error for that site. This vulnerability affects Firefox ESR < 102.12, Firefox < 114, and Thunderbird < 102.12.
Max Base Score
3.1
Published 2023-06-19
Updated 2023-06-27
EPSS 0.05%
Memory safety bugs present in Firefox 112. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 113.
Max Base Score
9.8
Published 2023-06-19
Updated 2023-06-27
EPSS 0.09%
Mozilla developers and community members Gabriele Svelto, Andrew Osmond, Emily McDonough, Sebastian Hengst, Andrew McCreight and the Mozilla Fuzzing Team reported memory safety bugs present in Firefox 112 and Firefox ESR 102.10. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 113, Firefox ESR < 102.11, and Thunderbird < 102.11.
Max Base Score
8.8
Published 2023-06-02
Updated 2023-06-09
EPSS 0.06%
Protocol handlers `ms-cxh` and `ms-cxh-full` could have been leveraged to trigger a denial of service. *Note: This attack only affects Windows. Other operating systems are not affected.* This vulnerability affects Firefox < 113, Firefox ESR < 102.11, and Thunderbird < 102.11.
Max Base Score
7.5
Published 2023-06-19
Updated 2023-06-27
EPSS 0.06%
When reading a file, an uninitialized value could have been used as read limit. This vulnerability affects Firefox < 113, Firefox ESR < 102.11, and Thunderbird < 102.11.
Max Base Score
8.8
Published 2023-06-02
Updated 2023-06-09
EPSS 0.07%
An attacker could have positioned a <code>datalist</code> element to obscure the address bar. This vulnerability affects Firefox < 113, Firefox ESR < 102.11, and Thunderbird < 102.11.
Max Base Score
4.3
Published 2023-06-02
Updated 2023-06-09
EPSS 0.05%
A type checking bug would have led to invalid code being compiled. This vulnerability affects Firefox < 113, Firefox ESR < 102.11, and Thunderbird < 102.11.
Max Base Score
6.5
Published 2023-06-02
Updated 2023-06-09
EPSS 0.06%
Documents were incorrectly assuming an ordering of principal objects when ensuring we were loading an appropriately privileged principal. In certain circumstances it might have been possible to cause a document to be loaded with a higher privileged principal than intended. This vulnerability affects Firefox < 113.
Max Base Score
6.5
Published 2023-06-19
Updated 2023-06-27
EPSS 0.05%
A maliciously crafted favicon could have led to an out of memory crash. This vulnerability affects Firefox < 113.
Max Base Score
7.5
Published 2023-06-19
Updated 2023-06-27
EPSS 0.05%
Service workers could reveal script base URL due to dynamic `import()`. This vulnerability affects Firefox < 113.
Max Base Score
5.3
Published 2023-06-19
Updated 2023-06-27
EPSS 0.05%
1977 vulnerabilities found
1 2 3 4 5 6 ...... 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80
This web site uses cookies for managing your session and website analytics (Google analytics) purposes as described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!