SPIP before 4.1.14 and 4.2.x before 4.2.8 allows XSS via the name of an uploaded file. This is related to javascript/bigup.js and javascript/bigup.utils.js.
Max CVSS
6.1
Published
2024-01-19
Updated
2024-01-25
EPSS
0.05%
ecrire/public/assembler.php in SPIP before 4.1.13 and 4.2.x before 4.2.7 allows XSS because input from _request() is not restricted to safe characters such as alphanumerics.
Max CVSS
6.1
Published
2024-01-04
Updated
2024-02-02
EPSS
0.05%

CVE-2023-27372

Public exploit exists
SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.
Max CVSS
9.8
Published
2023-02-28
Updated
2023-06-21
EPSS
97.04%
SPIP v4.1.5 and earlier was discovered to contain a SQL injection vulnerability via the _oups parameter. This vulnerability allows attackers to execute arbitrary code via a crafted POST request.
Max CVSS
9.8
Published
2023-02-27
Updated
2023-03-24
EPSS
0.10%
RCE in SPIP 3.1.13 through 4.1.2 allows remote authenticated users to execute arbitrary code via the _oups parameter.
Max CVSS
8.8
Published
2022-12-14
Updated
2023-01-30
EPSS
0.45%
Spip Web Framework v3.1.13 and below was discovered to contain multiple SQL injection vulnerabilities at /ecrire via the lier_trad and where parameters.
Max CVSS
8.8
Published
2022-05-19
Updated
2022-05-26
EPSS
0.14%
A PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.
Max CVSS
8.8
Published
2022-05-19
Updated
2022-05-26
EPSS
0.21%
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
Max CVSS
6.1
Published
2022-05-19
Updated
2022-05-26
EPSS
0.13%
SPIP before 3.2.14 and 4.x before 4.0.5 allows unauthenticated access to information about editorial objects.
Max CVSS
5.3
Published
2022-03-10
Updated
2022-03-18
EPSS
0.12%
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
Max CVSS
8.8
Published
2022-03-10
Updated
2022-03-18
EPSS
0.27%
SPIP 4.0.0 is affected by a remote command execution vulnerability. To exploit the vulnerability, an attacker must craft a malicious picture with a double extension, upload it and then click on it to execute it.
Max CVSS
8.8
Published
2022-01-26
Updated
2022-02-02
EPSS
0.17%
SPIP 4.0.0 is affected by a Cross Site Request Forgery (CSRF) vulnerability in ecrire/public/aiguiller.php, ecrire/public/balises.php, ecrire/balise/formulaire_.php. To exploit the vulnerability, a visitor must visit a malicious website which redirects to the SPIP website. It is also possible to combine XSS vulnerabilities in SPIP 4.0.0 to exploit it. The vulnerability allows an authenticated attacker to execute malicious code without the knowledge of the user on the website (CSRF).
Max CVSS
8.8
Published
2022-01-26
Updated
2022-02-02
EPSS
0.08%
SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability in ecrire/public/interfaces.php, adding the function safehtml to the vulnerable fields. An editor is able to modify his personal information. If the editor has an article written and available, when a user goes to the public site and wants to read the author's information, the malicious code will be executed. The "Who are you" and "Website Name" fields are vulnerable.
Max CVSS
5.4
Published
2022-01-26
Updated
2022-02-01
EPSS
0.05%
SPIP 4.0.0 is affected by a Cross Site Scripting (XSS) vulnerability. To exploit the vulnerability, a visitor must browse to a malicious SVG file. The vulnerability allows an authenticated attacker to inject malicious code running on the client side into web pages visited by other users (stored XSS).
Max CVSS
5.4
Published
2022-01-26
Updated
2022-02-01
EPSS
0.06%
prive/formulaires/configurer_preferences.php in SPIP before 3.2.8 does not properly validate the couleur, display, display_navigation, display_outils, imessage, and spip_ecran parameters.
Max CVSS
9.8
Published
2020-11-23
Updated
2021-02-04
EPSS
0.16%
_core_/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
Max CVSS
6.5
Published
2019-12-17
Updated
2022-05-03
EPSS
0.25%
SPIP before 3.1.11 and 3.2 before 3.2.5 provides different error messages from the password-reminder page depending on whether an e-mail address exists, which might help attackers to enumerate subscribers.
Max CVSS
5.3
Published
2019-09-17
Updated
2022-05-03
EPSS
0.27%
SPIP before 3.1.11 and 3.2 before 3.2.5 mishandles redirect URLs in ecrire/inc/headers.php with a %0D, %0A, or %20 character.
Max CVSS
6.1
Published
2019-09-17
Updated
2023-02-13
EPSS
0.17%
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
Max CVSS
6.1
Published
2019-09-17
Updated
2023-02-13
EPSS
0.18%
SPIP before 3.1.11 and 3.2 before 3.2.5 allows authenticated visitors to modify any published content and execute other modifications in the database. This is related to ecrire/inc/meta.php and ecrire/inc/securiser_action.php.
Max CVSS
6.5
Published
2019-09-17
Updated
2023-02-13
EPSS
0.07%
SPIP 3.1 before 3.1.10 and 3.2 before 3.2.4 allows authenticated visitors to execute arbitrary code on the host server because var_memotri is mishandled.
Max CVSS
8.8
Published
2019-04-10
Updated
2020-09-28
EPSS
0.61%
Cross-site scripting (XSS) vulnerability (stored) in SPIP before 3.1.7 allows remote attackers to inject arbitrary web script or HTML via a crafted string, as demonstrated by a PGP field, related to prive/objets/contenu/auteur.html and ecrire/inc/texte_mini.php.
Max CVSS
6.1
Published
2017-10-22
Updated
2020-09-28
EPSS
0.18%
SPIP 3.1.x before 3.1.6 and 3.2.x before Beta 3 does not remove shell metacharacters from the host field, allowing a remote attacker to cause remote code execution.
Max CVSS
9.8
Published
2017-06-17
Updated
2017-11-04
EPSS
2.81%
SPIP 3.1.x suffer from a Reflected Cross Site Scripting Vulnerability in /ecrire/exec/info_plugin.php involving the `$plugin` parameter, as demonstrated by a /ecrire/?exec=info_plugin URL.
Max CVSS
6.1
Published
2016-12-17
Updated
2017-07-27
EPSS
0.13%
SPIP 3.1.x suffers from a Reflected Cross Site Scripting Vulnerability in /ecrire/exec/puce_statut.php involving the `$id` parameter, as demonstrated by a /ecrire/?exec=puce_statut URL.
Max CVSS
6.1
Published
2016-12-17
Updated
2017-07-27
EPSS
0.13%
52 vulnerabilities found
1 2 3
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!