CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Postgresql » Postgresql » 7.2.1 : Security Vulnerabilities

Cpe Name:cpe:/a:postgresql:postgresql:7.2.1
Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2018-1115 2018-05-10 2019-10-09
6.4
None Remote Low Not required None Partial Partial
postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.
2 CVE-2017-14798 362 2018-03-01 2019-10-02
6.9
None Local Medium Not required Complete Complete Complete
A race condition in the postgresql init script could be used by attackers able to access the postgresql account to escalate their privileges to root.
3 CVE-2007-0556 DoS 2007-02-05 2018-10-16
6.6
None Remote High Single system Complete None Complete
The query planner in PostgreSQL before 8.0.11, 8.1 before 8.1.7, and 8.2 before 8.2.2 does not verify that a table is compatible with a "previously made query plan," which allows remote authenticated users to cause a denial of service (server crash) and possibly access database content via an "ALTER COLUMN TYPE" SQL statement, which can be leveraged to read arbitrary memory from the server.
4 CVE-2006-5540 DoS 2006-10-26 2017-10-10
4.0
None Remote Low Single system None None Partial
backend/parser/analyze.c in PostgreSQL 8.1.x before 8.1.5 allows remote authenticated users to cause a denial of service (daemon crash) via certain aggregate functions in an UPDATE statement, which are not properly handled during a "MIN/MAX index optimization."
5 CVE-2005-1409 2005-05-03 2018-10-19
7.5
User Remote Low Not required Partial Partial Partial
PostgreSQL 7.3.x through 8.0.x gives public EXECUTE access to certain character conversion functions, which allows unprivileged users to call those functions with malicious values, with unknown impact, aka the "Character conversion vulnerability."
6 CVE-2005-0247 119 Exec Code Overflow 2005-05-02 2017-10-10
6.5
User Remote Low Single system Partial Partial Partial
Multiple buffer overflows in gram.y for PostgreSQL 8.0.1 and earlier may allow attackers to execute arbitrary code via (1) a large number of variables in a SQL statement being handled by the read_sql_construct function, (2) a large number of INTO variables in a SELECT statement being handled by the make_select_stmt function, (3) a large number of arbitrary variables in a SELECT statement being handled by the make_select_stmt function, and (4) a large number of INTO variables in a FETCH statement being handled by the make_fetch_stmt function, a different set of vulnerabilities than CVE-2005-0245.
7 CVE-2005-0246 DoS 2005-05-02 2017-10-10
5.0
None Remote Low Not required None None Partial
The intagg contrib module for PostgreSQL 8.0.0 and earlier allows attackers to cause a denial of service (crash) via crafted arrays.
8 CVE-2005-0245 Exec Code Overflow 2005-02-01 2017-10-10
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in gram.y for PostgreSQL 8.0.0 and earlier may allow attackers to execute arbitrary code via a large number of arguments to a refcursor function (gram.y), which leads to a heap-based buffer overflow, a different vulnerability than CVE-2005-0247.
9 CVE-2005-0244 264 Exec Code Bypass 2005-05-02 2017-10-10
6.5
User Remote Low Single system Partial Partial Partial
PostgreSQL 8.0.0 and earlier allows local users to bypass the EXECUTE permission check for functions by using the CREATE AGGREGATE command.
10 CVE-2005-0227 94 Exec Code 2005-05-02 2017-10-10
4.3
None Local Low Single system Partial Partial Partial
PostgreSQL (pgsql) 7.4.x, 7.2.x, and other versions allows local users to load arbitrary shared libraries and execute code via the LOAD extension.
11 CVE-2004-0977 2005-02-09 2017-10-10
2.1
None Local Low Not required None Partial None
The make_oidjoins_check script in PostgreSQL 7.4.5 and earlier allows local users to overwrite files via a symlink attack on temporary files.
12 CVE-2004-0547 DoS Overflow 2004-08-06 2017-07-10
5.0
None Remote Low Not required None None Partial
Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).
13 CVE-2003-0901 Exec Code Overflow 2003-11-03 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in to_ascii for PostgreSQL 7.2.x, and 7.3.x before 7.3.4, allows remote attackers to execute arbitrary code.
14 CVE-2002-1642 DoS 2002-10-03 2017-07-10
7.2
Admin Local Low Not required Complete Complete Complete
PostgreSQL 7.2.1 and 7.2.2 allows local users to delete transaction log (pg_clog) data and cause a denial of service (data loss) via the VACUUM command.
15 CVE-2002-1402 DoS Exec Code Overflow 2003-01-17 2016-10-17
4.6
User Local Low Not required Partial Partial Partial
Buffer overflows in the (1) TZ and (2) SET TIME ZONE enivronment variables for PostgreSQL 7.2.1 and earlier allow local users to cause a denial of service and possibly execute arbitrary code.
16 CVE-2002-1401 119 DoS Exec Code Overflow 2003-01-17 2008-09-10
6.5
User Remote Low Single system Partial Partial Partial
Buffer overflows in (1) circle_poly, (2) path_encode and (3) path_add (also incorrectly identified as path_addr) for PostgreSQL 7.2.3 and earlier allow attackers to cause a denial of service and possibly execute arbitrary code, possibly as a result of an integer overflow.
17 CVE-2002-1400 Exec Code Overflow 2003-01-17 2016-10-17
7.5
User Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in the repeat() function for PostgreSQL before 7.2.2 allows attackers to execute arbitrary code by causing repeat() to generate a large string.
18 CVE-2002-1399 2003-01-17 2016-10-17
10.0
None Remote Low Not required Complete Complete Complete
Unknown vulnerability in cash_out and possibly other functions in PostgreSQL 7.2.1 and earlier, and possibly later versions before 7.2.3, with unknown impact, based on an invalid integer input which is processed as a different data type, as demonstrated using cash_out(2).
19 CVE-2002-1398 DoS Exec Code Overflow 2003-01-17 2016-10-17
4.6
User Local Low Not required Partial Partial Partial
Buffer overflow in the date parser for PostgreSQL before 7.2.2 allows attackers to cause a denial of service and possibly execute arbitrary code via a long date string, aka a vulnerability "in handling long datetime input."
20 CVE-2002-0972 DoS Exec Code Overflow 2002-09-24 2016-10-17
4.6
User Local Low Not required Partial Partial Partial
Buffer overflows in PostgreSQL 7.2 allow attackers to cause a denial of service and possibly execute arbitrary code via long arguments to the functions (1) lpad or (2) rpad.
Total number of vulnerabilities : 20   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.