CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Moodle » Moodle » 3.0.3 : Security Vulnerabilities

Cpe Name:cpe:/a:moodle:moodle:3.0.3
Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2017-12157 200 +Info 2017-09-18 2017-09-28
4.0
None Remote Low Single system Partial None None
In Moodle 3.x, various course reports allow teachers to view details about users in the groups they can't access.
2 CVE-2017-12156 79 XSS 2017-09-18 2017-09-21
4.3
None Remote Medium Not required None Partial None
Moodle 3.x has XSS in the contact form on the "non-respondents" page in non-anonymous feedback.
3 CVE-2017-7491 352 CSRF 2017-05-15 2017-05-23
4.3
None Remote Medium Not required None Partial None
In Moodle 2.x and 3.x, a CSRF attack is possible that allows attackers to change the "number of courses displayed in the course overview block" configuration setting.
4 CVE-2017-7490 264 2017-05-15 2017-05-23
5.0
None Remote Low Not required Partial None None
In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.
5 CVE-2017-7489 264 2017-05-15 2017-05-23
6.5
None Remote Low Single system Partial Partial Partial
In Moodle 2.x and 3.x, remote authenticated users can take ownership of arbitrary blogs by editing an external blog link.
6 CVE-2017-2641 89 Sql 2017-03-26 2017-08-15
7.5
None Remote Low Not required Partial Partial Partial
In Moodle 2.x and 3.x, SQL injection can occur via user preferences.
7 CVE-2017-2576 20 2017-01-20 2017-01-25
5.0
None Remote Low Not required None Partial None
In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.
8 CVE-2016-8644 264 2017-01-20 2017-01-25
5.0
None Remote Low Not required Partial None None
In Moodle 2.x and 3.x, the capability to view course notes is checked in the wrong context.
9 CVE-2016-8643 284 2017-01-20 2017-01-25
4.0
None Remote Low Single system None Partial None
In Moodle 2.x and 3.x, non-admin site managers may accidentally edit admins via web services.
10 CVE-2016-8642 284 2017-01-20 2017-01-25
5.0
None Remote Low Not required Partial None None
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
11 CVE-2016-7038 640 2017-01-20 2017-01-25
5.0
None Remote Low Not required Partial None None
In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.
12 CVE-2016-5014 200 +Info 2017-01-20 2017-01-25
5.8
None Remote Medium Not required Partial Partial None
In Moodle 2.x and 3.x, an unenrolled user still receives event monitor notifications even though they can no longer access the course.
13 CVE-2016-5013 74 2017-01-20 2017-01-25
5.8
None Remote Medium Not required Partial Partial None
In Moodle 2.x and 3.x, text injection can occur in email headers, potentially leading to outbound spam.
14 CVE-2016-3734 352 CSRF 2017-04-20 2017-04-27
6.8
None Remote Medium Not required Partial Partial Partial
Cross-site request forgery (CSRF) vulnerability in markposts.php in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13 and earlier allows remote attackers to hijack the authentication of users for requests that marks forum posts as read.
15 CVE-2016-3733 284 2017-04-20 2017-04-28
4.0
None Remote Low Single system None Partial None
The "restore teacher" feature in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to overwrite the course idnumber.
16 CVE-2016-3732 200 +Info 2017-04-20 2017-04-27
4.0
None Remote Low Single system Partial None None
The capability check to access other badges in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to read the badges of other users.
17 CVE-2016-3731 200 +Info 2017-04-20 2017-04-27
5.0
None Remote Low Not required Partial None None
Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, and 2.8 through 2.8.11 allows remote attackers to obtain the names of hidden forums and forum discussions.
18 CVE-2016-3729 284 2017-04-20 2017-04-27
4.0
None Remote Low Single system None Partial None
The user editing form in Moodle 3.0 through 3.0.3, 2.9 through 2.9.5, 2.8 through 2.8.11, 2.7 through 2.7.13, and earlier allows remote authenticated users to edit profile fields locked by the administrator.
Total number of vulnerabilities : 18   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.