CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Elementor : Security Vulnerabilities

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1 CVE-2022-29455 79 XSS 2022-06-13 2022-06-27
4.3
None Remote Medium Not required None Partial None
DOM-based Reflected Cross-Site Scripting (XSS) vulnerability in Elementor's Elementor Website Builder plugin <= 3.5.5 versions.
2 CVE-2022-1329 862 Exec Code 2022-04-19 2022-04-27
6.5
None Remote Low ??? Partial Partial Partial
The Elementor Website Builder plugin for WordPress is vulnerable to unauthorized execution of several AJAX actions due to a missing capability check in the ~/core/app/modules/onboarding/module.php file that make it possible for attackers to modify site data in addition to uploading malicious files that can be used to obtain remote code execution, in versions 3.6.0 to 3.6.2.
3 CVE-2021-24891 79 XSS 2021-11-23 2021-12-15
4.3
None Remote Medium Not required None Partial None
The Elementor Website Builder WordPress plugin before 3.4.8 does not sanitise or escape user input appended to the DOM via a malicious hash, resulting in a DOM Cross-Site Scripting issue.
4 CVE-2021-24206 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the image box widget (includes/widgets/image-box.php) accepts a ‘title_size’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request containing JavaScript in the ‘title_size’ parameter, which is not filtered and is output without escaping. This JavaScript will then be executed when the saved page is viewed or previewed.
5 CVE-2021-24205 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the icon box widget (includes/widgets/icon-box.php) accepts a ‘title_size’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request containing JavaScript in the ‘title_size’ parameter, which is not filtered and is output without escaping. This JavaScript will then be executed when the saved page is viewed or previewed.
6 CVE-2021-24204 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the accordion widget (includes/widgets/accordion.php) accepts a ‘title_html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request containing JavaScript in the ‘title_html_tag’ parameter, which is not filtered and is output without escaping. This JavaScript will then be executed when the saved page is viewed or previewed.
7 CVE-2021-24203 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the divider widget (includes/widgets/divider.php) accepts an ‘html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request with this parameter set to ‘script’ and combined with a ‘text’ parameter containing JavaScript, which will then be executed when the saved page is viewed or previewed.
8 CVE-2021-24202 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the heading widget (includes/widgets/heading.php) accepts a ‘header_size’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request with this parameter set to ‘script’ and combined with a ‘title’ parameter containing JavaScript, which will then be executed when the saved page is viewed or previewed.
9 CVE-2021-24201 79 XSS 2021-04-05 2021-04-09
3.5
None Remote Medium ??? None Partial None
In the Elementor Website Builder WordPress plugin before 3.1.4, the column element (includes/elements/column.php) accepts an ‘html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request containing JavaScript in the ‘html_tag’ parameter, which is not filtered and is output without escaping. This JavaScript will then be executed when the saved page is viewed or previewed.
10 CVE-2020-36171 79 XSS 2021-01-06 2021-01-11
4.3
None Remote Medium Not required None Partial None
The Elementor Website Builder plugin before 3.0.14 for WordPress does not properly restrict SVG uploads.
11 CVE-2020-20634 732 2020-08-21 2021-07-21
4.0
None Remote Low ??? None Partial None
Elementor 2.9.5 and below WordPress plugin allows authenticated users to activate its safe mode feature. This can be exploited to disable all security plugins on the blog.
12 CVE-2020-20406 79 XSS 2020-09-16 2020-09-18
3.5
None Remote Medium ??? None Partial None
A stored XSS vulnerability exists in the Custom Link Attributes control Affect function in Elementor Page Builder 2.9.2 and earlier versions. It is caused by inadequate filtering on the link custom attributes.
13 CVE-2020-15020 79 XSS 2020-08-31 2020-09-04
3.5
None Remote Medium ??? None Partial None
An issue was discovered in the Elementor plugin through 2.9.13 for WordPress. An authenticated attacker can achieve stored XSS via the Name Your Template field.
14 CVE-2020-13865 79 XSS 2020-06-05 2020-06-09
3.5
None Remote Medium ??? None Partial None
The Elementor Page Builder plugin before 2.9.9 for WordPress suffers from multiple stored XSS vulnerabilities. An author user can create posts that result in stored XSS vulnerabilities, by using a crafted link in the custom URL or by applying custom attributes.
15 CVE-2020-13864 79 XSS 2020-06-05 2020-06-09
3.5
None Remote Medium ??? None Partial None
The Elementor Page Builder plugin before 2.9.9 for WordPress suffers from a stored XSS vulnerability. An author user can create posts that result in a stored XSS by using a crafted payload in custom links.
16 CVE-2020-13126 434 Exec Code 2020-05-17 2020-05-18
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in the Elementor Pro plugin before 2.9.4 for WordPress, as exploited in the wild in May 2020 in conjunction with CVE-2020-13125. An attacker with the Subscriber role can upload arbitrary executable files to achieve remote code execution. NOTE: the free Elementor plugin is unaffected.
17 CVE-2020-8426 79 XSS 2020-01-28 2020-01-31
3.5
None Remote Medium ??? None Partial None
The Elementor plugin before 2.8.5 for WordPress suffers from a reflected XSS vulnerability on the elementor-system-info page. These can be exploited by targeting an authenticated user.
18 CVE-2020-7109 2020-01-22 2020-01-24
7.5
None Remote Low Not required Partial Partial Partial
The Elementor Page Builder plugin before 2.8.4 for WordPress does not sanitize data during creation of a new template.
19 CVE-2020-7055 434 Exec Code 2020-04-22 2020-04-28
9.0
None Remote Low ??? Complete Complete Complete
An issue was discovered in Elementor 2.7.4. Arbitrary file upload is possible in the Elementor Import Templates function, allowing an attacker to execute code via a crafted ZIP archive.
20 CVE-2018-18379 79 XSS 2019-10-07 2020-08-25
4.3
None Remote Medium Not required None Partial None
The elementor-edit-template class in wp-admin/customize.php in the Elementor Pro plugin before 2.0.10 for WordPress has XSS.
21 CVE-2017-18596 269 2019-09-10 2020-08-25
6.5
None Remote Low ??? Partial Partial Partial
The elementor plugin before 1.8.0 for WordPress has incorrect access control for internal functions.
Total number of vulnerabilities : 21   Page : 1 (This Page)
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.