Craft is a content management system. This is a potential moderate impact, low complexity privilege escalation vulnerability in Craft starting in 3.x prior to 3.9.6 and 4.x prior to 4.4.16 with certain user permissions setups. This has been fixed in Craft 4.4.16 and Craft 3.9.6. Users should ensure they are running at least those versions.
Max CVSS
8.8
Published
2024-01-03
Updated
2024-01-10
EPSS
0.07%

CVE-2023-41892

Public exploit exists
Craft CMS is a platform for creating digital experiences. This is a high-impact, low-complexity attack vector. Users running Craft installations before 4.4.15 are encouraged to update to at least that version to mitigate the issue. This issue has been fixed in Craft CMS 4.4.15.
Max CVSS
10.0
Published
2023-09-13
Updated
2023-12-22
EPSS
87.49%
Craft is a CMS for creating custom digital experiences on the web and beyond. Bypassing the validatePath function can lead to potential remote code execution. This vulnerability can lead to malicious control of vulnerable systems and data exfiltrations. Although the vulnerability is exploitable only in the authenticated users, configuration with ALLOW_ADMIN_CHANGES=true, there is still a potential security threat (Remote Code Execution). This issue has been patched in version 4.4.15 and version 3.8.15.
Max CVSS
7.2
Published
2023-08-23
Updated
2023-08-29
EPSS
0.13%
An issue was discovered in the Feed Me plugin 4.6.1 for Craft CMS. It allows remote attackers to cause a denial of service (DoS) via crafted strings to Feed-Me Name and Feed-Me URL fields, due to saving a feed using an Asset element type with no volume selected. NOTE: this is not a report about code provided by the Craft CMS product; it is only a report about the Feed Me plugin. NOTE: a third-party report states that commit b5d6ede51848349bd91bc95fec288b6793f15e28 has "nothing to do with security."
Max CVSS
7.5
Published
2024-01-30
Updated
2024-02-06
EPSS
0.09%
Cross Site Scripting (XSS) vulnerability in Craft CMS Audit Plugin before version 3.0.2 allows attackers to execute arbitrary code during user creation.
Max CVSS
5.4
Published
2024-01-30
Updated
2024-02-05
EPSS
0.05%
Craft CMS through 4.4.9 is vulnerable to HTML Injection.
Max CVSS
6.1
Published
2023-06-20
Updated
2023-06-27
EPSS
0.05%
Craft is a CMS for creating custom digital experiences on the web. Cross-site scripting (XSS) can be triggered via the Update Asset Index utility. This issue has been patched in version 4.4.6.
Max CVSS
5.5
Published
2023-05-26
Updated
2023-06-01
EPSS
0.05%
Craft is a CMS for creating custom digital experiences. Cross site scripting (XSS) can be triggered by review volumes. This issue has been fixed in version 4.4.7.
Max CVSS
5.5
Published
2023-05-26
Updated
2023-06-02
EPSS
0.05%
Craft is a CMS for creating custom digital experiences on the web. A malformed RSS feed can deliver an XSS payload. This issue was patched in version 4.4.6.
Max CVSS
6.1
Published
2023-05-27
Updated
2023-06-02
EPSS
0.05%
Craft is a CMS for creating custom digital experiences on the web.The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. This issue was patched in version 4.4.6.
Max CVSS
4.8
Published
2023-05-26
Updated
2023-06-02
EPSS
0.05%
Craft CMS is an open source content management system. In affected versions of Craft CMS an unrestricted file extension may lead to Remote Code Execution. If the name parameter value is not empty string('') in the View.php's doesTemplateExist() -> resolveTemplate() -> _resolveTemplateInternal() -> _resolveTemplate() function, it returns directly without extension verification, so that arbitrary extension files are rendered as twig templates. When attacker with admin privileges on a DEV or an improperly configured STG or PROD environment, they can exploit this vulnerability to remote code execution. Code execution may grant the attacker access to the host operating system. This issue has been addressed in version 4.4.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Max CVSS
7.2
Published
2023-05-19
Updated
2023-05-26
EPSS
0.12%
Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.
Max CVSS
6.1
Published
2023-05-09
Updated
2023-05-16
EPSS
0.05%
** DISPUTED ** CraftCMS version 3.7.59 is vulnerable to Server-Side Template Injection (SSTI). An authenticated attacker can inject Twig Template to User Photo Location field when setting User Photo Location in User Settings, lead to Remote Code Execution. NOTE: the vendor disputes this because only Administrators can add this Twig code, and (by design) Administrators are allowed to do that by default.
Max CVSS
7.2
Published
2023-06-13
Updated
2023-06-28
EPSS
0.14%
CraftCMS 3.7.59 is vulnerable Cross Site Scripting (XSS). An attacker can inject javascript code into Volume Name.
Max CVSS
6.1
Published
2023-04-25
Updated
2023-05-04
EPSS
0.05%
An issue found in CraftCMS v.3.8.1 allows a remote attacker to execute arbitrary code via a crafted script to the Section parameter.
Max CVSS
8.8
Published
2023-05-12
Updated
2023-05-22
EPSS
0.23%
Craft is a platform for creating digital experiences. When you insert a payload inside a label name or instruction of an entry type, an cross-site scripting (XSS) happens in the quick post widget on the admin dashboard. This issue has been fixed in version 4.3.7.
Max CVSS
6.1
Published
2023-03-03
Updated
2023-03-10
EPSS
0.06%
A post-authentication stored cross-site scripting vulnerability exists in Craft CMS versions <= 4.4.11. HTML, including script tags can be injected into field names which, when the field is added to a category or section, will trigger when users visit the Categories or Entries pages respectively.
Max CVSS
5.4
Published
2023-05-26
Updated
2023-06-01
EPSS
0.05%
All Craft CMS versions between 3.0.0 and 3.7.32 disclose password hashes of users who authenticate using their E-Mail address or username in Anti-CSRF-Tokens. Craft CMS uses a cookie called CRAFT_CSRF_TOKEN and a HTML hidden field called CRAFT_CSRF_TOKEN to avoid Cross Site Request Forgery attacks. The CRAFT_CSRF_TOKEN cookie discloses the password hash in without encoding it whereas the corresponding HTML hidden field discloses the users' password hash in a masked manner, which can be decoded by using public functions of the YII framework.
Max CVSS
7.5
Published
2022-12-05
Updated
2023-02-16
EPSS
0.15%
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via Drafts.
Max CVSS
5.4
Published
2022-09-16
Updated
2022-09-21
EPSS
0.05%
Craft CMS 4.2.0.1 suffers from Stored Cross Site Scripting (XSS) in /admin/myaccount.
Max CVSS
5.4
Published
2022-09-16
Updated
2022-09-17
EPSS
0.05%
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
Max CVSS
5.4
Published
2022-09-16
Updated
2022-09-17
EPSS
0.05%
Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.
Max CVSS
5.4
Published
2022-09-16
Updated
2022-09-21
EPSS
0.05%
Craft CMS 4.2.0.1 is affected by Cross Site Scripting (XSS) in the file src/web/assets/cp/src/js/BaseElementSelectInput.js and in specific on the line label: elementInfo.label.
Max CVSS
5.4
Published
2022-09-21
Updated
2022-09-22
EPSS
0.05%
Craft CMS through 3.7.36 allows a remote unauthenticated attacker, who knows at least one valid username, to reset the account's password and take over the account by providing a crafted HTTP header to the application while using the password reset functionality. Specifically, the attacker must send X-Forwarded-Host to the /index.php?p=admin/actions/users/send-password-reset-email URI. NOTE: the vendor's position is that a customer can already work around this by adjusting the configuration (i.e., by not using the default configuration).
Max CVSS
8.8
Published
2022-05-09
Updated
2022-05-18
EPSS
0.70%
Craft CMS before 3.7.29 allows XSS.
Max CVSS
6.1
Published
2022-04-03
Updated
2022-04-11
EPSS
0.07%
44 vulnerabilities found
1 2
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!