CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Apple » Mac Os X : Security Vulnerabilities (Execute Code)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
851 CVE-2006-3498 Exec Code Overflow 2006-08-02 2017-07-19
10.0
Admin Remote Low Not required Complete Complete Complete
Stack-based buffer overflow in bootpd in the DHCP component for Apple Mac OS X 10.3.9 and 10.4.7 allows remote attackers to execute arbitrary code via a crafted BOOTP request.
852 CVE-2006-3497 DoS Exec Code 2006-08-02 2011-04-07
5.1
User Remote High Not required Partial Partial Partial
Unspecified vulnerability in the "compression state handling" in Bom for Apple Mac OS X 10.3.9 and 10.4.7 allows user-assisted attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted Zip archive.
853 CVE-2006-1985 119 Exec Code Overflow 2006-04-21 2017-07-19
5.1
User Remote High Not required Partial Partial Partial
Heap-based buffer overflow in BOM BOMArchiveHelper 10.4 (6.3) Build 312, as used in Mac OS X 10.4.6 and earlier, allows user-assisted attackers to execute arbitrary code via a crafted archive (such as ZIP) that contains long path names, which triggers an error in the BOMStackPop function.
854 CVE-2006-1983 119 DoS Exec Code Overflow 2006-04-21 2017-07-19
6.4
None Remote Low Not required None Partial Partial
Multiple heap-based buffer overflows in Mac OS X 10.4.6 and earlier allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) PredictorVSetField function for TIFF or (2) CFAllocatorAllocate function for GIF, as used in applications that use ImageIO or AppKit. NOTE: the BMP vector has been re-assigned to CVE-2006-2238 because it affects a separate product family.
855 CVE-2006-1982 Exec Code Overflow 2006-04-21 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in the LZWDecodeVector function in Mac OS X before 10.4.6, as used in applications that use ImageIO or AppKit, allows remote attackers to execute arbitrary code via crafted TIFF images.
856 CVE-2006-1473 DoS Exec Code Overflow 2006-08-02 2017-07-19
5.0
None Remote Low Not required None None Partial
Integer overflow in AFP Server for Apple Mac OS X 10.3.9 and 10.4.7 allows remote attackers to cause a denial of service (crash) and execute arbitrary code via unknown vectors.
857 CVE-2006-1471 134 Exec Code 2006-06-27 2018-10-18
4.6
User Local Low Not required Partial Partial Partial
Format string vulnerability in the CF_syslog function launchd in Apple Mac OS X 10.4 up to 10.4.6 allows local users to execute arbitrary code via format string specifiers that are not properly handled in a syslog call in the logging facility, as demonstrated by using a crafted plist file.
858 CVE-2006-1469 119 DoS Exec Code Overflow 2006-06-27 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
Stack-based buffer overflow in ImageIO in Apple Mac OS X 10.4 up to 10.4.6 allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TIFF image.
859 CVE-2006-1456 Exec Code Overflow 2006-05-12 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in QuickTime Streaming Server in Apple Mac OS X 10.3.9 and 10.4.6 allows remote attackers to execute arbitrary code via a crafted RTSP request, which is not properly handled during message logging.
860 CVE-2006-1452 Exec Code Overflow 2006-05-12 2017-07-19
4.6
User Local Low Not required Partial Partial Partial
Stack-based buffer overflow in Preview in Apple Mac OS 10.4 up to 10.4.6 allows local users to execute arbitrary code via a deep directory hierarchy.
861 CVE-2006-1450 Exec Code 2006-05-12 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
Mail in Apple Mac OS X 10.3.9 and 10.4.6 allows remote attackers to execute arbitrary code via an enriched text e-mail message with "invalid color information" that causes Mail to allocate and initialize arbitrary classes.
862 CVE-2006-1449 Exec Code Overflow 2006-05-12 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
Integer overflow in Mail in Apple Mac OS X 10.3.9 and 10.4.6 allows remote attackers to execute arbitrary code via a crafted MacMIME encapsulated attachment.
863 CVE-2006-1448 Exec Code 2006-05-12 2017-07-19
6.5
User Remote Low Single system Partial Partial Partial
Finder in Apple Mac OS X 10.3.9 and 10.4.6 allows user-assisted attackers to execute arbitrary code by tricking a user into launching an Internet Location item that appears to use a safe URL scheme, but which actually has a different and more risky scheme.
864 CVE-2006-1445 Exec Code Overflow 2006-05-12 2017-07-19
6.5
User Remote Low Single system Partial Partial Partial
Buffer overflow in the FTP server (FTPServer) in Apple Mac OS X 10.3.9 and 10.4.6 allows remote authenticated users to execute arbitrary code via vectors related to "FTP server path name handling."
865 CVE-2006-1443 Exec Code 2006-05-12 2017-07-19
6.5
User Remote Low Single system Partial Partial Partial
Integer underflow in CoreFoundation in Apple Mac OS X 10.3.9 and 10.4.6 allows context-dependent attackers to execute arbitrary code via unspecified vectors involving conversions from string to file system representation within (1) CFStringGetFileSystemRepresentation or (2) getFileSystemRepresentation:maxLength:withPath in NSFileManager, and possibly other similar API functions.
866 CVE-2006-1442 Exec Code 2006-05-12 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
The bundle API in CoreFoundation in Apple Mac OS X 10.3.9 and 10.4.6 loads dynamic libraries even if the client application has not directly requested it, which allows attackers to execute arbitrary code from an untrusted bundle.
867 CVE-2006-1441 Exec Code Overflow 2006-05-12 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
Integer overflow in CFNetwork in Apple Mac OS X 10.4.6 allows remote attackers to execute arbitrary code via crafted chunked transfer encoding.
868 CVE-2006-1220 Exec Code Overflow 2006-03-13 2013-09-06
4.6
User Local Low Not required Partial Partial Partial
Integer overflow in the mach_msg_send function in the kernel for Mac OS X might allow local users to execute arbitrary code via unknown attack vectors related to a large message header size, which leads to a heap-based buffer overflow.
869 CVE-2006-0848 16 Exec Code 2006-02-22 2017-07-19
5.1
User Remote High Not required Partial Partial Partial
The "Open 'safe' files after downloading" option in Safari on Apple Mac OS X allows remote user-assisted attackers to execute arbitrary commands by tricking a user into downloading a __MACOSX folder that contains metadata (resource fork) that invokes the Terminal, which automatically interprets the script using bash, as demonstrated using a ZIP file that contains a script with a safe file extension.
870 CVE-2006-0396 Exec Code Overflow 2006-03-14 2018-10-19
5.1
User Remote High Not required Partial Partial Partial
Buffer overflow in Mail in Apple Mac OS X 10.4 up to 10.4.5, when patched with Security Update 2006-001, allows remote attackers to execute arbitrary code via a long Real Name value in an e-mail attachment sent in AppleDouble format, which triggers the overflow when the user double-clicks on an attachment.
871 CVE-2006-0395 Exec Code 2006-08-04 2017-07-19
5.1
User Remote High Not required Partial Partial Partial
The Download Validation in Mail in Mac OS X 10.4 does not properly recognize attachment file types to warn a user of an unsafe type, which allows user-assisted remote attackers to execute arbitrary code via crafted file types.
872 CVE-2006-0392 DoS Exec Code Overflow 2006-08-02 2017-07-19
5.1
User Remote High Not required Partial Partial Partial
Buffer overflow in Apple Mac OS X 10.4.7 allows user-assisted attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted Canon RAW image.
873 CVE-2006-0387 Exec Code Overflow 2006-03-06 2017-07-19
6.4
None Remote Low Not required None Partial Partial
Stack-based buffer overflow in Safari in Mac OS X 10.4.5 and earlier, and 10.3.9 and earlier, allows remote attackers to execute arbitrary code via unspecified vectors involving a web page with crafted JavaScript, a different vulnerability than CVE-2005-4504.
874 CVE-2006-0384 DoS Exec Code 2006-03-02 2017-07-19
7.5
User Remote Low Not required Partial Partial Partial
automount in Mac OS X 10.4.5 and earlier allows remote file servers to cause a denial of service (unresponsiveness) or execute arbitrary code via unspecified vectors that cause automount to "mount file systems with reserved names".
875 CVE-2005-3712 119 Exec Code Overflow 2005-12-31 2017-07-10
6.5
None Remote Low Single system Partial Partial Partial
Heap-based buffer overflow in rsync in Mac OS X 10.4 through 10.4.5 allows remote authenticated users to execute arbitrary code via long extended attributes.
876 CVE-2005-3706 Exec Code Overflow 2005-12-31 2017-07-10
6.4
None Remote Low Not required None Partial Partial
Heap-based buffer overflow in LibSystem in Mac OS X 10.4 through 10.4.5 allows context-dependent attackers to execute arbitrary code by causing an application that uses LibSystem to request a large amount of memory.
877 CVE-2005-3705 Exec Code Overflow 2005-11-30 2017-07-10
7.5
User Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in WebKit in Mac OS X and OS X Server 10.3.9 and 10.4.3, as used in applications such as Safari, allows remote attackers to execute arbitrary code via unknown attack vectors.
878 CVE-2005-3700 Exec Code 2005-11-30 2017-07-10
4.6
User Local Low Not required Partial Partial Partial
Unknown vulnerability in iodbcadmintool in the ODBC Administrator utility in Mac OS X and OS X Server 10.3.9 and 10.4.3 allows local users to execute arbitrary code via unknown attack vectors.
879 CVE-2005-2757 Exec Code Overflow 2005-11-30 2017-07-10
7.5
User Remote Low Not required Partial Partial Partial
Heap-based buffer overflow in CoreFoundation in Mac OS X and OS X Server 10.4 through 10.4.3 allows remote attackers to execute arbitrary code via unknown attack vectors involving "validation of URLs."
880 CVE-2005-2747 Exec Code Overflow 2005-10-25 2017-07-10
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in ImageIO for Apple Mac OS X 10.4.2, as used by applications such as WebCore and Safari, allows remote attackers to execute arbitrary code via a crafted GIF file.
881 CVE-2005-2744 Exec Code Overflow 2005-10-25 2017-07-10
5.1
User Remote High Not required Partial Partial Partial
Buffer overflow in QuickDraw Manager for Apple OS X 10.3.9 and 10.4.2, as used by applications such as Safari, Mail, and Finder, allows remote attackers to execute arbitrary code via a crafted PICT file.
882 CVE-2005-2743 Exec Code 2005-10-25 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
The Java extensions for QuickTime 6.52 and earlier in Apple Mac OS X 10.3.9 allow untrusted applets to call arbitrary functions in system libraries, which allows remote attackers to execute arbitrary code.
883 CVE-2005-2522 Exec Code 2005-08-19 2008-09-05
5.1
User Remote High Not required Partial Partial Partial
Safari in WebKit in Mac OS X 10.4 to 10.4.2 directly accesses URLs within PDF files without the normal security checks, which allows remote attackers to execute arbitrary code via links in a PDF file.
884 CVE-2005-2521 Exec Code Overflow 2005-08-19 2008-09-05
4.6
User Local Low Not required Partial Partial Partial
Buffer overflow in traceroute in Mac OS X 10.3.9 allows local users to execute arbitrary code via unknown vectors.
885 CVE-2005-2518 Exec Code Overflow 2005-08-19 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in servermgrd in Mac OS X 10.3.9 and 10.4.2 allows remote attackers to execute arbitrary code during authentication.
886 CVE-2005-2516 Exec Code 2005-08-19 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Safari in Mac OS X 10.3.9 and 10.4.2, when rendering Rich Text Format (RTF) files, can directly access URLs without performing the normal security checks, which allows remote attackers to execute arbitrary commands.
887 CVE-2005-2514 Exec Code Overflow 2005-08-19 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in ping in Mac OS X 10.3.9 allows local users to execute arbitrary code.
888 CVE-2005-2505 Exec Code Overflow 2005-08-19 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in CoreFoundation in Mac OS X 10.3.9 allows attackers to execute arbitrary code via command line arguments to an application that uses CoreFoundation.
889 CVE-2005-2502 Exec Code Overflow 2005-08-19 2008-09-10
5.1
User Remote High Not required Partial Partial Partial
Buffer overflow in AppKit for Mac OS X 10.3.9 and 10.4.2, as used in applications such as TextEdit, allows external user-assisted attackers to execute arbitrary code via a crafted Microsoft Word file.
890 CVE-2005-2501 Exec Code Overflow 2005-08-19 2008-09-05
7.6
Admin Remote High Not required Complete Complete Complete
Buffer overflow in AppKit for Mac OS X 10.3.9 and 10.4.2 allows external user-assisted attackers to execute arbitrary code via a crafted Rich Text Format (RTF) file.
891 CVE-2005-1933 Exec Code 2005-06-13 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
Dashboard in Apple Mac OS X Tiger 10.4 allows attackers to execute arbitrary commands by overriding the behavior of system widgets via a user widget with the same bundle identifier (CFBundleIdentifier), a different vulnerability than CVE-2005-1474.
892 CVE-2005-1343 Exec Code Overflow 2005-05-03 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Stack-based buffer overflow in the VPN daemon (vpnd) for Mac OS X before 10.3.9 allows local users to execute arbitrary code via a long -i (Server_id) argument.
893 CVE-2005-1342 Exec Code 2005-05-04 2008-09-05
7.5
User Remote Low Not required Partial Partial Partial
The x-man-page: URI handler for Apple Terminal 1.4.4 in Mac OS X 10.3.9 does not cleanse terminal escape sequences, which allows remote attackers to execute arbitrary commands.
894 CVE-2005-1341 Exec Code 2005-05-04 2008-09-05
5.1
User Remote High Not required Partial Partial Partial
Apple Terminal 1.4.4 allows attackers to execute arbitrary commands via terminal escape sequences.
895 CVE-2005-1336 Exec Code Overflow 2005-05-04 2008-09-05
4.6
None Local Low Not required Partial Partial Partial
Buffer overflow in the Foundation framework for Mac OS X 10.3.9 allows local users to execute arbitrary code via a long environment variable.
896 CVE-2005-1307 Exec Code 2005-05-17 2017-07-10
7.2
Admin Local Low Not required Complete Complete Complete
The (1) stopserver.sh and (2) startserver.sh scripts in Adobe Version Cue on Mac OS X uses the current working directory to find and execute the productname.sh script, which allows local users to execute arbitrary code by copying and calling the scripts from a user-controlled directory.
897 CVE-2005-0972 Exec Code Overflow 2005-05-12 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Integer overflow in the searchfs system call in Mac OS X 10.3.9 and earlier allows local users to execute arbitrary code via crafted parameters.
898 CVE-2005-0969 DoS Exec Code Overflow 2005-05-12 2008-09-05
4.6
User Local Low Not required Partial Partial Partial
Heap-based buffer overflow in the syscall emulation functionality in Mac OS X before 10.3.9 allows local users to cause a denial of service (kernel panic) and possibly execute arbitrary code via crafted parameters.
899 CVE-2005-0716 Exec Code Overflow 2005-03-21 2008-09-05
7.2
Admin Local Low Not required Complete Complete Complete
Stack-based buffer overflow in the Core Foundation Library in Mac OS X 10.3.5 and 10.3.6, and possibly earlier versions, allows local users to execute arbitrary code via a long CF_CHARSET_PATH environment variable.
900 CVE-2005-0373 Exec Code Overflow 2004-10-07 2017-07-10
7.5
User Remote Low Not required Partial Partial Partial
Buffer overflow in digestmd5.c CVS release 1.170 (also referred to as digestmda5.c), as used in the DIGEST-MD5 SASL plugin for Cyrus-SASL but not in any official releases, allows remote attackers to execute arbitrary code.
Total number of vulnerabilities : 923   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 (This Page)19
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.