CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Debian » Debian Linux » 8.0 : Security Vulnerabilities Published In 2018

Cpe Name:cpe:/o:debian:debian_linux:8.0
Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
651 CVE-2017-17485 502 Exec Code Bypass 2018-01-10 2019-09-26
7.5
None Remote Low Not required Partial Partial Partial
FasterXML jackson-databind through 2.8.10 and 2.9.x through 2.9.3 allows unauthenticated remote code execution because of an incomplete fix for the CVE-2017-7525 deserialization flaw. This is exploitable by sending maliciously crafted JSON input to the readValue method of the ObjectMapper, bypassing a blacklist that is ineffective if the Spring libraries are available in the classpath.
652 CVE-2017-15715 20 2018-03-26 2019-08-15
6.8
None Remote Medium Not required Partial Partial Partial
In Apache httpd 2.4.0 to 2.4.29, the expression specified in <FilesMatch> could match '$' to a newline character in a malicious filename, rather than matching only the end of the filename. This could be exploited in environments where uploads of some files are are externally blocked, but only by matching the trailing portion of the filename.
653 CVE-2017-15710 787 DoS 2018-03-26 2019-08-15
5.0
None Remote Low Not required None None Partial
In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29, mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the Accept-Language header value to lookup the right charset encoding when verifying the user's credentials. If the header value is not present in the charset conversion table, a fallback mechanism is used to truncate it to a two characters value to allow a quick retry (for example, 'en-US' is truncated to 'en'). A header value of less than two characters forces an out of bound write of one NUL byte to a memory location that is not part of the string. In the worst case, quite unlikely, the process would crash which could be used as a Denial of Service attack. In the more likely case, this memory is already reserved for future use and the issue has no effect at all.
654 CVE-2017-15705 20 DoS 2018-09-17 2018-12-16
5.0
None Remote Low Not required None None Partial
A denial of service vulnerability was identified that exists in Apache SpamAssassin before 3.4.2. The vulnerability arises with certain unclosed tags in emails that cause markup to be handled incorrectly leading to scan timeouts. In Apache SpamAssassin, using HTML::Parser, we setup an object and hook into the begin and end tag event handlers In both cases, the "open" event is immediately followed by a "close" event - even if the tag *does not* close in the HTML being parsed. Because of this, we are missing the "text" event to deal with the object normally. This can cause carefully crafted emails that might take more scan time than expected leading to a Denial of Service. The issue is possibly a bug or design decision in HTML::Parser that specifically impacts the way Apache SpamAssassin uses the module with poorly formed html. The exploit has been seen in the wild but not believed to have been purposefully part of a Denial of Service attempt. We are concerned that there may be attempts to abuse the vulnerability in the future.
655 CVE-2017-15698 295 2018-01-31 2018-06-14
4.3
None Remote Medium Not required None Partial None
When parsing the AIA-Extension field of a client certificate, Apache Tomcat Native Connector 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 did not correctly handle fields longer than 127 bytes. The result of the parsing error was to skip the OCSP check. It was therefore possible for client certificates that should have been rejected (if the OCSP check had been made) to be accepted. Users not using OCSP checks are not affected by this vulnerability.
656 CVE-2017-15429 79 XSS 2018-08-28 2018-11-07
4.3
None Remote Medium Not required None Partial None
Inappropriate implementation in V8 WebAssembly JS bindings in Google Chrome prior to 63.0.3239.108 allowed a remote attacker to inject arbitrary scripts or HTML (UXSS) via a crafted HTML page.
657 CVE-2017-15422 190 Overflow 2018-08-28 2018-11-07
4.3
None Remote Medium Not required None None Partial
Integer overflow in international date handling in International Components for Unicode (ICU) for C/C++ before 60.1, as used in V8 in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to perform an out of bounds memory read via a crafted HTML page.
658 CVE-2017-15420 20 2018-08-28 2019-01-09
4.3
None Remote Medium Not required None Partial None
Incorrect handling of back navigations in error pages in Navigation in Google Chrome prior to 63.0.3239.84 allowed a remote attacker to spoof the contents of the Omnibox (URL bar) via a crafted HTML page.
659 CVE-2017-15412 416 2018-08-28 2018-10-25
6.8
None Remote Medium Not required Partial Partial Partial
Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
660 CVE-2017-15399 416 2018-08-28 2018-11-07
9.3
None Remote Medium Not required Complete Complete Complete
A use after free in V8 in Google Chrome prior to 62.0.3202.89 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
661 CVE-2017-15398 119 Exec Code Overflow 2018-08-28 2018-11-07
7.5
None Remote Low Not required Partial Partial Partial
A stack buffer overflow in the QUIC networking stack in Google Chrome prior to 62.0.3202.89 allowed a remote attacker to gain code execution via a malicious server.
662 CVE-2017-15396 119 Overflow 2018-08-28 2018-11-07
4.3
None Remote Medium Not required None None Partial
A stack buffer overflow in NumberingSystem in International Components for Unicode (ICU) for C/C++ before 60.2, as used in V8 in Google Chrome prior to 62.0.3202.75 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
663 CVE-2017-15395 416 2018-02-07 2018-02-23
4.3
None Remote Medium Not required None None Partial
A use after free in Blink in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page, aka an ImageCapture NULL pointer dereference.
664 CVE-2017-15394 20 2018-02-07 2018-02-23
4.3
None Remote Medium Not required None Partial None
Insufficient Policy Enforcement in Extensions in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to perform domain spoofing in permission dialogs via IDN homographs in a crafted Chrome Extension.
665 CVE-2017-15393 668 2018-02-07 2019-10-02
6.8
None Remote Medium Not required Partial Partial Partial
Insufficient Policy Enforcement in Devtools remote debugging in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to obtain access to remote debugging functionality via a crafted HTML page, aka a Referer leak.
666 CVE-2017-15392 20 2018-02-07 2018-02-23
4.0
None Remote Low Single system None Partial None
Insufficient data validation in V8 in Google Chrome prior to 62.0.3202.62 allowed an attacker who can write to the Windows Registry to potentially exploit heap corruption via a crafted Windows Registry entry, related to PlatformIntegration.
667 CVE-2017-15391 2018-02-07 2019-10-02
4.3
None Remote Medium Not required None Partial None
Insufficient Policy Enforcement in Extensions in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to access Extension pages without authorisation via a crafted HTML page.
668 CVE-2017-15390 20 2018-02-07 2018-02-23
4.3
None Remote Medium Not required None Partial None
Insufficient Policy Enforcement in Omnibox in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to perform domain spoofing via IDN homographs in a crafted domain name.
669 CVE-2017-15389 20 2018-02-07 2018-02-22
4.3
None Remote Medium Not required None Partial None
An insufficient watchdog timer in navigation in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to spoof the contents of the Omnibox (URL bar) via a crafted HTML page.
670 CVE-2017-15388 125 2018-02-07 2018-02-22
6.8
None Remote Medium Not required Partial Partial Partial
Iteration through non-finite points in Skia in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to perform an out of bounds memory read via a crafted HTML page.
671 CVE-2017-15387 2018-02-07 2019-10-02
6.8
None Remote Medium Not required Partial Partial Partial
Insufficient enforcement of Content Security Policy in Blink in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to open javascript: URL windows when they should not be allowed to via a crafted HTML page.
672 CVE-2017-15386 20 2018-02-07 2018-02-23
4.3
None Remote Medium Not required None Partial None
Incorrect implementation in Blink in Google Chrome prior to 62.0.3202.62 allowed a remote attacker to spoof the contents of the Omnibox (URL bar) via a crafted HTML page.
673 CVE-2017-15132 772 2018-01-25 2019-10-09
5.0
None Remote Low Not required None None Partial
A flaw was found in dovecot 2.0 up to 2.2.33 and 2.3.0. An abort of SASL authentication results in a memory leak in dovecot's auth client used by login processes. The leak has impact in high performance configuration where same login processes are reused and can cause the process to crash due to memory exhaustion.
674 CVE-2017-15130 DoS 2018-03-02 2019-10-02
4.3
None Remote Medium Not required None None Partial
A denial of service flaw was found in dovecot before 2.2.34. An attacker able to generate random SNI server names could exploit TLS SNI configuration lookups, leading to excessive memory usage and the process to restart.
675 CVE-2017-15120 476 DoS 2018-07-27 2019-10-09
5.0
None Remote Low Not required None None Partial
An issue has been found in the parsing of authoritative answers in PowerDNS Recursor before 4.0.8, leading to a NULL pointer dereference when parsing a specially crafted answer containing a CNAME of a different class than IN. An unauthenticated remote attacker could cause a denial of service.
676 CVE-2017-15105 20 2018-01-23 2019-10-09
5.0
None Remote Low Not required None Partial None
A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound into accepting a NODATA proof.
677 CVE-2017-15095 502 Exec Code 2018-02-06 2019-09-26
7.5
None Remote Low Not required Partial Partial Partial
A deserialization flaw was discovered in the jackson-databind in versions before 2.8.10 and 2.9.1, which could allow an unauthenticated user to perform code execution by sending the maliciously crafted input to the readValue method of the ObjectMapper. This issue extends the previous flaw CVE-2017-7525 by blacklisting more classes that could be used maliciously.
678 CVE-2017-14461 125 DoS 2018-03-02 2018-04-03
5.5
None Remote Low Single system Partial None Partial
A specially crafted email delivered over SMTP and passed on to Dovecot by MTA can trigger an out of bounds read resulting in potential sensitive information disclosure and denial of service. In order to trigger this vulnerability, an attacker needs to send a specially crafted email message to the server.
679 CVE-2017-14450 119 Overflow 2018-04-24 2019-03-28
5.8
None Remote Medium Not required None Partial Partial
A buffer overflow vulnerability exists in the GIF image parsing functionality of SDL2_image-2.0.2. A specially crafted GIF image can lead to a buffer overflow on a global section. An attacker can display an image to trigger this vulnerability.
680 CVE-2017-14449 415 2018-04-24 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
A double-Free vulnerability exists in the XCF image rendering functionality of SDL2_image-2.0.2. A specially crafted XCF image can cause a Double-Free situation to occur. An attacker can display a specially crafted image to trigger this vulnerability.
681 CVE-2017-14448 119 Exec Code Overflow 2018-04-24 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable code execution vulnerability exists in the XCF image rendering functionality of SDL2_image-2.0.2. A specially crafted XCF image can cause a heap overflow resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.
682 CVE-2017-14442 119 Exec Code Overflow 2018-04-24 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable code execution vulnerability exists in the BMP image rendering functionality of SDL2_image-2.0.2. A specially crafted BMP image can cause a stack overflow resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.
683 CVE-2017-14441 190 Exec Code Overflow 2018-04-24 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable code execution vulnerability exists in the ICO image rendering functionality of SDL2_image-2.0.2. A specially crafted ICO image can cause an integer overflow, cascading to a heap overflow resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.
684 CVE-2017-14440 119 Exec Code Overflow 2018-04-24 2019-03-28
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable code execution vulnerability exists in the ILBM image rendering functionality of SDL2_image-2.0.2. A specially crafted ILBM image can cause a stack overflow resulting in code execution. An attacker can display a specially crafted image to trigger this vulnerability.
685 CVE-2017-13305 125 2018-04-04 2019-10-02
3.6
None Local Low Not required Partial None Partial
A information disclosure vulnerability in the Upstream kernel encrypted-keys. Product: Android. Versions: Android kernel. Android ID: A-70526974.
686 CVE-2017-13194 20 2018-01-12 2019-05-06
7.8
None Remote Low Not required None None Complete
A vulnerability in the Android media framework (libvpx) related to odd frame width. Product: Android. Versions: 7.0, 7.1.1, 7.1.2, 8.0, 8.1. Android ID: A-64710201.
687 CVE-2017-12197 20 Bypass 2018-01-18 2019-10-09
4.0
None Remote Low Single system Partial None None
It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.
688 CVE-2017-12187 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in RENDER extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
689 CVE-2017-12186 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in X-Resource extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
690 CVE-2017-12185 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in MIT-SCREEN-SAVER extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
691 CVE-2017-12184 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in XINERAMA extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
692 CVE-2017-12183 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in XFIXES extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
693 CVE-2017-12182 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in XFree86 DRI extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
694 CVE-2017-12181 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in XFree86 DGA extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
695 CVE-2017-12180 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing length validation in XFree86 VidModeExtension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
696 CVE-2017-12179 190 Exec Code Overflow 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was vulnerable to integer overflow in (S)ProcXIBarrierReleasePointer functions allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
697 CVE-2017-12178 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 had wrong extra length check in ProcXIChangeHierarchy function allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
698 CVE-2017-12177 190 Exec Code Overflow 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was vulnerable to integer overflow in ProcDbeGetVisualInfo function allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
699 CVE-2017-12176 20 Exec Code 2018-01-24 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
xorg-x11-server before 1.19.5 was missing extra length validation in ProcEstablishConnection function allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
700 CVE-2017-12163 200 +Info 2018-07-26 2019-10-09
4.8
None Local Network Low Not required Partial Partial None
An information leak flaw was found in the way SMB1 protocol was implemented by Samba before 4.4.16, 4.5.x before 4.5.14, and 4.6.x before 4.6.8. A malicious client could use this flaw to dump server memory contents to a file on the samba share or to a shared printer, though the exact area of server memory cannot be controlled by the attacker.
Total number of vulnerabilities : 862   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 (This Page)15 16 17 18
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.