CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 6 and 6.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
4001 CVE-2019-18191 459 2019-12-16 2020-08-24
6.5
None Remote Low ??? Partial Partial Partial
A privilege escalation vulnerability in the Trend Micro Deep Security as a Service Quick Setup cloud formation template could allow an authenticated entity with certain unrestricted AWS execution privileges to escalate to full privileges within the target AWS account.
4002 CVE-2019-18183 78 2020-02-24 2020-08-24
6.8
None Remote Medium Not required Partial Partial Partial
pacman before 5.2 is vulnerable to arbitrary command injection in lib/libalpm/sync.c in the apply_deltas() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable the non-default delta feature and retrieve an attacker-controlled crafted database and delta file.
4003 CVE-2019-18182 78 2020-02-24 2020-08-24
6.8
None Remote Medium Not required Partial Partial Partial
pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.
4004 CVE-2019-17676 352 CSRF 2019-10-17 2019-10-21
6.8
None Remote Medium Not required Partial Partial Partial
app/system/admin/admin/index.class.php in MetInfo 7.0.0beta allows a CSRF attack to add a user account via a doSaveSetup action to admin/index.php, as demonstrated by an admin/?n=admin&c=index&a=doSaveSetup URI.
4005 CVE-2019-17675 352 CSRF 2019-10-17 2019-11-05
6.8
None Remote Medium Not required Partial Partial Partial
WordPress before 5.2.4 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
4006 CVE-2019-17654 345 2020-03-15 2020-03-19
6.8
None Remote Medium Not required Partial Partial Partial
An Insufficient Verification of Data Authenticity vulnerability in FortiManager 6.2.1, 6.2.0, 6.0.6 and below may allow an unauthenticated attacker to perform a Cross-Site WebSocket Hijacking (CSWSH) attack.
4007 CVE-2019-17653 352 CSRF 2020-03-12 2020-03-18
6.8
None Remote Medium Not required Partial Partial Partial
A Cross-Site Request Forgery (CSRF) vulnerability in the user interface of Fortinet FortiSIEM 5.2.5 could allow a remote, unauthenticated attacker to perform arbitrary actions using an authenticated user's session by persuading the victim to follow a malicious link.
4008 CVE-2019-17652 787 Overflow 2020-02-06 2020-02-12
6.8
None Remote Low ??? None None Complete
A stack buffer overflow vulnerability in FortiClient for Linux 6.2.1 and below may allow a user with low privilege to cause FortiClient processes running under root priviledge crashes via sending specially crafted "StartAvCustomScan" type IPC client requests to the fctsched process due the argv data not been well sanitized.
4009 CVE-2019-17642 352 Exec Code CSRF 2020-03-05 2020-08-24
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in Centreon before 18.10.8, 19.10.1, and 19.04.2. It allows CSRF with resultant remote command execution via shell metacharacters in a POST to centreon-autodiscovery-server/views/scan/ajax/call.php in the Autodiscovery plugin.
4010 CVE-2019-17635 502 Exec Code 2020-01-17 2020-01-23
6.8
None Remote Medium Not required Partial Partial Partial
Eclipse Memory Analyzer version 1.9.1 and earlier is subject to a deserialization vulnerability if an index file of a parsed heap dump is replaced by a malicious version and the heap dump is reopened in Memory Analyzer. The user must chose to reopen an already parsed heap dump with an untrusted index for the problem to occur. The problem can be averted if the index files from an untrusted source are deleted and the heap dump is opened and reparsed. Also some local configuration data is subject to a deserialization vulnerability if the local data were to be replaced with a malicious version. This can be averted if the local configuration data stored on the file system cannot be changed by an attacker. The vulnerability could possibly allow code execution on the local system.
4011 CVE-2019-17633 352 2019-12-19 2019-12-27
6.8
None Remote Medium Not required Partial Partial Partial
For Eclipse Che versions 6.16 to 7.3.0, with both authentication and TLS disabled, visiting a malicious web site could trigger the start of an arbitrary Che workspace. Che with no authentication and no TLS is not usually deployed on a public network but is often used for local installations (e.g. on personal laptops). In that case, even if the Che API is not exposed externally, some javascript running in the local browser is able to send requests to it.
4012 CVE-2019-17631 269 2019-10-17 2020-10-16
6.4
None Remote Low Not required None Partial Partial
From Eclipse OpenJ9 0.15 to 0.16, access to diagnostic operations such as causing a GC or creating a diagnostic file are permitted without any privilege checks.
4013 CVE-2019-17612 89 Sql 2019-10-15 2019-10-17
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in 74CMS v5.2.8. There is a SQL Injection generated by the _list method in the Common/Controller/BackendController.class.php file via the index.php?m=Admin&c=Ad&a=category sort parameter.
4014 CVE-2019-17605 639 2019-11-07 2020-08-24
6.5
None Remote Low ??? Partial Partial Partial
A mass assignment vulnerability in eyecomms eyeCMS through 2019-10-15 allows any candidate to take over another candidate's account (by also exploiting CVE-2019-17604) via a modified candidate id and an additional password parameter. The outcome is that the password of this other candidate is changed.
4015 CVE-2019-17593 352 CSRF 2019-10-14 2019-10-16
6.8
None Remote Medium Not required Partial Partial Partial
JIZHICMS 1.5.1 allows admin.php/Admin/adminadd.html CSRF to add an administrator.
4016 CVE-2019-17590 352 Bypass CSRF 2019-11-26 2020-02-25
6.8
None Remote Medium Not required Partial Partial Partial
** DISPUTED ** The csrf_callback function in the CSRF Magic library through 2016-03-27 is vulnerable to CSRF protection bypass as it allows one to tamper with the csrf token values. A remote attacker can exploit this by crafting a malicious page and dispersing it to a victim via social engineering, enticing them to click the link. Once the user/victim clicks the "try again" button, the attacker can take over the account and perform unintended actions on the victim's behalf. NOTE: A third-party maintainer has stated that this CVE is a false report. They state that the csrf_callback function is actually a callback function to the callers own handler for output. The function called can be changed via configuration to a custom callback to handle failed validation differently. They also stated that there is no way for an attacker to change tokens to make them valid from the client side. The only thing an attack can do is to pull the token out of the javascript, but that will always be possible and has nothing to do with the callback.
4017 CVE-2019-17575 94 Exec Code Bypass 2019-10-14 2019-10-17
6.5
None Remote Low ??? Partial Partial Partial
A file-rename filter bypass exists in admin/media/rename.php in WBCE CMS 1.4.0 and earlier. This can be exploited by an authenticated user with admin privileges to rename a media filename and extension. (For example: place PHP code in a .jpg file, and then change the file's base name to filename.ph and change the file's extension to p. Because of concatenation, the name is then treated as filename.php.) At the result, remote attackers can execute arbitrary PHP code.
4018 CVE-2019-17574 639 2019-10-14 2019-10-18
6.4
None Remote Low Not required Partial Partial None
An issue was discovered in the Popup Maker plugin before 1.8.13 for WordPress. An unauthenticated attacker can partially control the arguments of the do_action function to invoke certain popmake_ or pum_ methods, as demonstrated by controlling content and delivery of popmake-system-info.txt (aka the "support debug text file").
4019 CVE-2019-17564 502 2020-04-01 2021-03-30
6.8
None Remote Medium Not required Partial Partial Partial
Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.
4020 CVE-2019-17560 295 2020-03-30 2020-07-15
6.4
None Remote Low Not required Partial Partial None
The "Apache NetBeans" autoupdate system does not validate SSL certificates and hostnames for https based downloads. This allows an attacker to intercept downloads of autoupdates and modify the download, potentially injecting malicious code. ÔÇťApache NetBeans" versions up to and including 11.2 are affected by this vulnerability.
4021 CVE-2019-17558 94 Exec Code 2019-12-30 2021-03-25
6.0
None Remote Medium ??? Partial Partial Partial
Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset `velocity/` directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting `params.resource.loader.enabled` by defining a response writer with that setting set to `true`. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is `trusted` (has been uploaded by an authenticated user).
4022 CVE-2019-17547 416 2019-10-14 2019-10-18
6.8
None Remote Medium Not required Partial Partial Partial
In ImageMagick before 7.0.8-62, TraceBezier in MagickCore/draw.c has a use-after-free.
4023 CVE-2019-17546 787 Overflow 2019-10-14 2020-08-24
6.8
None Remote Medium Not required Partial Partial Partial
tif_getimage.c in LibTIFF through 4.0.10, as used in GDAL through 3.0.1 and other products, has an integer overflow that potentially causes a heap-based buffer overflow via a crafted RGBA image, related to a "Negative-size-param" condition.
4024 CVE-2019-17544 125 2019-10-14 2019-10-19
6.4
None Remote Low Not required Partial None Partial
libaspell.a in GNU Aspell before 0.60.8 has a stack-based buffer over-read in acommon::unescape in common/getdata.cpp via an isolated \ character.
4025 CVE-2019-17543 120 Overflow 2019-10-14 2020-10-20
6.8
None Remote Medium Not required Partial Partial Partial
LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."
4026 CVE-2019-17541 416 2019-10-14 2021-04-20
6.8
None Remote Medium Not required Partial Partial Partial
ImageMagick before 7.0.8-55 has a use-after-free in DestroyStringInfo in MagickCore/string.c because the error manager is mishandled in coders/jpeg.c.
4027 CVE-2019-17540 787 Overflow 2019-10-14 2021-04-20
6.8
None Remote Medium Not required Partial Partial Partial
ImageMagick before 7.0.8-54 has a heap-based buffer overflow in ReadPSInfo in coders/ps.c.
4028 CVE-2019-17537 22 Dir. Trav. 2019-10-13 2019-10-17
6.4
None Remote Low Not required None Partial Partial
Jiangnan Online Judge (aka jnoj) 0.8.0 has Directory Traversal for file deletion via the web/polygon/problem/deletefile?id=1&name=../ substring.
4029 CVE-2019-17534 416 2019-10-13 2019-10-17
6.8
None Remote Medium Not required Partial Partial Partial
vips_foreign_load_gif_scan_image in foreign/gifload.c in libvips before 8.8.2 tries to access a color map before a DGifGetImageDesc call, leading to a use-after-free.
4030 CVE-2019-17533 125 2019-10-13 2020-08-24
6.4
None Remote Low Not required Partial None Partial
Mat_VarReadNextInfo4 in mat4.c in MATIO 1.5.17 omits a certain '\0' character, leading to a heap-based buffer over-read in strdup_vprintf when uninitialized memory is accessed.
4031 CVE-2019-17531 502 2019-10-12 2021-01-21
6.8
None Remote Medium Not required Partial Partial Partial
A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.0.0 through 2.9.10. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint and the service has the apache-log4j-extra (version 1.2.x) jar in the classpath, and an attacker can provide a JNDI service to access, it is possible to make the service execute a malicious payload.
4032 CVE-2019-17530 125 2019-10-12 2019-10-17
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in Bento4 1.5.1.0. There is a heap-based buffer over-read in AP4_PrintInspector::AddField in Core/Ap4Atom.cpp when called from AP4_CencSampleEncryption::DoInspectFields in Core/Ap4CommonEncryption.cpp, when called from AP4_Atom::Inspect in Core/Ap4Atom.cpp.
4033 CVE-2019-17529 125 2019-10-12 2019-10-17
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in Bento4 1.5.1.0. There is a heap-based buffer over-read in AP4_CencSampleEncryption::DoInspectFields in Core/Ap4CommonEncryption.cpp when called from AP4_Atom::Inspect in Core/Ap4Atom.cpp.
4034 CVE-2019-17520 120 DoS 2020-02-10 2020-02-14
6.1
None Local Network Low Not required None None Complete
The Bluetooth Low Energy implementation on Texas Instruments SDK through 3.30.00.20 for CC2640R2 devices does not properly restrict the SM Public Key packet on reception, allowing attackers in radio range to cause a denial of service (crash) via crafted packets.
4035 CVE-2019-17518 120 Overflow 2020-02-10 2020-02-14
6.1
None Local Network Low Not required None None Complete
The Bluetooth Low Energy implementation on Dialog Semiconductor SDK through 1.0.14.1081 for DA1468x devices responds to link layer packets with a payload length larger than expected, allowing attackers in radio range to cause a buffer overflow via a crafted packet. This affects, for example, August Smart Lock.
4036 CVE-2019-17517 120 Overflow 2020-02-10 2021-02-11
6.1
None Local Network Low Not required None None Complete
The Bluetooth Low Energy implementation on Dialog Semiconductor SDK through 5.0.4 for DA14580/1/2/3 devices does not properly restrict the L2CAP payload length, allowing attackers in radio range to cause a buffer overflow via a crafted Link Layer packet.
4037 CVE-2019-17512 306 2019-10-16 2020-08-24
6.4
None Remote Low Not required Partial Partial None
There are some web interfaces without authentication requirements on D-Link DIR-412 A1-1.14WW routers. An attacker can clear the router's log file via act=clear&logtype=sysact to log_clear.php, which could be used to erase attack traces.
4038 CVE-2019-17490 434 2019-10-10 2019-10-16
6.5
None Remote Low ??? Partial Partial Partial
app\modules\polygon\controllers\ProblemController in Jiangnan Online Judge (aka jnoj) 0.8.0 allows arbitrary file upload, as demonstrated by PHP code (with a .php filename but the image/png content type) to the web/polygon/problem/tests URI.
4039 CVE-2019-17436 2019-10-16 2020-08-24
6.6
None Local Low Not required None Complete Complete
A Local Privilege Escalation vulnerability exists in GlobalProtect Agent for Linux and Mac OS X version 5.0.4 and earlier and version 4.1.12 and earlier, that can allow non-root users to overwrite root files on the file system.
4040 CVE-2019-17431 352 CSRF 2019-10-10 2019-10-11
6.8
None Remote Medium Not required Partial Partial Partial
An issue was discovered in fastadmin 1.0.0.20190705_beta. There is a public/index.php/admin/auth/admin/add CSRF vulnerability.
4041 CVE-2019-17426 20 Bypass 2019-10-10 2019-10-16
6.4
None Remote Low Not required Partial Partial None
Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).
4042 CVE-2019-17424 787 DoS Exec Code Overflow 2019-10-22 2019-11-18
6.8
None Remote Medium Not required Partial Partial Partial
A stack-based buffer overflow in the processPrivilage() function in IOS/process-general.c in nipper-ng 0.11.10 allows remote attackers (serving firewall configuration files) to achieve Remote Code Execution or Denial Of Service via a crafted file.
4043 CVE-2019-17419 89 Sql 2019-10-10 2019-10-10
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in MetInfo 7.0. There is SQL injection via the admin/?n=user&c=admin_user&a=doGetUserInfo id parameter.
4044 CVE-2019-17418 89 Sql 2019-10-10 2019-10-10
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in MetInfo 7.0. There is SQL injection via the admin/?n=language&c=language_general&a=doSearchParameter appno parameter, a different issue than CVE-2019-16997.
4045 CVE-2019-17403 434 Exec Code 2019-11-25 2019-12-04
6.5
None Remote Low ??? Partial Partial Partial
Nokia IMPACT < 18A: An unrestricted File Upload vulnerability was found that may lead to Remote Code Execution.
4046 CVE-2019-17386 352 CSRF 2019-10-10 2019-10-15
6.8
None Remote Medium Not required Partial Partial Partial
The animate-it plugin before 2.3.6 for WordPress has CSRF in edsanimate.php.
4047 CVE-2019-17382 639 Bypass 2019-10-09 2020-08-24
6.4
None Remote Low Not required Partial Partial None
An issue was discovered in zabbix.php?action=dashboard.view&dashboardid=1 in Zabbix through 4.4. An attacker can bypass the login page and access the dashboard page, and then create a Dashboard, Report, Screen, or Map without any Username/Password (i.e., anonymously). All created elements (Dashboard/Report/Screen/Map) are accessible by other users and by an admin.
4048 CVE-2019-17375 613 2019-10-09 2019-10-11
6.5
None Remote Low ??? Partial Partial Partial
cPanel before 82.0.15 allows API token credentials to persist after an account has been renamed or terminated (SEC-517).
4049 CVE-2019-17370 20 Exec Code 2019-10-09 2019-10-11
6.5
None Remote Low ??? Partial Partial Partial
OTCMS v3.85 allows arbitrary PHP Code Execution because admin/sysCheckFile_deal.php blocks "into outfile" in a SELECT statement, but does not block the "into/**/outfile" manipulation. Therefore, the attacker can create a .php file.
4050 CVE-2019-17367 352 CSRF 2019-10-18 2019-10-22
6.8
None Remote Medium Not required Partial Partial Partial
OpenWRT firmware version 18.06.4 is vulnerable to CSRF via wireless/radio0.network1, wireless/radio1.network1, firewall, firewall/zones, firewall/forwards, firewall/rules, network/wan, network/wan6, or network/lan under /cgi-bin/luci/admin/network/.
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.