CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In October 2018

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
301 CVE-2018-18066 476 DoS 2018-10-08 2018-11-26
5.0
None Remote Low Not required None None Partial
snmp_oid_compare in snmplib/snmp_api.c in Net-SNMP before 5.8 has a NULL Pointer Exception bug that can be used by an unauthenticated attacker to remotely cause the instance to crash via a crafted UDP packet, resulting in Denial of Service.
302 CVE-2018-18065 476 DoS 2018-10-08 2019-04-03
4.0
None Remote Low Single system None None Partial
_set_key in agent/helpers/table_container.c in Net-SNMP before 5.8 has a NULL Pointer Exception bug that can be used by an authenticated attacker to remotely cause the instance to crash via a crafted UDP packet, resulting in Denial of Service.
303 CVE-2018-18064 119 Overflow 2018-10-08 2019-01-08
4.3
None Remote Medium Not required None None Partial
cairo through 1.15.14 has an out-of-bounds stack-memory write during processing of a crafted document by WebKitGTK+ because of the interaction between cairo-rectangular-scan-converter.c (the generate and render_rows functions) and cairo-image-compositor.c (the _cairo_image_spans_and_zero function).
304 CVE-2018-18062 79 XSS 2018-10-10 2018-11-28
4.3
None Remote Medium Not required None Partial None
An issue was discovered in dialog.php in tecrail Responsive FileManager 9.8.1. A reflected XSS vulnerability allows remote attackers to inject arbitrary web script or HTML.
305 CVE-2018-18061 287 2018-10-10 2018-11-28
6.4
None Remote Low Not required None Partial Partial
An issue was discovered in dialog.php in tecrail Responsive FileManager 9.8.1. Attackers can access the file manager interface that provides them with the ability to upload and delete files.
306 CVE-2018-18029 79 XSS 2018-10-09 2018-11-23
3.5
None Remote Medium Single system None Partial None
Navigate CMS has Stored XSS via the navigate.php Title field in an edit action.
307 CVE-2018-18026 119 DoS Exec Code Overflow 2018-10-19 2018-12-04
4.6
None Local Low Not required Partial Partial Partial
IMFCameraProtect.sys in IObit Malware Fighter 6.2 (and possibly lower versions) is vulnerable to a stack-based buffer overflow. The attacker can use DeviceIoControl to pass a user specified size which can be used to overwrite return addresses. This can lead to a denial of service or code execution attack.
308 CVE-2018-18025 125 DoS 2018-10-07 2019-06-25
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.8-13 Q16, there is a heap-based buffer over-read in the EncodeImage function of coders/pict.c, which allows attackers to cause a denial of service via a crafted SVG image file.
309 CVE-2018-18024 835 DoS 2018-10-07 2019-10-02
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.8-13 Q16, there is an infinite loop in the ReadBMPImage function of the coders/bmp.c file. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted bmp file.
310 CVE-2018-18023 125 DoS 2018-10-07 2019-06-25
4.3
None Remote Medium Not required None None Partial
In ImageMagick 7.0.8-13 Q16, there is a heap-based buffer over-read in the SVGStripString function of coders/svg.c, which allows attackers to cause a denial of service via a crafted SVG image file.
311 CVE-2018-18021 20 DoS 2018-10-07 2019-04-02
3.6
None Local Low Not required None Partial Partial
arch/arm64/kvm/guest.c in KVM in the Linux kernel before 4.18.12 on the arm64 platform mishandles the KVM_SET_ON_REG ioctl. This is exploitable by attackers who can create virtual machines. An attacker can arbitrarily redirect the hypervisor flow of control (with full register control). An attacker can also cause a denial of service (hypervisor panic) via an illegal exception return. This occurs because of insufficient restrictions on userspace access to the core register file, and because PSTATE.M validation does not prevent unintended execution modes.
312 CVE-2018-18020 20 DoS 2018-10-06 2018-11-25
4.3
None Remote Medium Not required None None Partial
In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.
313 CVE-2018-18016 772 2018-10-05 2019-10-02
4.3
None Remote Medium Not required None None Partial
ImageMagick 7.0.7-28 has a memory leak vulnerability in WritePCXImage in coders/pcx.c.
314 CVE-2018-18014 287 Exec Code 2018-10-24 2019-10-02
7.2
None Local Low Not required Complete Complete Complete
** DISPUTED *** Lack of authentication in Citrix Xen Mobile through 10.8 allows low-privileged local users to execute system commands as root by making requests to private services listening on ports 8000, 30000 and 30001. NOTE: the vendor disputes that this is a vulnerability, stating it is "already mitigated by the internal firewall that limits access to configuration services to localhost."
315 CVE-2018-18013 Exec Code 2018-10-24 2018-10-24
0.0
None ??? ??? ??? ??? ??? ???
** DISPUTED *** Xen Mobile through 10.8.0 includes a service listening on port 5001 within its firewall that accepts unauthenticated input. If this service is supplied with raw serialised Java objects, it deserialises them back into Java objects in memory, giving rise to a remote code execution vulnerability. NOTE: the vendor disputes that this is a vulnerability, stating it is "already mitigated by the internal firewall that limits access to configuration services to localhost."
316 CVE-2018-17986 352 CSRF 2018-10-04 2018-11-27
6.8
None Remote Medium Not required Partial Partial Partial
rars/user/data in razorCMS 3.4.8 allows CSRF for changing the password of an admin user.
317 CVE-2018-17985 400 2018-10-04 2018-11-27
4.3
None Remote Medium Not required None None Partial
An issue was discovered in cp-demangle.c in GNU libiberty, as distributed in GNU Binutils 2.31. There is a stack consumption problem caused by the cplus_demangle_type function making recursive calls to itself in certain scenarios involving many 'P' characters.
318 CVE-2018-17984 185 Exec Code 2018-10-04 2018-12-13
4.6
None Local Low Not required Partial Partial Partial
An unanchored /[a-z]{2}/ regular expression in ISPConfig before 3.1.13 makes it possible to include arbitrary files, leading to code execution. This is exploitable by authenticated users who have local filesystem access.
319 CVE-2018-17983 125 2018-10-04 2018-12-13
6.4
None Remote Low Not required Partial None Partial
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
320 CVE-2018-17980 426 Exec Code +Priv 2018-10-15 2019-01-22
6.8
None Remote Medium Not required Partial Partial Partial
NoMachine before 5.3.27 and 6.x before 6.3.6 allows attackers to gain privileges via a Trojan horse wintab32.dll file located in the same directory as a .nxs file, as demonstrated by a scenario where the .nxs file and the DLL are in the current working directory, and the Trojan horse code is executed. (The directory could, in general, be on a local filesystem or a network share.).
321 CVE-2018-17977 400 DoS 2018-10-08 2018-11-26
4.9
None Local Low Not required None None Complete
The Linux kernel 4.14.67 mishandles certain interaction among XFRM Netlink messages, IPPROTO_AH packets, and IPPROTO_IP packets, which allows local users to cause a denial of service (memory consumption and system hang) by leveraging root access to execute crafted applications, as demonstrated on CentOS 7.
322 CVE-2018-17974 125 DoS 2018-10-03 2019-10-02
4.3
None Remote Medium Not required None None Partial
An issue was discovered in Tcpreplay 4.3.0 beta1. A heap-based buffer over-read was triggered in the function dlt_en10mb_encode() of the file plugins/dlt_en10mb/en10mb.c, due to inappropriate values in the function memmove(). The length (pktlen + ctx -> l2len) can be larger than source value (packet + ctx->l2len) because the function fails to ensure the length of a packet is valid. This leads to Denial of Service.
323 CVE-2018-17972 269 2018-10-03 2019-10-02
4.9
None Local Low Not required Complete None None
An issue was discovered in the proc_pid_stack function in fs/proc/base.c in the Linux kernel through 4.18.11. It does not ensure that only root may inspect the kernel stack of an arbitrary task, allowing a local attacker to exploit racy stack unwinding and leak kernel task stack contents.
324 CVE-2018-17969 522 2018-10-03 2019-10-02
5.0
None Remote Low Not required Partial None None
Samsung SCX-6545X V2.00.03.01 03-23-2012 devices allows remote attackers to discover cleartext credentials via iso.3.6.1.4.1.236.11.5.11.81.10.1.5.0 and iso.3.6.1.4.1.236.11.5.11.81.10.1.6.0 SNMP requests.
325 CVE-2018-17968 338 2018-10-23 2018-12-07
5.0
None Remote Low Not required Partial None None
A gambling smart contract implementation for RuletkaIo, an Ethereum gambling game, generates a random value that is predictable by an external contract call. The developer wrote a random() function that uses a block timestamp and block hash from the Ethereum blockchain. This can be predicted by writing the same random function code in an exploit contract to determine the deadSeat value.
326 CVE-2018-17967 772 2018-10-03 2019-10-02
4.3
None Remote Medium Not required None None Partial
ImageMagick 7.0.7-28 has a memory leak vulnerability in ReadBGRImage in coders/bgr.c.
327 CVE-2018-17966 772 2018-10-03 2019-10-02
4.3
None Remote Medium Not required None None Partial
ImageMagick 7.0.7-28 has a memory leak vulnerability in WritePDBImage in coders/pdb.c.
328 CVE-2018-17965 772 2018-10-03 2019-10-02
4.3
None Remote Medium Not required None None Partial
ImageMagick 7.0.7-28 has a memory leak vulnerability in WriteSGIImage in coders/sgi.c.
329 CVE-2018-17964 79 XSS 2018-10-17 2018-11-30
4.3
None Remote Medium Not required None Partial None
Aryanic HighPortal 12.5 has XSS via an Add Tags action.
330 CVE-2018-17963 190 DoS 2018-10-09 2019-08-06
7.5
None Remote Low Not required Partial Partial Partial
qemu_deliver_packet_iov in net/net.c in Qemu accepts packet sizes greater than INT_MAX, which allows attackers to cause a denial of service or possibly have unspecified other impact.
331 CVE-2018-17962 119 Overflow 2018-10-09 2019-09-24
5.0
None Remote Low Not required None None Partial
Qemu has a Buffer Overflow in pcnet_receive in hw/net/pcnet.c because an incorrect integer data type is used.
332 CVE-2018-17961 209 Bypass 2018-10-15 2019-10-02
6.8
None Remote Medium Not required Partial Partial Partial
Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving errorhandler setup. NOTE: this issue exists because of an incomplete fix for CVE-2018-17183.
333 CVE-2018-17958 190 Overflow 2018-10-09 2019-05-31
5.0
None Remote Low Not required None None Partial
Qemu has a Buffer Overflow in rtl8139_do_receive in hw/net/rtl8139.c because an incorrect integer data type is used.
334 CVE-2018-17947 79 XSS 2018-10-03 2018-11-16
4.3
None Remote Medium Not required None Partial None
The Snazzy Maps plugin before 1.1.5 for WordPress has XSS via the text or tab parameter.
335 CVE-2018-17946 79 XSS 2018-10-03 2018-11-16
4.3
None Remote Medium Not required None Partial None
The Tribulant Slideshow Gallery plugin before 1.6.6.1 for WordPress has XSS via the id, method, Gallerymessage, Galleryerror, or Galleryupdated parameter.
336 CVE-2018-17942 119 Overflow 2018-10-03 2018-11-20
6.8
None Remote Medium Not required Partial Partial Partial
The convert_to_decimal function in vasnprintf.c in Gnulib before 2018-09-23 has a heap-based buffer overflow because memory is not allocated for a trailing '\0' character during %f processing.
337 CVE-2018-17938 20 2018-10-03 2018-12-20
5.0
None Remote Low Not required None Partial None
Zimbra Collaboration before 8.8.10 GA allows text content spoofing via a loginErrorCode value.
338 CVE-2018-17935 254 2018-10-24 2019-10-09
4.8
None Local Network Low Not required None Partial Partial
All versions of Telecrane F25 Series Radio Controls before 00.0A use fixed codes that are reproducible by sniffing and re-transmission. This can lead to unauthorized replay of a command, spoofing of an arbitrary message, or keeping the controlled load in a permanent "stop" state.
339 CVE-2018-17933 Exec Code 2018-10-30 2019-10-09
6.5
None Remote Low Single system Partial Partial Partial
VGo Robot (Versions 3.0.3.52164 and 3.0.3.53662. Prior versions may also be affected) connected to the VGo XAMPP. User accounts may be able to execute commands that are outside the scope of their privileges and within the scope of an admin account. If an attacker has access to VGo XAMPP Client credentials, they may be able to execute admin commands on the connected robot.
340 CVE-2018-17931 284 Exec Code 2018-10-30 2019-10-09
7.2
None Local Low Not required Complete Complete Complete
If an attacker has physical access to the VGo Robot (Versions 3.0.3.52164 and 3.0.3.53662. Prior versions may also be affected) they may be able to alter scripts, which may allow code execution with root privileges.
341 CVE-2018-17929 119 Exec Code Overflow 2018-10-11 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
In Delta Industrial Automation TPEditor, TPEditor Versions 1.90 and prior, multiple stack-based buffer overflow vulnerabilities may be exploited by processing specially crafted project files lacking user input validation before copying data from project files onto the stack and may allow an attacker to remotely execute arbitrary code.
342 CVE-2018-17927 787 Exec Code 2018-10-11 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
In Delta Industrial Automation TPEditor, TPEditor Versions 1.90 and prior, multiple out-of-bounds write vulnerabilities may be exploited by processing specially crafted project files lacking user input validation, which may cause the system to write outside the intended buffer area and may allow remote code execution.
343 CVE-2018-17925 2018-10-10 2019-10-09
4.4
None Local Medium Not required Partial Partial Partial
Multiple instances of this vulnerability (Unsafe ActiveX Control Marked Safe For Scripting) have been identified in the third-party ActiveX object provided to GE iFIX versions 2.0 - 5.8 by Gigasoft. Only the independent use of the Gigasoft charting package outside the iFIX product may expose users to the reported vulnerability. The reported method shown to impact Internet Explorer is not exposed in the iFIX product, nor is the core functionality of the iFIX product known to be impacted.
344 CVE-2018-17923 287 2018-10-24 2019-10-09
6.9
None Local Medium Not required Complete Complete Complete
SAGA1-L8B with any firmware versions prior to A0.10 are vulnerable to an attack that an attacker with physical access to the product may able to reprogram it.
345 CVE-2018-17921 284 2018-10-24 2019-10-09
5.8
None Local Network Low Not required Partial Partial Partial
SAGA1-L8B with any firmware versions prior to A0.10 are vulnerable to an attack that may allow an attacker to force-pair the device without human interaction.
346 CVE-2018-17919 798 2018-10-10 2019-10-09
6.4
None Remote Low Not required Partial Partial None
All versions of Hangzhou Xiongmai Technology Co., Ltd XMeye P2P Cloud Server may allow an attacker to use an undocumented user account "default" with its default password to login to XMeye and access/view video streams.
347 CVE-2018-17917 200 +Info 2018-10-10 2019-10-09
5.0
None Remote Low Not required Partial None None
All versions of Hangzhou Xiongmai Technology Co., Ltd XMeye P2P Cloud Server may allow an attacker to use MAC addresses to enumerate potential Cloud IDs. Using this ID, the attacker can discover and connect to valid devices using one of the supported apps.
348 CVE-2018-17915 311 2018-10-10 2019-10-09
6.4
None Remote Low Not required Partial Partial None
All versions of Hangzhou Xiongmai Technology Co., Ltd XMeye P2P Cloud Server do not encrypt all device communication. This includes the XMeye service and firmware update communication. This could allow an attacker to eavesdrop on video feeds, steal XMeye login credentials, or impersonate the update server with malicious update code.
349 CVE-2018-17911 119 Exec Code Overflow 2018-10-16 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
LAquis SCADA Versions 4.1.0.3870 and prior has several stack-based buffer overflow vulnerabilities, which may allow remote code execution.
350 CVE-2018-17910 119 Exec Code Overflow 2018-10-29 2019-10-09
9.3
None Remote Medium Not required Complete Complete Complete
WebAccess Versions 8.3.2 and prior. The application fails to properly validate the length of user-supplied data, causing a buffer overflow condition that allows for arbitrary remote code execution.
Total number of vulnerabilities : 1473   Page : 1 2 3 4 5 6 7 (This Page)8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.