CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 5 and 5.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
2901 CVE-2017-16163 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
dylmomo is a simple file server. dylmomo is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2902 CVE-2017-16162 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
22lixian is a simple file server. 22lixian is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2903 CVE-2017-16161 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
shenliru is a simple file server. shenliru is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2904 CVE-2017-16160 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
11xiaoli is a simple file server. 11xiaoli is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2905 CVE-2017-16159 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
caolilinode is a simple file server. caolilinode is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2906 CVE-2017-16158 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
dcserver is a static file server. dcserver is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2907 CVE-2017-16157 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
censorify.tanisjr is a simple web server and API RESTful service. censorify.tanisjr is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2908 CVE-2017-16156 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
myprolyz is a static file server. myprolyz is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2909 CVE-2017-16155 22 Dir. Trav. 2018-06-06 2018-07-19
5.0
None Remote Low Not required Partial None None
fast-http-cli is the command line interface for fast-http, a simple web server. fast-http-cli is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2910 CVE-2017-16154 22 Dir. Trav. 2018-06-06 2018-07-19
5.0
None Remote Low Not required Partial None None
earlybird is a web server module for early development. earlybird is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2911 CVE-2017-16153 22 Dir. Trav. 2018-05-29 2018-07-03
5.0
None Remote Low Not required Partial None None
gaoxuyan is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2912 CVE-2017-16152 22 Dir. Trav. 2018-06-06 2018-07-19
5.0
None Remote Low Not required Partial None None
static-html-server is a static file server. static-html-server is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2913 CVE-2017-16150 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
wanggoujing123 is a simple webserver. wanggoujing123 is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2914 CVE-2017-16149 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
zwserver is a weather web server. zwserver is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2915 CVE-2017-16148 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
serve46 is a static file server. serve46 is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2916 CVE-2017-16147 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
shit-server is a file server. shit-server is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2917 CVE-2017-16146 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
mockserve is a file server. mockserve is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2918 CVE-2017-16145 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
sspa is a server dedicated to single-page apps. sspa is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2919 CVE-2017-16144 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
myserver.alexcthomas18 is a file server. myserver.alexcthomas18 is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2920 CVE-2017-16143 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
commentapp.stetsonwood is an http server. commentapp.stetsonwood is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2921 CVE-2017-16142 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
infraserver is a RESTful server. infraserver is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2922 CVE-2017-16141 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
lab6drewfusbyu is an http server. lab6drewfusbyu is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2923 CVE-2017-16140 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
lab6.brit95 is a file server. lab6.brit95 is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2924 CVE-2017-16139 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
jikes is a file server. jikes is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url. Accessible files are restricted to files with .htm and .js extensions.
2925 CVE-2017-16138 400 DoS 2018-06-06 2019-01-07
5.0
None Remote Low Not required None None Partial
The mime module is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.
2926 CVE-2017-16137 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
The debug module is vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. It takes around 50k characters to block for 2 seconds making this a low severity issue.
2927 CVE-2017-16136 400 DoS 2018-06-06 2018-07-23
5.0
None Remote Low Not required None None Partial
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.
2928 CVE-2017-16135 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
serverzyy is a static file server. serverzyy is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2929 CVE-2017-16134 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
http_static_simple is an http server. http_static_simple is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2930 CVE-2017-16133 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
goserv is an http server. goserv is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2931 CVE-2017-16132 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
simple-npm-registry is a local npm package cache. simple-npm-registry is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2932 CVE-2017-16131 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
unicorn-list is a web framework. unicorn-list is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2933 CVE-2017-16130 22 Dir. Trav. 2018-06-06 2018-07-31
5.0
None Remote Low Not required Partial None None
exxxxxxxxxxx is an Http eX Frame Google Style JavaScript Guide. exxxxxxxxxxx is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url. Accessible files are restricted to those with a file extension. Files with no extension such as /etc/passwd throw an error.
2934 CVE-2017-16126 200 +Info 2018-06-06 2018-07-31
5.0
None Remote Low Not required Partial None None
The module botbait is a tool to be used to track bot and automated tools usage with-in the npm ecosystem. botbait is known to record and track user information. The module tracks the following information. Source IP process.versions process.platform How the module was invoked (test, require, pre-install)
2935 CVE-2017-16125 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
rtcmulticonnection-client is a signaling implementation for RTCMultiConnection.js, a multi-session manager. rtcmulticonnection-client is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2936 CVE-2017-16124 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
node-server-forfront is a simple static file server. node-server-forfront is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2937 CVE-2017-16123 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
welcomyzt is a simple file server. welcomyzt is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2938 CVE-2017-16122 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
cuciuci is a simple fileserver. cuciuci is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2939 CVE-2017-16121 22 Dir. Trav. 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
datachannel-client is a signaling implementation for DataChannel.js. datachannel-client is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2940 CVE-2017-16120 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
liyujing is a static file server. liyujing is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2941 CVE-2017-16119 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
Fresh is a module used by the Express.js framework for HTTP response freshness testing. It is vulnerable to a regular expression denial of service when it is passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
2942 CVE-2017-16118 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
2943 CVE-2017-16117 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
slug is a module to slugify strings, even if they contain unicode. slug is vulnerable to regular expression denial of service is specially crafted untrusted input is passed as input. About 50k characters can block the event loop for 2 seconds.
2944 CVE-2017-16116 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
The string module is a module that provides extra string operations. The string module is vulnerable to regular expression denial of service when specifically crafted untrusted user input is passed into the underscore or unescapeHTML methods.
2945 CVE-2017-16115 400 DoS 2018-06-06 2018-07-27
5.0
None Remote Low Not required None None Partial
The timespan module is vulnerable to regular expression denial of service. Given 50k characters of untrusted user input it will block the event loop for around 10 seconds.
2946 CVE-2017-16114 400 DoS 2018-06-06 2018-07-27
5.0
None Remote Low Not required None None Partial
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
2947 CVE-2017-16113 20 DoS 2018-06-06 2018-07-27
5.0
None Remote Low Not required None None Partial
The parsejson module is vulnerable to regular expression denial of service when untrusted user input is passed into it to be parsed.
2948 CVE-2017-16111 400 DoS 2018-06-06 2018-07-31
5.0
None Remote Low Not required None None Partial
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
2949 CVE-2017-16110 22 Dir. Trav. 2018-06-06 2018-07-19
5.0
None Remote Low Not required Partial None None
weather.swlyons is a simple web server for weather updates. weather.swlyons is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2950 CVE-2017-16109 22 Dir. Trav. 2018-06-06 2018-07-19
5.0
None Remote Low Not required Partial None None
easyquick is a simple web server. easyquick is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url. Access is constrained, however, to supported file types. Requesting a file such as /etc/passwd returns a "not supported" error.
Total number of vulnerabilities : 21598   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 (This Page)60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.