CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 5 and 5.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
2601 CVE-2017-16084 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
list-n-stream is a server for static files to list and stream local videos. list-n-stream v0.0.10 or lower is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2602 CVE-2017-16083 22 Dir. Trav. 2018-06-06 2018-07-12
5.0
None Remote Low Not required Partial None None
node-simple-router is a minimalistic router for Node. node-simple-router is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the URL.
2603 CVE-2017-16081 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
cross-env.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2604 CVE-2017-16080 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
nodesass was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2605 CVE-2017-16079 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
smb was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2606 CVE-2017-16078 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
shadowsock was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2607 CVE-2017-16077 200 +Info 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
mongose was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2608 CVE-2017-16076 200 +Info 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
proxy.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2609 CVE-2017-16075 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
http-proxy.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2610 CVE-2017-16074 200 +Info 2018-06-06 2018-07-13
5.0
None Remote Low Not required Partial None None
crossenv was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2611 CVE-2017-16073 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
noderequest was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2612 CVE-2017-16072 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
nodemailer.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2613 CVE-2017-16071 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
nodemailer-js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2614 CVE-2017-16070 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
nodecaffe was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2615 CVE-2017-16069 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
nodeffmpeg was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2616 CVE-2017-16068 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
ffmepg was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2617 CVE-2017-16067 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
node-opencv was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2618 CVE-2017-16066 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
opencv.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2619 CVE-2017-16065 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
openssl.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2620 CVE-2017-16064 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
node-openssl was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2621 CVE-2017-16063 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
node-opensl was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2622 CVE-2017-16062 200 +Info 2018-05-29 2018-07-02
5.0
None Remote Low Not required Partial None None
node-tkinter was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2623 CVE-2017-16061 200 +Info 2018-05-29 2018-07-02
5.0
None Remote Low Not required Partial None None
tkinter was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2624 CVE-2017-16060 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
babelcli was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2625 CVE-2017-16059 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
mssql-node was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2626 CVE-2017-16058 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
gruntcli was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2627 CVE-2017-16057 200 +Info 2018-06-06 2018-07-02
5.0
None Remote Low Not required Partial None None
nodemssql was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2628 CVE-2017-16056 200 +Info 2018-06-06 2018-07-03
5.0
None Remote Low Not required Partial None None
mssql.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2629 CVE-2017-16055 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`sqlserver` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2630 CVE-2017-16054 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`nodefabric` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2631 CVE-2017-16053 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`fabric-js` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2632 CVE-2017-16052 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`node-fabric` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2633 CVE-2017-16051 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`sqliter` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2634 CVE-2017-16050 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`sqlite.js` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2635 CVE-2017-16049 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`nodesqlite` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2636 CVE-2017-16048 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`node-sqlite` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2637 CVE-2017-16047 200 +Info 2018-05-29 2018-07-02
5.0
None Remote Low Not required Partial None None
mysqljs was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2638 CVE-2017-16046 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`mariadb` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2639 CVE-2017-16045 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`jquery.js` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2640 CVE-2017-16044 200 +Info 2018-06-04 2018-07-03
5.0
None Remote Low Not required Partial None None
`d3.js` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
2641 CVE-2017-16039 22 Dir. Trav. 2018-06-04 2018-07-19
5.0
None Remote Low Not required Partial None None
`hftp` is a static http or ftp server `hftp` is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2642 CVE-2017-16038 22 Dir. Trav. 2018-06-04 2018-07-19
5.0
None Remote Low Not required Partial None None
`f2e-server` 1.12.11 and earlier is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url. This is compounded by `f2e-server` requiring elevated privileges to run.
2643 CVE-2017-16037 22 Dir. Trav. 2018-06-04 2018-07-19
5.0
None Remote Low Not required Partial None None
`gomeplus-h5-proxy` is vulnerable to a directory traversal issue, allowing attackers to access any file in the system by placing '../' in the URL.
2644 CVE-2017-16036 22 Dir. Trav. 2018-06-04 2018-07-19
5.0
None Remote Low Not required Partial None None
`badjs-sourcemap-server` receives files sent by `badjs-sourcemap`. `badjs-sourcemap-server` is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the url.
2645 CVE-2017-16031 330 +Info 2018-06-04 2018-07-31
5.0
None Remote Low Not required Partial None None
Socket.io is a realtime application framework that provides communication via websockets. Because socket.io 0.9.6 and earlier depends on `Math.random()` to create socket IDs, the IDs are predictable. An attacker is able to guess the socket ID and gain access to socket.io servers, potentially obtaining sensitive information.
2646 CVE-2017-16030 399 2018-06-04 2018-07-31
5.0
None Remote Low Not required None None Partial
Useragent is used to parse useragent headers. It uses several regular expressions to accomplish this. An attacker could edit their own headers, creating an arbitrarily long useragent string, causing the event loop and server to block. This affects Useragent 2.1.12 and earlier.
2647 CVE-2017-16029 22 Dir. Trav. 2018-06-04 2018-07-19
5.0
None Remote Low Not required Partial None None
hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.
2648 CVE-2017-16028 338 2018-06-04 2018-07-31
5.0
None Remote Low Not required Partial None None
react-native-meteor-oauth is a library for Oauth2 login to a Meteor server in React Native. The oauth Random Token is generated using a non-cryptographically strong RNG (Math.random()).
2649 CVE-2017-16023 20 DoS 2018-06-04 2018-07-18
5.0
None Remote Low Not required None None Partial
Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.
2650 CVE-2017-16014 388 DoS 2018-06-04 2018-07-27
5.0
None Remote Low Not required None None Partial
Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.
Total number of vulnerabilities : 21278   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 (This Page)54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.