CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 6 and 6.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
2251 CVE-2020-12497 787 Exec Code Overflow 2020-07-01 2021-03-31
6.8
None Remote Medium Not required Partial Partial Partial
PLCopen XML file parsing in Phoenix Contact PC Worx and PC Worx Express version 1.87 and earlier can lead to a stack-based overflow. Manipulated PC Worx projects could lead to a remote code execution due to insufficient input data validation.
2252 CVE-2020-12495 269 2020-11-19 2020-12-08
6.5
None Remote Low ??? Partial Partial Partial
Endress+Hauser Ecograph T (Neutral/Private Label) (RSG35, ORSG35) with Firmware version prior to V2.0.0 is prone to improper privilege management. The affected device has a web-based user interface with a role-based access system. Users with different roles have different write and read privileges. The access system is based on dynamic "tokens". The vulnerability is that user sessions are not closed correctly and a user with fewer rights is assigned the higher rights when he logs on.
2253 CVE-2020-12479 22 Dir. Trav. 2020-04-29 2020-05-01
6.5
None Remote Low ??? Partial Partial Partial
TeamPass 2.1.27.36 allows any authenticated TeamPass user to trigger a PHP file include vulnerability via a crafted HTTP request with sources/users.queries.php newValue directory traversal.
2254 CVE-2020-12470 552 Exec Code 2020-04-29 2020-05-04
6.5
None Remote Low ??? Partial Partial Partial
MonoX through 5.1.40.5152 allows administrators to execute arbitrary code by modifying an ASPX template.
2255 CVE-2020-12468 2020-04-29 2020-05-01
6.8
None Remote Medium Not required Partial Partial Partial
Subrion CMS 4.2.1 allows CSV injection via a phrase value within a language. This is related to phrases/add/ and languages/download/.
2256 CVE-2020-12467 384 2020-04-29 2020-05-01
6.4
None Remote Low Not required Partial Partial None
Subrion CMS 4.2.1 allows session fixation via an alphanumeric value in a session cookie.
2257 CVE-2020-12461 89 Sql 2020-04-29 2020-05-05
6.5
None Remote Low ??? Partial Partial Partial
PHP-Fusion 9.03.50 allows SQL Injection because maincore.php has an insufficient protection mechanism. An attacker can develop a crafted payload that can be inserted into the sort_order GET parameter on the members.php members search page. This parameter allows for control over anything after the ORDER BY clause in the SQL query.
2258 CVE-2020-12456 22 Exec Code Dir. Trav. 2020-08-26 2020-09-01
6.5
None Remote Low ??? Partial Partial Partial
A remote code execution vulnerability in Mitel MiVoice Connect Client before 214.100.1223.0 could allow an attacker to execute arbitrary code in the chat notification window, due to improper rendering of chat messages. A successful exploit could allow an attacker to steal session cookies, perform directory traversal, and execute arbitrary scripts in the context of the Connect client.
2259 CVE-2020-12431 427 2020-05-21 2020-06-08
6.3
None Local Medium Not required None Complete Complete
A Windows privilege change issue was discovered in Splashtop Software Updater before 1.5.6.16. Insecure permissions on the configuration file and named pipe allow for local privilege escalation to NT AUTHORITY/SYSTEM, by forcing a permission change to any Splashtop files and directories, with resultant DLL hijacking. This product is bundled with Splashtop Streamer (before 3.3.8.0) and Splashtop Business (before 3.3.8.0).
2260 CVE-2020-12427 352 CSRF 2020-05-13 2020-05-15
6.8
None Remote Medium Not required Partial Partial Partial
The Western Digital WD Discovery application before 3.8.229 for MyCloud Home on Windows and macOS is vulnerable to CSRF, with impacts such as stealing data, modifying disk contents, or exhausting disk space.
2261 CVE-2020-12423 427 Exec Code 2020-07-09 2020-07-20
6.9
None Local Medium Not required Complete Complete Complete
When the Windows DLL "webauthn.dll" was missing from the Operating System, and a malicious one was placed in a folder in the user's %PATH%, Firefox may have loaded the DLL, leading to arbitrary code execution. *Note: This issue only affects the Windows operating system; other operating systems are unaffected.* This vulnerability affects Firefox < 78.
2262 CVE-2020-12409 2020-07-09 2020-07-13
6.8
None Remote Medium Not required Partial Partial Partial
When using certain blank characters in a URL, they where incorrectly rendered as spaces instead of an encoded URL. This vulnerability affects Firefox < 77.
2263 CVE-2020-12403 125 2021-05-27 2021-06-09
6.4
None Remote Low Not required Partial None Partial
A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.
2264 CVE-2020-12387 362 2020-05-26 2020-06-12
6.8
None Remote Medium Not required Partial Partial Partial
A race condition when running shutdown code for Web Worker led to a use-after-free vulnerability. This resulted in a potentially exploitable crash. This vulnerability affects Firefox ESR < 68.8, Firefox < 76, and Thunderbird < 68.8.0.
2265 CVE-2020-12347 20 2020-11-12 2020-11-20
6.5
None Remote Low ??? Partial Partial Partial
Improper input validation in the Intel(R) Data Center Manager Console before version 3.6.2 may allow an authenticated user to potentially enable escalation of privilege via network access.
2266 CVE-2020-12339 2021-02-17 2021-02-22
6.5
None Remote Low ??? Partial Partial Partial
Insufficient control flow management in the API for the Intel(R) Collaboration Suite for WebRTC before version 4.3.1 may allow an authenticated user to potentially enable escalation of privilege via network access.
2267 CVE-2020-12282 352 XSS CSRF 2020-09-24 2020-09-27
6.8
None Remote Medium Not required Partial Partial Partial
iSmartgate PRO 1.5.9 is vulnerable to CSRF via the busca parameter in the form used for searching for users, accessible via /index.php. (This can be combined with reflected XSS.)
2268 CVE-2020-12258 384 2020-05-18 2020-05-19
6.4
None Remote Low Not required Partial Partial None
rConfig 3.9.4 is vulnerable to session fixation because session expiry and randomization are mishandled. The application can reuse a session via PHPSESSID. Also, an attacker can exploit this vulnerability in conjunction with CVE-2020-12256 or CVE-2020-12259.
2269 CVE-2020-12257 352 CSRF 2020-05-18 2020-05-18
6.8
None Remote Medium Not required Partial Partial Partial
rConfig 3.9.4 is vulnerable to cross-site request forgery (CSRF) because it lacks implementation of CSRF protection such as a CSRF token. An attacker can leverage this vulnerability by creating a form (add a user, delete a user, or edit a user).
2270 CVE-2020-12255 434 Exec Code 2020-05-18 2020-05-19
6.5
None Remote Low ??? Partial Partial Partial
rConfig 3.9.4 is vulnerable to remote code execution due to improper validation in the file upload functionality. vendor.crud.php accepts a file upload by checking content-type without considering the file extension and header. Thus, an attacker can exploit this by uploading a .php file to vendor.php that contains arbitrary PHP code and changing the content-type to image/gif.
2271 CVE-2020-12252 434 Exec Code 2020-04-29 2020-05-18
6.0
None Remote Medium ??? Partial Partial Partial
An issue was discovered in Gigamon GigaVUE 5.5.01.11. The upload functionality allows an arbitrary file upload for an authenticated user. If an executable file is uploaded into the www-root directory, then it could yield remote code execution via the filename parameter.
2272 CVE-2020-12248 787 Exec Code Overflow 2020-09-04 2020-09-09
6.8
None Remote Medium Not required Partial Partial Partial
In Foxit Reader and PhantomPDF before 10.0.1, and PhantomPDF before 9.7.3, attackers can execute arbitrary code via a heap-based buffer overflow because dirty image-resource data is mishandled.
2273 CVE-2020-12147 22 Dir. Trav. 2020-11-05 2020-11-12
6.5
None Remote Low ??? Partial Partial Partial
In Silver Peak Unity Orchestrator versions prior to 8.9.11+, 8.10.11+, or 9.0.1+, an authenticated user can make unauthorized MySQL queries against the Orchestrator database using the /sqlExecution REST API, which had been used for internal testing.
2274 CVE-2020-12146 22 Dir. Trav. 2020-11-05 2020-11-12
6.5
None Remote Low ??? Partial Partial Partial
In Silver Peak Unity Orchestrator versions prior to 8.9.11+, 8.10.11+, or 9.0.1+, an authenticated user can access, modify, and delete restricted files on the Orchestrator server using the/debugFiles REST API.
2275 CVE-2020-12118 276 +Info 2020-04-23 2020-05-01
6.4
None Remote Low Not required Partial Partial None
The keygen protocol implementation in Binance tss-lib before 1.2.0 allows attackers to generate crafted h1 and h2 parameters in order to compromise a signing round or obtain sensitive information from other parties.
2276 CVE-2020-12104 89 Exec Code Sql 2020-05-05 2020-05-07
6.5
None Remote Low ??? Partial Partial Partial
The Import feature in the wp-advanced-search plugin 3.3.6 for WordPress is vulnerable to authenticated SQL injection via an uploaded .sql file. An attacker can use this to execute SQL commands without any validation.
2277 CVE-2020-12102 22 Dir. Trav. 2020-04-28 2020-05-18
6.8
None Remote Low ??? Complete None None
In Tiny File Manager 2.4.1, there is a Path Traversal vulnerability in the ajax recursive directory listing functionality. This allows authenticated users to enumerate directories and files on the filesystem (outside of the application scope).
2278 CVE-2020-12077 434 Exec Code 2020-04-23 2020-04-28
6.5
None Remote Low ??? Partial Partial Partial
The mappress-google-maps-for-wordpress plugin before 2.53.9 for WordPress does not correctly implement AJAX functions with nonces (or capability checks), leading to remote code execution.
2279 CVE-2020-12076 352 XSS CSRF 2020-04-23 2020-04-29
6.8
None Remote Medium Not required Partial Partial Partial
The data-tables-generator-by-supsystic plugin before 1.9.92 for WordPress lacks CSRF nonce checks for AJAX actions. One consequence of this is stored XSS.
2280 CVE-2020-12075 276 2020-04-23 2020-04-29
6.5
None Remote Low ??? Partial Partial Partial
The data-tables-generator-by-supsystic plugin before 1.9.92 for WordPress lacks capability checks for AJAX actions.
2281 CVE-2020-12074 74 2020-04-23 2020-04-28
6.5
None Remote Low ??? Partial Partial Partial
The users-customers-import-export-for-wp-woocommerce plugin before 1.3.9 for WordPress allows subscribers to import administrative accounts via CSV.
2282 CVE-2020-12073 2020-04-23 2020-04-28
6.5
None Remote Low ??? Partial Partial Partial
The responsive-add-ons plugin before 2.2.7 for WordPress has incorrect access control for wp-admin/admin-ajax.php?action= requests.
2283 CVE-2020-12068 269 2020-05-14 2020-05-21
6.4
None Remote Low Not required Partial Partial None
An issue was discovered in CODESYS Development System before 3.5.16.0. CODESYS WebVisu and CODESYS Remote TargetVisu are susceptible to privilege escalation.
2284 CVE-2020-12050 362 2020-04-30 2020-05-27
6.9
None Local Medium Not required Complete Complete Complete
SQLiteODBC 0.9996, as packaged for certain Linux distributions as 0.9996-4, has a race condition leading to root privilege escalation because any user can replace a /tmp/sqliteodbc$$ file with new contents that cause loading of an arbitrary library.
2285 CVE-2020-12032 311 2020-06-29 2020-07-08
6.4
None Remote Low Not required Partial Partial None
Baxter ExactaMix EM 2400 Versions 1.10, 1.11 and ExactaMix EM1200 Versions 1.1, 1.2 systems store device data with sensitive information in an unencrypted database. This could allow an attacker with network access to view or modify sensitive data including PHI.
2286 CVE-2020-12029 20 Exec Code 2020-07-20 2020-11-20
6.8
None Remote Medium Not required Partial Partial Partial
All versions of FactoryTalk View SE do not properly validate input of filenames within a project directory. A remote, unauthenticated attacker may be able to execute a crafted file on a remote endpoint that may result in remote code execution (RCE). Rockwell Automation recommends applying patch 1126289. Before installing this patch, the patch rollup dated 06 Apr 2020 or later MUST be applied. 1066644 – Patch Roll-up for CPR9 SRx.
2287 CVE-2020-12026 22 Dir. Trav. 2020-05-08 2020-05-11
6.5
None Remote Low ??? Partial Partial Partial
Advantech WebAccess Node, Version 8.4.4 and prior, Version 9.0.0. Multiple relative path traversal vulnerabilities exist that may allow a low privilege user to overwrite files outside the application’s control.
2288 CVE-2020-12021 79 Exec Code XSS 2020-06-23 2020-07-02
6.0
None Remote Medium ??? Partial Partial Partial
In OSIsoft PI Web API 2019 Patch 1 (1.12.0.6346) and all previous versions, the affected product is vulnerable to a cross-site scripting attack, which may allow an attacker to remotely execute arbitrary code.
2289 CVE-2020-12013 94 Exec Code 2020-07-16 2020-07-29
6.4
None Remote Low Not required Partial Partial None
A specially crafted WCF client that interfaces to the may allow the execution of certain arbitrary SQL commands remotely. This affects: Mitsubishi Electric MC Works64 Version 4.02C (10.95.208.31) and earlier, all versions; Mitsubishi Electric MC Works32 Version 3.00A (9.50.255.02); ICONICS GenBroker64, Platform Services, Workbench, FrameWorX Server v10.96 and prior; ICONICS GenBroker32 v9.5 and prior.
2290 CVE-2020-11988 918 2021-02-24 2021-04-01
6.4
None Remote Low Not required Partial Partial None
Apache XmlGraphics Commons 2.4 is vulnerable to server-side request forgery, caused by improper input validation by the XMPParser. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.
2291 CVE-2020-11987 918 2021-02-24 2021-06-14
6.4
None Remote Low Not required Partial Partial None
Apache Batik 1.13 is vulnerable to server-side request forgery, caused by improper input validation by the NodePickerPanel. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.
2292 CVE-2020-11980 918 2020-06-12 2021-01-07
6.5
None Remote Low ??? Partial Partial Partial
In Karaf, JMX authentication takes place using JAAS and authorization takes place using ACL files. By default, only an "admin" can actually invoke on an MBean. However there is a vulnerability there for someone who is not an admin, but has a "viewer" role. In the 'etc/jmx.acl.cfg', such as role can call get*. It's possible to authenticate as a viewer role + invokes on the MLet getMBeansFromURL method, which goes off to a remote server to fetch the desired MBean, which is then registered in Karaf. At this point the attack fails as "viewer" doesn't have the permission to invoke on the MBean. Still, it could act as a SSRF style attack and also it essentially allows a "viewer" role to pollute the MBean registry, which is a kind of privilege escalation. The vulnerability is low as it's possible to add a ACL to limit access. Users should update to Apache Karaf 4.2.9 or newer.
2293 CVE-2020-11978 78 2020-07-17 2021-06-02
6.5
None Remote Low ??? Partial Partial Partial
An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.
2294 CVE-2020-11969 287 2020-06-15 2020-12-23
6.8
None Remote Medium Not required Partial Partial Partial
If Apache TomEE is configured to use the embedded ActiveMQ broker, and the broker URI includes the useJMX=true parameter, a JMX port is opened on TCP port 1099, which does not include authentication. This affects Apache TomEE 8.0.0-M1 - 8.0.1, Apache TomEE 7.1.0 - 7.1.2, Apache TomEE 7.0.0-M1 - 7.0.7, Apache TomEE 1.0.0 - 1.7.5.
2295 CVE-2020-11958 787 Overflow 2020-04-21 2020-07-27
6.8
None Remote Medium Not required Partial Partial Partial
re2c 1.3 has a heap-based buffer overflow in Scanner::fill in parse/scanner.cc via a long lexeme.
2296 CVE-2020-11943 434 2020-04-29 2020-05-05
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in Open-AudIT 3.2.2. There is Arbitrary file upload.
2297 CVE-2020-11941 78 2020-04-27 2020-05-05
6.5
None Remote Low ??? Partial Partial Partial
An issue was discovered in Open-AudIT 3.2.2. There is OS Command injection in Discovery.
2298 CVE-2020-11900 415 2020-06-17 2020-07-22
6.4
None Remote Low Not required None Partial Partial
The Treck TCP/IP stack before 6.0.1.41 has an IPv4 tunneling Double Free.
2299 CVE-2020-11898 200 +Info 2020-06-17 2020-07-22
6.4
None Remote Low Not required Partial None Partial
The Treck TCP/IP stack before 6.0.1.66 improperly handles an IPv4/ICMPv4 Length Parameter Inconsistency, which might allow remote attackers to trigger an information leak.
2300 CVE-2020-11895 125 2020-04-19 2020-04-23
6.4
None Remote Low Not required Partial None Partial
Ming (aka libming) 0.4.8 has a heap-based buffer over-read (2 bytes) in the function decompileIF() in decompile.c.
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.