CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities Published In December 2018

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
1051 CVE-2018-5203 Exec Code 2018-12-28 2018-12-28
0.0
None ??? ??? ??? ??? ??? ???
DEXTUploadX5 version Between 1.0.0.0 and 2.2.0.0 contains a vulnerability that could allow remote attacker to download and execute remote arbitrary file by setting the arguments to the activex method. this can be leveraged for code execution.
1052 CVE-2018-5202 Exec Code 2018-12-21 2019-10-02
6.8
None Remote Medium Not required Partial Partial Partial
SKCertService 2.5.5 and earlier contains a vulnerability that could allow remote attacker to execute arbitrary code. This vulnerability exists due to the way .dll files are loaded by SKCertService. It allows an attacker to load a .dll of the attacker's choosing that could execute arbitrary code without the user's knowledge.
1053 CVE-2018-5201 119 DoS Overflow 2018-12-21 2019-01-08
4.3
None Remote Medium Not required None None Partial
Hancom Office 2018 10.0.0.8214 and earlier, Hancom Office NEO 9.6.1.10472 and earlier, Hancom Office 2014 9.1.1.4540 and earlier, Hancom Office 2010 8.5.8.1724 and earlier versions have a heap overflow vulnerability when handling Compound File in document. This result in a program crash or denial of service conditions.
1054 CVE-2018-5200 119 Exec Code Overflow Mem. Corr. 2018-12-20 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
KMPlayer 4.2.2.15 and earlier have a Heap Based Buffer Overflow Vulnerability. It could be exploited with a crafted FLV format file. The problem is that more frame data is copied to heap memory than the size specified in the frame header. This results in a memory corruption and remote code execution.
1055 CVE-2018-5199 20 2018-12-20 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
In Veraport G3 ALL on MacOS, due to insufficient domain validation, It is possible to overwrite installation file to malicious file. A remote unauthenticated attacker may use this vulnerability to execute arbitrary file.
1056 CVE-2018-5198 362 Exec Code 2018-12-20 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
In Veraport G3 ALL on MacOS, a race condition when calling the Veraport API allow remote attacker to cause arbitrary file download and execution. This results in remote code execution.
1057 CVE-2018-5196 119 Exec Code Overflow 2018-12-21 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
Alzip 10.76.0.0 and earlier is vulnerable to a stack overflow caused by improper bounds checking. By persuading a victim to open a specially-crafted LZH archive file, a attacker could execute arbitrary code execution.
1058 CVE-2018-4040 824 2018-12-01 2018-12-27
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable uninitialized pointer vulnerability exists in the rich text format parser of Atlantis Word Processor, version 3.2.7.2. A specially crafted document can cause certain RTF tokens to dereference a pointer that has been uninitialized and then write to it. An attacker must convince a victim to open a specially crafted document in order to trigger this vulnerability.
1059 CVE-2018-4039 787 Exec Code 2018-12-01 2018-12-26
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable out-of-bounds write vulnerability exists in the PNG implementation of Atlantis Word Processor, version 3.2.7.2. This can allow an attacker to corrupt memory, which can result in code execution under the context of the application. An attacker must convince a victim to open a specially crafted document in order to trigger this vulnerability.
1060 CVE-2018-4038 123 Exec Code 2018-12-01 2018-12-27
6.8
None Remote Medium Not required Partial Partial Partial
An exploitable arbitrary write vulnerability exists in the open document format parser of the Atlantis Word Processor, version 3.2.7.2, while trying to null-terminate a string. A specially crafted document can allow an attacker to pass an untrusted value as a length to a constructor. This constructor will miscalculate a length and then use it to calculate the position to write a null byte. This can allow an attacker to corrupt memory, which can result in code execution under the context of the application. An attacker must convince a victim to open a specially crafted document in order to trigger this vulnerability.
1061 CVE-2018-4021 78 Exec Code 2018-12-03 2019-10-02
6.5
None Remote Low Single system Partial Partial Partial
An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_battery_mode` POST parameter.
1062 CVE-2018-4020 78 Exec Code 2018-12-03 2019-10-02
6.5
None Remote Low Single system Partial Partial Partial
An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_ac_mode` POST parameter parameter.
1063 CVE-2018-4019 78 Exec Code 2018-12-03 2019-10-02
6.5
None Remote Low Single system Partial Partial Partial
An exploitable command injection vulnerability exists in the way Netgate pfSense CE 2.4.4-RELEASE processes the parameters of a specific POST request. The attacker can exploit this and gain the ability to execute arbitrary commands on the system. An attacker needs to be able to send authenticated POST requests to the administration web interface. Command injection is possible in the `powerd_normal_mode` parameter.
1064 CVE-2018-4015 2018-12-18 2018-12-18
0.0
None ??? ??? ??? ??? ??? ???
An exploitable vulnerability exists in the HTTP client functionality of the Webroot BrightCloud SDK. The configuration of the HTTP client does not enforce a secure connection by default, resulting in a failure to validate TLS certificates. An attacker could impersonate a remote BrightCloud server to exploit this vulnerability.
1065 CVE-2018-3988 2018-12-10 2018-12-15
0.0
None ??? ??? ??? ??? ??? ???
Signal Messenger for Android 4.24.8 may expose private information when using "disappearing messages." If a user uses the photo feature available in the "attach file" menu, then Signal will leave the picture in its own cache directory, which is available to any application on the system.
1066 CVE-2018-3951 119 Exec Code Overflow 2018-12-01 2018-12-27
6.5
None Remote Low Single system Partial Partial Partial
An exploitable remote code execution vulnerability exists in the HTTP header-parsing function of the TP-Link TL-R600VPN HTTP Server. A specially crafted HTTP request can cause a buffer overflow, resulting in remote code execution on the device. An attacker can send an authenticated HTTP request to trigger this vulnerability.
1067 CVE-2018-3854 200 +Info 2018-12-03 2019-10-02
3.6
None Local Low Not required Partial Partial None
An exploitable information disclosure vulnerability exists in the password protection functionality of Quicken Deluxe 2018 for Mac version 5.2.2. A specially crafted sqlite3 request can cause the removal of the password protection, allowing an attacker to access and modify the data without knowing the password. An attacker needs to have access to the password-protected files to trigger this vulnerability.
1068 CVE-2018-3705 732 DoS 2018-12-13 2019-10-02
2.1
None Local Low Not required None None Partial
Improper directory permissions in the installer for the Intel(R) System Defense Utility (all versions) may allow authenticated users to potentially enable a denial of service via local access.
1069 CVE-2018-3704 732 2018-12-13 2019-10-02
4.6
None Local Low Not required Partial Partial Partial
Improper directory permissions in the installer for the Intel Parallel Studio before 2019 Gold may allow authenticated users to potentially enable an escalation of privilege via local access.
1070 CVE-2018-2505 79 XSS 2018-12-11 2019-01-07
4.3
None Remote Medium Not required None Partial None
SAP Commerce does not sufficiently validate user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability in storefronts that are based on the product. Fixed in versions (SAP Hybris Commerce, versions 6.2, 6.3, 6.4, 6.5, 6.6, 6.7).
1071 CVE-2018-2504 79 XSS 2018-12-11 2019-01-07
4.3
None Remote Medium Not required None Partial None
SAP NetWeaver AS Java Web Container service does not validate against whitelist the HTTP host header which can result in HTTP Host Header Manipulation or Cross-Site Scripting (XSS) vulnerability. This is fixed in versions 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50.
1072 CVE-2018-2503 862 2018-12-11 2019-10-02
3.3
None Local Network Low Not required Partial None None
By default, the SAP NetWeaver AS Java keystore service does not sufficiently restrict the access to resources that should be protected. This has been fixed in SAP NetWeaver AS Java (ServerCore versions 7.11, 7.20, 7.30, 7.31, 7.40, 7.50).
1073 CVE-2018-2502 79 XSS 2018-12-11 2019-01-07
4.3
None Remote Medium Not required None Partial None
TRACE method is enabled in SAP Business One Service Layer . Attacker can use XST (Cross Site Tracing) attack if frontend applications that are using Service Layer has a XSS vulnerability. This has been fixed in SAP Business One Service Layer (B1_ON_HANA, versions 9.2, 9.3).
1074 CVE-2018-2500 200 +Info 2018-12-11 2019-01-04
1.9
None Local Medium Not required Partial None None
Under certain conditions SAP Mobile Secure Android client (before version 6.60.19942.0 SP28 1711) allows an attacker to access information which would otherwise be restricted.
1075 CVE-2018-2497 20 2018-12-11 2019-01-07
4.0
None Remote Low Single system None Partial None
The security audit log of SAP HANA, versions 1.0 and 2.0, does not log SELECT events if these events are part of a statement with the syntax CREATE TABLE <table_name> AS SELECT.
1076 CVE-2018-2494 863 2018-12-11 2019-10-02
6.5
None Remote Low Single system Partial Partial Partial
Necessary authorization checks for an authenticated user, resulting in escalation of privileges, have been fixed in SAP Basis AS ABAP of SAP NetWeaver 700 to 750, from 750 onwards delivered as ABAP Platform.
1077 CVE-2018-2492 20 2018-12-11 2019-01-08
5.5
None Remote Low Single system None Partial Partial
SAML 2.0 functionality in SAP NetWeaver AS Java, does not sufficiently validate XML documents received from an untrusted source. This is fixed in versions 7.2, 7.30, 7.31, 7.40 and 7.50.
1078 CVE-2018-2486 79 XSS 2018-12-11 2019-01-07
3.5
None Remote Medium Single system None Partial None
SAP Marketing (UICUAN (1.20, 1.30, 1.40), SAPSCORE (1.13, 1.14)) does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.
1079 CVE-2018-1977 20 DoS 2018-12-14 2019-10-09
4.0
None Remote Low Single system None None Partial
IBM DB2 for Linux, UNIX and Windows 11.1 (includes DB2 Connect Server) contains a denial of service vulnerability. A remote, authenticated DB2 user could exploit this vulnerability by issuing a specially-crafted SELECT statement with TRUNCATE function. IBM X-Force ID: 154032.
1080 CVE-2018-1973 269 2018-12-20 2019-10-09
9.0
Admin Remote Low Single system Complete Complete Complete
IBM API Connect 5.0.0.0 through 5.0.8.4 allows a user with limited 'API Administrator level access to give themselves full 'Administrator' level access through the members functionality. IBM X-Force ID: 153914.
1081 CVE-2018-1957 200 +Info 2018-12-10 2019-10-09
2.1
None Local Low Not required Partial None None
IBM WebSphere Application Server 9 could allow sensitive information to be available caused by mishandling of data by the application based on an incorrect return by the httpServletRequest#authenticate() API when an unprotected URI is accessed. IBM X-Force ID: 153629.
1082 CVE-2018-1941 269 2018-12-05 2019-10-09
4.6
None Local Low Not required Partial Partial Partial
IBM Campaign 9.1.0 and 9.1.2 could allow a local user to obtain admini privileges due to the application not validating access permissions. IBM X-Force ID: 153382.
1083 CVE-2018-1935 200 +Info 2018-12-06 2019-10-09
4.0
None Remote Low Single system Partial None None
IBM Connections 5.0, 5.5, and 6.0 could allow an authenticated user to obtain sensitive information from invalid request error messages. IBM X-Force ID: 153315.
1084 CVE-2018-1926 352 CSRF 2018-12-12 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 Admin Console is vulnerable to cross-site request forgery, caused by improper validation of user-supplied input. By persuading a user to visit a malicious URL, a remote attacker could send a specially-crafted request. An attacker could exploit this vulnerability to perform CSRF attack and update available applications. IBM X-Force ID: 152992.
1085 CVE-2018-1920 611 2018-12-07 2019-10-09
5.5
None Remote Low Single system Partial None Partial
IBM Marketing Platform 9.1.0, 9.1.2 and 10.1 is vulnerable to a XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources. IBM X-Force ID: 152855.
1086 CVE-2018-1904 502 Exec Code 2018-12-11 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 could allow remote attackers to execute arbitrary Java code through an administrative client class with a serialized object from untrusted sources. IBM X-Force ID: 152533.
1087 CVE-2018-1901 +Priv 2018-12-12 2019-10-09
6.5
None Remote Low Single system Partial Partial Partial
IBM WebSphere Application Server 8.5 and 9.0 could allow a remote attacker to temporarily gain elevated privileges on the system, caused by incorrect cached value being used. IBM X-Force ID: 152530.
1088 CVE-2018-1900 79 XSS 2018-12-11 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Curam Social Program Management 6.0.5, 6.1.1, 6.2.0, 7.0.1, and 7.0.3 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 152529.
1089 CVE-2018-1896 74 2018-12-07 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Connections 5.0, 5.5, and 6.0 is vulnerable to possible host header injection attack that could cause navigation to the attacker's domain. IBM X-Force ID: 152456.
1090 CVE-2018-1891 79 XSS 2018-12-17 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Security Guardium 10 and 10.5 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 152082.
1091 CVE-2018-1889 79 XSS 2018-12-17 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Security Guardium 10.0 and 10.5 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 152080.
1092 CVE-2018-1887 798 2018-12-13 2019-10-09
4.6
None Local Low Not required Partial Partial Partial
IBM Security Access Manager Appliance 9.0.1.0, 9.0.2.0, 9.0.3.0, 9.0.4.0, and 9.0.5.0 contains hard-coded credentials, such as a password or cryptographic key, which it uses for its own inbound authentication, outbound communication to external components, or encryption of internal data. IBM X-Force ID: 152078.
1093 CVE-2018-1886 200 +Info 2018-12-13 2019-10-09
5.0
None Remote Low Not required Partial None None
IBM Security Access Manager Appliance 9.0.1.0, 9.0.2.0, 9.0.3.0, 9.0.4.0, and 9.0.5.0 discloses sensitive information to unauthorized users. The information can be used to mount further attacks on the system. IBM X-Force ID: 152021.
1094 CVE-2018-1883 DoS 2018-12-07 2019-10-09
5.0
None Remote Low Not required None None Partial
A problem within the IBM MQ 9.0.2, 9.0.3, 9.0.4, 9.0.5, and 9.1.0.0 Console REST API Could allow attackers to execute a denial of service attack preventing users from logging into the MQ Console REST API. IBM X-Force ID: 151969.
1095 CVE-2018-1871 79 XSS 2018-12-06 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Financial Transaction Manager for Digital Payments for Multi-Platform 3.0.0, 3.0.2, and 3.0.5 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 151329.
1096 CVE-2018-1848 79 XSS 2018-12-14 2019-10-09
4.3
None Remote Medium Not required None Partial None
IBM Business Automation Workflow 18.0.0.0 and 18.0.0.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 150947.
1097 CVE-2018-1840 668 +Priv 2018-12-03 2019-10-09
6.8
None Remote Medium Not required Partial Partial Partial
IBM WebSphere Application Server 8.5 and 9.0 could allow a remote attacker to gain elevated privileges on the system, caused when a security domain is configured to use a federated repository other than global federated repository and then migrated to a newer release of WebSphere Application Server. IBM X-Force ID: 150813.
1098 CVE-2018-1833 20 2018-12-18 2019-10-09
3.5
None Remote Medium Single system None Partial None
IBM Event Streams 2018.3.0 could allow a remote attacker to submit an API request with a fake Host request header. An attacker, who has already gained authorised access via the CLI, could exploit this vulnerability to spoof the request header. IBM X-Force ID: 150507.
1099 CVE-2018-1821 611 2018-12-13 2019-10-09
6.4
None Remote Low Not required Partial None Partial
IBM Operational Decision Management 8.5, 8.6, 8.7, 8.8, and 8.9 is vulnerable to a XML External Entity Injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources. IBM X-Force ID: 150170.
1100 CVE-2018-1818 798 2018-12-13 2019-10-09
7.5
None Remote Low Not required Partial Partial Partial
IBM Security Guardium 10 and 10.5 contains hard-coded credentials, such as a password or cryptographic key, which it uses for its own inbound authentication, outbound communication to external components, or encryption of internal data. IBM X-Force ID: 150022.
Total number of vulnerabilities : 1160   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 (This Page)23 24
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.