CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 7 and 7.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
9601 CVE-2017-9226 787 Mem. Corr. 2017-05-24 2018-10-31
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A heap out-of-bounds write or read occurs in next_state_val() during regular expression compilation. Octal numbers larger than 0xff are not handled correctly in fetch_token() and fetch_token_in_cc(). A malformed regular expression containing an octal number in the form of '\700' would produce an invalid code point value larger than 0xff in next_state_val(), resulting in an out-of-bounds write memory corruption.
9602 CVE-2017-9225 787 Overflow 2017-05-24 2017-06-02
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A stack out-of-bounds write in onigenc_unicode_get_case_fold_codes_by_str() occurs during regular expression compilation. Code point 0xFFFFFFFF is not properly handled in unicode_unfold_key(). A malformed regular expression could result in 4 bytes being written off the end of a stack buffer of expand_case_fold_string() during the call to onigenc_unicode_get_case_fold_codes_by_str(), a typical stack buffer overflow.
9603 CVE-2017-9224 125 2017-05-24 2018-10-31
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A stack out-of-bounds read occurs in match_at() during regular expression searching. A logical error involving order of validation and access in match_at() could result in an out-of-bounds read from a stack buffer.
9604 CVE-2017-9222 835 DoS 2017-06-27 2019-10-03
7.1
None Remote Medium Not required None None Complete
The mp4ff_parse_tag function in common/mp4ff/mp4meta.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.7 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted mp4 file.
9605 CVE-2017-9214 191 2017-05-23 2021-02-25
7.5
None Remote Low Not required Partial Partial Partial
In Open vSwitch (OvS) 2.7.0, while parsing an OFPT_QUEUE_GET_CONFIG_REPLY type OFP 1.0 message, there is a buffer over-read that is caused by an unsigned integer underflow in the function `ofputil_pull_queue_get_config_reply10` in `lib/ofp-util.c`.
9606 CVE-2017-9212 134 2017-05-23 2019-10-03
7.8
None Remote Low Not required None None Complete
The Bluetooth stack on the BMW 330i 2011 allows a remote crash of the CD/Multimedia software via %x or %c format string specifiers in a device name.
9607 CVE-2017-9200 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:528:63.
9608 CVE-2017-9199 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:192:19.
9609 CVE-2017-9198 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:508:18.
9610 CVE-2017-9197 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-tga.c:498:55.
9611 CVE-2017-9196 190 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "negative-size-param" issue in the ReadImage function in input-tga.c:528:7.
9612 CVE-2017-9195 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:620:27.
9613 CVE-2017-9194 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:559:29.
9614 CVE-2017-9193 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-tga.c:538:33.
9615 CVE-2017-9192 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-tga.c:528:7.
9616 CVE-2017-9191 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the rle_fread function in input-tga.c:252:15.
9617 CVE-2017-9188 20 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "left shift ... cannot be represented in type int" issue in input-bmp.c:516:63.
9618 CVE-2017-9187 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:486:7.
9619 CVE-2017-9186 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:326:17.
9620 CVE-2017-9185 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:319:7.
9621 CVE-2017-9184 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:314:7.
9622 CVE-2017-9183 704 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in input-bmp.c:309:7.
9623 CVE-2017-9173 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:497:29.
9624 CVE-2017-9172 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:496:29.
9625 CVE-2017-9171 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the ReadImage function in input-bmp.c:492:24.
9626 CVE-2017-9170 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:370:25.
9627 CVE-2017-9169 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:355:25.
9628 CVE-2017-9168 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:353:25.
9629 CVE-2017-9167 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the ReadImage function in input-bmp.c:337:25.
9630 CVE-2017-9166 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:18:11.
9631 CVE-2017-9165 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:17:11.
9632 CVE-2017-9164 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the GET_COLOR function in color.c:16:11.
9633 CVE-2017-9163 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in pxl-outline.c:106:54.
9634 CVE-2017-9162 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in autotrace.c:191:2.
9635 CVE-2017-9161 190 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a "cannot be represented in type int" issue in autotrace.c:188:23.
9636 CVE-2017-9160 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a stack-based buffer overflow in the pnmscanner_gettoken function in input-pnm.c:458:12.
9637 CVE-2017-9153 119 Overflow 2017-05-23 2019-03-19
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the pnm_load_rawpbm function in input-pnm.c:391:13.
9638 CVE-2017-9152 125 2017-05-23 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer over-read in the pnm_load_raw function in input-pnm.c:346:41.
9639 CVE-2017-9151 119 Overflow 2017-05-23 2017-05-28
7.5
None Remote Low Not required Partial Partial Partial
libautotrace.a in AutoTrace 0.31.1 has a heap-based buffer overflow in the pnm_load_ascii function in input-pnm.c:303:12.
9640 CVE-2017-9148 287 Bypass 2017-05-29 2018-01-05
7.5
None Remote Low Not required Partial Partial Partial
The TLS session cache in FreeRADIUS 2.1.1 through 2.1.7, 3.0.x before 3.0.14, 3.1.x before 2017-02-04, and 4.0.x before 2017-02-04 fails to reliably prevent resumption of an unauthenticated session, which allows remote attackers (such as malicious 802.1X supplicants) to bypass authentication via PEAP or TTLS.
9641 CVE-2017-9138 119 Overflow Bypass 2017-05-21 2017-06-02
7.7
None Local Network Low ??? Complete Complete Complete
There is a debug-interface vulnerability on some Tenda routers (FH1202/F1202/F1200: versions before 1.2.0.20). After connecting locally to a router in a wired or wireless manner, one can bypass intended access restrictions by sending shell commands directly and reading their results, or by entering shell commands that change this router's username and password.
9642 CVE-2017-9137 1188 2017-05-21 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
Ceragon FibeAir IP-10 wireless radios through 7.2.0 have a default password of mateidu for the mateidu account (a hidden user account established by the vendor). This account can be accessed via both the web interface and SSH. In the web interface, this simply grants an attacker read-only access to the device's settings. However, when using SSH, this gives an attacker access to a Linux shell. NOTE: the vendor has commented "The mateidu user is a known user, which is mentioned in the FibeAir IP-10 User Guide. Customers are instructed to change the mateidu user password. Changing the user password fully solves the vulnerability."
9643 CVE-2017-9136 327 2017-05-21 2019-10-03
7.8
None Remote Low Not required Complete None None
An issue was discovered on Mimosa Client Radios before 2.2.3. In the device's web interface, there is a page that allows an attacker to use an unsanitized GET parameter to download files from the device as the root user. The attacker can download any file from the device's filesystem. This can be used to view unsalted, MD5-hashed administrator passwords, which can then be cracked, giving the attacker full admin access to the device's web interface. This vulnerability can also be used to view the plaintext pre-shared key (PSK) for encrypted wireless connections, or to view the device's serial number (which allows an attacker to factory reset the device).
9644 CVE-2017-9122 835 DoS 2017-06-12 2020-09-28
7.1
None Remote Medium Not required None None Complete
The quicktime_read_moov function in moov.c in libquicktime 1.2.4 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted mp4 file.
9645 CVE-2017-9120 190 DoS Overflow 2018-08-02 2019-08-19
7.5
None Remote Low Not required Partial Partial Partial
PHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.
9646 CVE-2017-9119 400 DoS 2017-05-21 2019-03-19
7.5
None Remote Low Not required Partial Partial Partial
The i_zval_ptr_dtor function in Zend/zend_variables.h in PHP 7.1.5 allows attackers to cause a denial of service (memory consumption and application crash) or possibly have unspecified other impact by triggering crafted operations on array data structures.
9647 CVE-2017-9117 125 2017-05-21 2019-10-03
7.5
None Remote Low Not required Partial Partial Partial
In LibTIFF 4.0.7, the program processes BMP images without verifying that biWidth and biHeight in the bitmap-information header match the actual input, leading to a heap-based buffer over-read in bmp2tiff.
9648 CVE-2017-9109 119 Overflow 2020-06-18 2020-07-02
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in adns before 1.5.2. It fails to ignore apparent answers before the first RR that was found the first time. when this is fixed, the second answer scan finds the same RRs at the first. Otherwise, adns can be confused by interleaving answers for the CNAME target, with the CNAME itself. In that case the answer data structure (on the heap) can be overrun. With this fixed, it prefers to look only at the answer RRs which come after the CNAME, which is at least arguably correct.
9649 CVE-2017-9105 476 Exec Code 2020-06-18 2020-07-02
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in adns before 1.5.2. It corrupts a pointer when a nameserver speaks first because of a wrong number of pointer dereferences. This bug may well be exploitable as a remote code execution.
9650 CVE-2017-9104 400 2020-06-18 2020-07-02
7.5
None Remote Low Not required Partial Partial Partial
An issue was discovered in adns before 1.5.2. It hangs, eating CPU, if a compression pointer loop is encountered.
Total number of vulnerabilities : 32054   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 (This Page)194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.