CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Security Vulnerabilities (CVSS score between 7 and 7.99)

Press ESC to close
# CVE ID CWE ID # of Exploits Vulnerability Type(s) Publish Date Update Date Score Gained Access Level Access Complexity Authentication Conf. Integ. Avail.
3101 CVE-2017-1000232 415 2017-11-16 2017-11-29
7.5
None Remote Low Not required Partial Partial Partial
A double-free vulnerability in str2host.c in ldns 1.7.0 have unspecified impact and attack vectors.
3102 CVE-2017-1000231 415 2017-11-16 2018-02-03
7.5
None Remote Low Not required Partial Partial Partial
A double-free vulnerability in parse.c in ldns 1.7.0 have unspecified impact and attack vectors.
3103 CVE-2017-1000220 77 Exec Code 2017-11-16 2017-11-29
7.5
None Remote Low Not required Partial Partial Partial
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
3104 CVE-2017-1000219 77 Exec Code 2017-11-16 2017-12-04
7.5
None Remote Low Not required Partial Partial Partial
npm/KyleRoss windows-cpu all versions vulnerable to command injection resulting in code execution as Node.js user
3105 CVE-2017-1000218 119 DoS Exec Code Overflow 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
LightFTP version 1.1 is vulnerable to a buffer overflow in the "writelogentry" function resulting a denial of services or a remote code execution.
3106 CVE-2017-1000212 264 Exec Code 2017-11-17 2017-12-06
7.5
None Remote Low Not required Partial Partial Partial
Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled alchemist-server. A malicious website can execute requests against an ephemeral port on localhost that are then evaluated as elixir code.
3107 CVE-2017-1000210 119 DoS Exec Code Overflow 2017-11-16 2017-11-29
7.5
None Remote Low Not required Partial Partial Partial
picoTCP (versions 1.7.0 - 1.5.0) is vulnerable to stack buffer overflow resulting in code execution or denial of service attack
3108 CVE-2017-1000206 119 Exec Code Overflow 2017-11-17 2017-12-01
7.5
None Remote Low Not required Partial Partial Partial
samtools htslib library version 1.4.0 and earlier is vulnerable to buffer overflow in the CRAM rANS codec resulting in potential arbitrary code execution
3109 CVE-2017-1000197 417 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
October CMS build 412 is vulnerable to file path modification in asset move functionality resulting in creating creating malicious files on the server.
3110 CVE-2017-1000196 94 Exec Code 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
October CMS build 412 is vulnerable to PHP code execution in the asset manager functionality resulting in site compromise and possibly other applications on the server.
3111 CVE-2017-1000194 434 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
October CMS build 412 is vulnerable to Apache configuration modification via file upload functionality resulting in site compromise and possibly other applications on the server.
3112 CVE-2017-1000191 400 2017-11-17 2017-12-04
7.8
None Remote Low Not required None None Complete
Jool 3.5.0-3.5.1 is vulnerable to a kernel crashing packet resulting in a DOS.
3113 CVE-2017-1000173 119 Exec Code Overflow 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity Version: 1.0 Heap Overflow Potential Code Execution. By creating a large loop whiling pushing data to a buffer, we can break out of the bounds checking of that buffer. When list.join is called on the data it will read past a buffer resulting in a Heap-Buffer-Overflow.
3114 CVE-2017-1000172 416 Exec Code 2017-11-16 2017-11-30
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity Version: 1.0 Use-After-Free Possible code execution. An example of a Heap-Use-After-Free after the 'sublexer' pointer has been freed. Line 542 of gravity_lexer.c. 'lexer' is being used to access a variable but 'lexer' has already been freed, creating a Heap Use-After-Free condition.
3115 CVE-2017-1000158 119 Exec Code Overflow 2017-11-17 2019-05-08
7.5
None Remote Low Not required Partial Partial Partial
CPython (aka Python) up to 2.7.13 is vulnerable to an integer overflow in the PyString_DecodeEscape function in stringobject.c, resulting in heap-based buffer overflow (and possible arbitrary code execution)
3116 CVE-2017-1000154 287 2017-11-03 2017-11-13
7.5
None Remote Low Not required Partial Partial Partial
Mahara 15.04 before 15.04.8 and 15.10 before 15.10.4 and 16.04 before 16.04.2 are vulnerable to some authentication methods, which do not use Mahara's built-in login form, still allowing users to log in even if their institution was expired or suspended.
3117 CVE-2017-1000153 284 2017-11-03 2017-11-13
7.5
None Remote Low Not required Partial Partial Partial
Mahara 15.04 before 15.04.10 and 15.10 before 15.10.6 and 16.04 before 16.04.4 are vulnerable to incorrect access control after the password reset link is sent via email and then user changes default email, Mahara fails to invalidate old link.Consequently the link in email can be used to gain access to the user's account.
3118 CVE-2017-1000152 284 2017-11-03 2017-11-13
7.5
None Remote Low Not required Partial Partial Partial
Mahara 15.04 before 15.04.7 and 15.10 before 15.10.3 running PHP 5.3 are vulnerable to one user being logged in as another user on a separate computer as the same session ID is served. This situation can occur when a user takes an action that forces another user to be logged out of Mahara, such as an admin changing another user's account settings.
3119 CVE-2017-1000121 190 Overflow 2017-11-01 2017-11-21
7.5
None Remote Low Not required Partial Partial Partial
The UNIX IPC layer in WebKit, including WebKitGTK+ prior to 2.16.3, does not properly validate message size metadata, allowing a compromised secondary process to trigger an integer overflow and subsequent buffer overflow in the UI process. This vulnerability does not affect Apple products.
3120 CVE-2017-1000111 264 2017-10-04 2019-04-26
7.2
None Local Low Not required Complete Complete Complete
Linux kernel: heap out-of-bounds in AF_PACKET sockets. This new issue is analogous to previously disclosed CVE-2016-8655. In both cases, a socket option that changes socket state may race with safety checks in packet_set_ring. Previously with PACKET_VERSION. This time with PACKET_RESERVE. The solution is similar: lock the socket for the update. This issue may be exploitable, we did not investigate further. As this issue affects PF_PACKET sockets, it requires CAP_NET_RAW in the process namespace. But note that with user namespaces enabled, any process can create a namespace in which it has CAP_NET_RAW.
3121 CVE-2017-1000075 119 Overflow 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity version 1.0 is vulnerable to a stack overflow in the memcmp function
3122 CVE-2017-1000074 119 Overflow 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity version 1.0 is vulnerable to a stack overflow in the string_repeat() function.
3123 CVE-2017-1000073 119 Exec Code Overflow 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity version 1.0 is vulnerable to a heap overflow in an undisclosed component that can result in arbitrary code execution.
3124 CVE-2017-1000072 415 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
Creolabs Gravity version 1.0 is vulnerable to a Double Free in gravity_value resulting potentially leading to modification of unexpected memory locations
3125 CVE-2017-1000056 264 2017-07-17 2017-08-04
7.5
None Remote Low Not required Partial Partial Partial
Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.
3126 CVE-2017-1000047 22 Exec Code Dir. Trav. 2017-07-17 2017-07-21
7.5
None Remote Low Not required Partial Partial Partial
rbenv (all current versions) is vulnerable to Directory Traversal in the specification of Ruby version resulting in arbitrary code execution
3127 CVE-2017-1000044 119 Overflow Mem. Corr. 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
gtk-vnc 0.4.2 and older doesn't check framebuffer boundaries correctly when updating framebuffer which may lead to memory corruption when rendering
3128 CVE-2017-1000039 20 Exec Code 2017-07-17 2017-07-19
7.5
None Remote Low Not required Partial Partial Partial
Framadate version 1.0 is vulnerable to Formula Injection in the CSV Export resulting possible Information Disclosure and Code Execution
3129 CVE-2017-1000037 77 Exec Code 2017-07-17 2017-08-15
7.5
None Remote Low Not required Partial Partial Partial
RVM automatically loads environment variables from files in $PWD resulting in command execution RVM vulnerable to command injection when automatically loading environment variables from files in $PWD RVM automatically executes hooks located in $PWD resulting in code execution RVM automatically installs gems as specified by files in $PWD resulting in code execution RVM automatically does "bundle install" on a Gemfile specified by .versions.conf in $PWD resulting in code execution
3130 CVE-2017-1000022 284 2017-07-17 2018-09-05
7.5
None Remote Low Not required Partial Partial Partial
LogicalDoc Community Edition 7.5.3 and prior contain an Incorrect access control which could leave to privilege escalation.
3131 CVE-2017-1000021 611 2017-07-17 2018-09-05
7.5
None Remote Low Not required Partial Partial Partial
LogicalDoc Community Edition 7.5.3 and prior is vulnerable to XXE when indexing XML documents.
3132 CVE-2017-1000009 77 2017-07-17 2017-08-08
7.5
None Remote Low Not required Partial Partial Partial
Akeneo PIM CE and EE <1.6.6, <1.5.15, <1.4.28 are vulnerable to shell injection in the mass edition, resulting in remote execution.
3133 CVE-2017-1000004 89 Exec Code Sql 2017-07-17 2017-08-04
7.5
None Remote Low Not required Partial Partial Partial
ATutor version 2.2.1 and earlier are vulnerable to a SQL injection in the Assignment Dropbox, BasicLTI, Blog Post, Blog, Group Course Email, Course Alumni, Course Enrolment, Group Membership, Course unenrolment, Course Enrolment List Search, Glossary, Social Group Member Search, Social Friend Search, Social Group Search, File Comment, Gradebook Test Title, User Group Membership, Inbox/Sent Items, Sent Messages, Links, Photo Album, Poll, Social Application, Social Profile, Test, Content Menu, Auto-Login, and Gradebook components resulting in information disclosure, database modification, or potential code execution.
3134 CVE-2017-1000003 264 2017-07-17 2019-05-10
7.5
None Remote Low Not required Partial Partial Partial
ATutor versions 2.2.1 and earlier are vulnerable to an incorrect access control check vulnerability in the Social Application component resulting in privilege escalation. ATutor versions 2.2.1 and earlier are vulnerable to an incorrect access control check vulnerability in the Module component resulting in privilege escalation. ATutor versions 2.2.1 and earlier are vulnerable to a incorrect access control check vulnerability in the Alternative Content component resulting in privilege escalation.
3135 CVE-2017-1000002 22 Exec Code Dir. Trav. Bypass 2017-07-17 2017-07-27
7.5
None Remote Low Not required Partial Partial Partial
ATutor versions 2.2.1 and earlier are vulnerable to a directory traversal and file extension check bypass in the Course component resulting in code execution. ATutor versions 2.2.1 and earlier are vulnerable to a directory traversal vulnerability in the Course Icon component resulting in information disclosure.
3136 CVE-2017-18548 89 Sql 2019-08-16 2019-08-16
7.5
None Remote Low Not required Partial Partial Partial
The note-press plugin before 0.1.2 for WordPress has SQL injection.
3137 CVE-2017-18515 89 Sql 2019-08-14 2019-08-16
7.5
None Remote Low Not required Partial Partial Partial
The wp-statistics plugin before 12.0.8 for WordPress has SQL injection.
3138 CVE-2017-18514 89 Sql 2019-08-14 2019-08-16
7.5
None Remote Low Not required Partial Partial Partial
The simple-login-log plugin before 1.1.2 for WordPress has SQL injection.
3139 CVE-2017-18463 20 Exec Code 2019-08-02 2019-08-06
7.2
None Local Low Not required Complete Complete Complete
cPanel before 62.0.17 allows code execution in the context of the root account via a long DocumentRoot path (SEC-225).
3140 CVE-2017-18460 20 Exec Code 2019-08-02 2019-08-07
7.2
None Local Low Not required Complete Complete Complete
cPanel before 62.0.17 allows arbitrary code execution during automatic SSL installation (SEC-221).
3141 CVE-2017-18459 20 Exec Code 2019-08-02 2019-08-07
7.2
None Local Low Not required Complete Complete Complete
cPanel before 62.0.17 allows arbitrary code execution during account modification (SEC-220).
3142 CVE-2017-18435 434 Exec Code 2019-08-02 2019-08-09
7.5
None Remote Low Not required Partial Partial Partial
cPanel before 64.0.21 allows demo accounts to execute code via the BoxTrapper API (SEC-238).
3143 CVE-2017-18434 20 Exec Code 2019-08-02 2019-08-09
7.2
None Local Low Not required Complete Complete Complete
cPanel before 64.0.21 allows code execution in the context of the root account via a SET_VHOST_LANG_PACKAGE multilang adminbin call (SEC-237).
3144 CVE-2017-18400 77 Exec Code 2019-08-02 2019-08-13
7.2
None Local Low Not required Complete Complete Complete
cPanel before 68.0.15 allows local root code execution via cpdavd (SEC-333).
3145 CVE-2017-18390 275 Exec Code 2019-08-02 2019-08-08
7.2
None Local Low Not required Complete Complete Complete
cPanel before 68.0.15 allows code execution in the context of the root account because of weak permissions on incremental backups (SEC-322).
3146 CVE-2017-18388 20 2019-08-02 2019-08-09
7.2
None Local Low Not required Complete Complete Complete
cPanel before 68.0.15 can perform unsafe file operations because Jailshell does not set the umask (SEC-315).
3147 CVE-2017-18379 119 Overflow 2019-07-27 2019-07-31
7.5
None Remote Low Not required Partial Partial Partial
In the Linux kernel before 4.14, an out of boundary access happened in drivers/nvme/target/fc.c.
3148 CVE-2017-18378 77 Exec Code 2019-06-11 2019-06-12
7.5
None Remote Low Not required Partial Partial Partial
In NETGEAR ReadyNAS Surveillance before 1.4.3-17 x86 and before 1.1.4-7 ARM, $_GET['uploaddir'] is not escaped and is passed to system() through $tmp_upload_dir, leading to upgrade_handle.php?cmd=writeuploaddir remote command execution.
3149 CVE-2017-18371 798 2019-05-02 2019-05-03
7.5
None Remote Low Not required Partial Partial Partial
The ZyXEL P660HN-T1A v2 TCLinux Fw #7.3.37.6 router distributed by TrueOnline has three user accounts with default passwords, including two hardcoded service accounts: one with the username true and password true, and another with the username supervisor and password zyad1234. These accounts can be used to login to the web interface, exploit authenticated command injections, and change router settings for malicious purposes.
3150 CVE-2017-18365 502 Exec Code 2019-03-28 2019-03-29
7.5
None Remote Low Not required Partial Partial Partial
The Management Console in GitHub Enterprise 2.8.x before 2.8.7 has a deserialization issue that allows unauthenticated remote attackers to execute arbitrary code. This occurs because the enterprise session secret is always the same, and can be found in the product's source code. By sending a crafted cookie signed with this secret, one can call Marshal.load with arbitrary data, which is a problem because the Marshal data format allows Ruby objects.
Total number of vulnerabilities : 26271   Page : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 (This Page)64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526
CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.