Integer overflow in the license_read_scope_list function in libfreerdp/core/license.c in FreeRDP through 1.0.2 allows remote RDP servers to cause a denial of service (application crash) or possibly have unspecified other impact via a large ScopeCount value in a Scope List in a Server License Request packet.
Max CVSS
6.8
EPSS Score
1.25%
Published
2014-01-03
Updated
2020-08-30
In FreeRDP greater than 1.1 and before 2.0.0, there is an out-of-bounds read in update_read_icon_info. It allows reading a attacker-defined amount of client memory (32bit unsigned -> 4GB) to an intermediate buffer. This can be used to crash the client or store information for later retrieval. This has been patched in 2.0.0.
Max CVSS
5.9
EPSS Score
0.85%
Published
2020-05-07
Updated
2023-10-24
In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bound read in in update_read_bitmap_data that allows client memory to be read to an image buffer. The result displayed on screen as colour.
Max CVSS
4.9
EPSS Score
0.28%
Published
2020-05-07
Updated
2023-10-24
In FreeRDP after 1.0 and before 2.0.0, there is a stream out-of-bounds seek in update_read_synchronize that could lead to a later out-of-bounds read.
Max CVSS
5.5
EPSS Score
0.15%
Published
2020-05-07
Updated
2023-10-24
In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.
Max CVSS
3.5
EPSS Score
0.31%
Published
2020-05-07
Updated
2023-10-24
In FreeRDP after 1.1 and before 2.0.0, a stream out-of-bounds seek in rdp_read_font_capability_set could lead to a later out-of-bounds read. As a result, a manipulated client or server might force a disconnect due to an invalid data read. This has been fixed in 2.0.0.
Max CVSS
3.5
EPSS Score
0.20%
Published
2020-05-12
Updated
2023-10-24
libfreerdp/codec/planar.c in FreeRDP version > 1.0 through 2.0.0-rc4 has an Out-of-bounds Write.
Max CVSS
6.6
EPSS Score
0.37%
Published
2020-05-15
Updated
2022-04-26
libfreerdp/gdi/gdi.c in FreeRDP > 1.0 through 2.0.0-rc4 has an Out-of-bounds Read.
Max CVSS
6.5
EPSS Score
0.49%
Published
2020-05-15
Updated
2022-07-30
libfreerdp/gdi/region.c in FreeRDP versions > 1.0 through 2.0.0-rc4 has an Integer Overflow.
Max CVSS
6.6
EPSS Score
1.48%
Published
2020-05-15
Updated
2022-07-30
libfreerdp/cache/bitmap.c in FreeRDP versions > 1.0 through 2.0.0-rc4 has an Out of bounds read.
Max CVSS
3.5
EPSS Score
0.34%
Published
2020-05-15
Updated
2022-07-30
libfreerdp/core/update.c in FreeRDP versions > 1.1 through 2.0.0-rc4 has an Out-of-bounds Read.
Max CVSS
3.5
EPSS Score
0.13%
Published
2020-05-15
Updated
2022-04-26
An issue was discovered in FreeRDP before 2.1.1. An out-of-bounds (OOB) read vulnerability has been detected in ntlm_read_ChallengeMessage in winpr/libwinpr/sspi/NTLM/ntlm_message.c.
Max CVSS
7.1
EPSS Score
0.13%
Published
2020-05-22
Updated
2023-10-24
An issue was discovered in FreeRDP before 2.1.1. An out-of-bounds (OOB) read vulnerability has been detected in security_fips_decrypt in libfreerdp/core/security.c due to an uninitialized value.
Max CVSS
5.5
EPSS Score
0.05%
Published
2020-05-22
Updated
2023-10-24
An issue was discovered in FreeRDP before 2.1.1. An out-of-bounds (OOB) write vulnerability has been detected in crypto_rsa_common in libfreerdp/crypto/crypto.c.
Max CVSS
8.3
EPSS Score
0.13%
Published
2020-05-22
Updated
2023-10-24
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!