Ruby 1.6.x up to 1.6.8, 1.8.x up to 1.8.2, and 1.9.0 development up to 2005-09-01 allows attackers to bypass safe level and taint flag protections and execute disallowed code when Ruby processes a program through standard input (stdin).
Max CVSS
7.5
Published
2005-10-07
Updated
2017-10-11
EPSS
1.59%
Macromedia Flash 6 and 7 (Flash.ocx) allows remote attackers to execute arbitrary code via a SWF file with a modified frame type identifier that is used as an out-of-bounds array index to a function pointer.
Max CVSS
5.1
Published
2005-11-05
Updated
2018-10-19
EPSS
93.88%
Multiple off-by-one errors in the cURL library (libcurl) 7.11.2 through 7.15.0 allow local users to trigger a buffer overflow and cause a denial of service or bypass PHP security restrictions via certain URLs that (1) are malformed in a way that prevents a terminating null byte from being added to either a hostname or path buffer, or (2) contain a "?" separator in the hostname portion, which causes a "/" to be prepended to the resulting string.
Max CVSS
4.6
Published
2005-12-08
Updated
2018-10-19
EPSS
0.06%
Multiple unspecified vulnerabilities in Adobe Flash Player 8.0.22.0 and earlier allow remote attackers to execute arbitrary code via a crafted SWF file.
Max CVSS
5.1
Published
2006-03-15
Updated
2018-10-12
EPSS
50.92%
NSSecureTextField in AppKit in Apple Mac OS X 10.4.6 does not re-enable secure event input under certain circumstances, which could allow other applications in the window session to monitor input characters and keyboard events.
Max CVSS
2.1
Published
2006-05-12
Updated
2017-07-20
EPSS
0.26%
BOM in Apple Mac OS X 10.3.9 and 10.4.6 allows attackers to overwrite arbitrary files via an archive that contains symbolic links.
Max CVSS
2.1
Published
2006-05-12
Updated
2017-07-20
EPSS
0.08%
Integer overflow in CFNetwork in Apple Mac OS X 10.4.6 allows remote attackers to execute arbitrary code via crafted chunked transfer encoding.
Max CVSS
7.5
Published
2006-05-12
Updated
2017-07-20
EPSS
6.94%
The bundle API in CoreFoundation in Apple Mac OS X 10.3.9 and 10.4.6 loads dynamic libraries even if the client application has not directly requested it, which allows attackers to execute arbitrary code from an untrusted bundle.
Max CVSS
7.5
Published
2006-05-12
Updated
2017-07-20
EPSS
0.95%
Integer underflow in CoreFoundation in Apple Mac OS X 10.3.9 and 10.4.6 allows context-dependent attackers to execute arbitrary code via unspecified vectors involving conversions from string to file system representation within (1) CFStringGetFileSystemRepresentation or (2) getFileSystemRepresentation:maxLength:withPath in NSFileManager, and possibly other similar API functions.
Max CVSS
6.5
Published
2006-05-12
Updated
2017-07-20
EPSS
0.51%
CoreGraphics in Apple Mac OS X 10.4.6, when "Enable access for assistive devices" is on, allows an application to bypass restrictions for secure event input and read certain events from other applications in the same window session by using Quartz Event Services.
Max CVSS
2.1
Published
2006-05-12
Updated
2017-07-20
EPSS
0.06%
Buffer overflow in the FTP server (FTPServer) in Apple Mac OS X 10.3.9 and 10.4.6 allows remote authenticated users to execute arbitrary code via vectors related to "FTP server path name handling."
Max CVSS
6.5
Published
2006-05-12
Updated
2017-07-20
EPSS
1.33%
Keychain in Apple Mac OS X 10.3.9 and 10.4.6 might allow an application to bypass a locked Keychain by first obtaining a reference to the Keychain when it is unlocked, then reusing that reference after the Keychain has been locked.
Max CVSS
5.0
Published
2006-05-12
Updated
2017-07-20
EPSS
0.82%
LaunchServices in Apple Mac OS X 10.4.6 allows remote attackers to cause Safari to launch unsafe content via long file name extensions, which prevents Download Validation from determining which application will be used to open the file.
Max CVSS
5.0
Published
2006-05-12
Updated
2017-07-20
EPSS
1.09%
Finder in Apple Mac OS X 10.3.9 and 10.4.6 allows user-assisted attackers to execute arbitrary code by tricking a user into launching an Internet Location item that appears to use a safe URL scheme, but which actually has a different and more risky scheme.
Max CVSS
6.5
Published
2006-05-12
Updated
2017-07-20
EPSS
0.51%
Integer overflow in Mail in Apple Mac OS X 10.3.9 and 10.4.6 allows remote attackers to execute arbitrary code via a crafted MacMIME encapsulated attachment.
Max CVSS
7.5
Published
2006-05-12
Updated
2017-07-20
EPSS
6.94%
Mail in Apple Mac OS X 10.3.9 and 10.4.6 allows remote attackers to execute arbitrary code via an enriched text e-mail message with "invalid color information" that causes Mail to allocate and initialize arbitrary classes.
Max CVSS
7.5
Published
2006-05-12
Updated
2017-07-20
EPSS
5.33%
MySQL Manager in Apple Mac OS X 10.3.9 and 10.4.6, when setting up a new MySQL database server, does not use the "New MySQL root password" that is provided, which causes the MySQL root password to be blank and allows local users to gain full privileges to that database.
Max CVSS
7.2
Published
2006-05-12
Updated
2017-07-20
EPSS
0.06%
Stack-based buffer overflow in Preview in Apple Mac OS 10.4 up to 10.4.6 allows local users to execute arbitrary code via a deep directory hierarchy.
Max CVSS
4.6
Published
2006-05-12
Updated
2017-07-20
EPSS
0.06%
Stack-based buffer overflow in Apple QuickTime before 7.1 allows remote attackers to execute arbitrary code via a crafted QuickDraw PICT image format file containing malformed font information.
Max CVSS
5.1
Published
2006-05-12
Updated
2018-10-18
EPSS
15.06%
Heap-based buffer overflow in Apple QuickTime before 7.1 allows remote attackers to execute arbitrary code via a crafted QuickDraw PICT image format file with malformed image data.
Max CVSS
5.1
Published
2006-05-12
Updated
2018-10-18
EPSS
16.13%
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!