In NGINX Controller versions prior to 3.2.0, an unauthenticated attacker with network access to the Controller API can create unprivileged user accounts. The user which is created is only able to upload a new license to the system but cannot view or modify any other components of the system.
Max CVSS
8.6
EPSS Score
0.12%
Published
2020-03-27
Updated
2022-04-22
In versions of NGINX Controller prior to 3.2.0, communication between NGINX Controller and NGINX Plus instances skip TLS verification by default.
Max CVSS
7.4
EPSS Score
0.18%
Published
2020-04-23
Updated
2020-04-30
In versions prior to 3.3.0, the NGINX Controller is configured to communicate with its Postgres database server over unencrypted channels, making the communicated data vulnerable to interception via man-in-the-middle (MiTM) attacks.
Max CVSS
5.8
EPSS Score
0.07%
Published
2020-04-23
Updated
2022-04-26
In versions of NGINX Controller prior to 3.3.0, the helper.sh script, which is used optionally in NGINX Controller to change settings, uses sensitive items as command-line arguments.
Max CVSS
5.5
EPSS Score
0.04%
Published
2020-04-23
Updated
2020-04-30
In versions prior to 3.3.0, the NGINX Controller Agent installer script 'install.sh' uses HTTP instead of HTTPS to check and install packages
Max CVSS
8.1
EPSS Score
0.24%
Published
2020-04-23
Updated
2022-04-26
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!