CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2018-12613

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).
Publish Date : 2018-06-21 Last Update Date : 2019-04-26
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
6.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Execute CodeBypass a restriction or similar
CWE ID 287

- Products Affected By CVE-2018-12613

# Product Type Vendor Product Version Update Edition Language
1 Application Phpmyadmin Phpmyadmin 4.8.0 Version Details Vulnerabilities
2 Application Phpmyadmin Phpmyadmin 4.8.0.1 Version Details Vulnerabilities
3 Application Phpmyadmin Phpmyadmin 4.8.1 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Phpmyadmin Phpmyadmin 3

- References For CVE-2018-12613

https://www.phpmyadmin.net/security/PMASA-2018-4/ CONFIRM
https://www.exploit-db.com/exploits/44928/
EXPLOIT-DB 44928
https://www.exploit-db.com/exploits/45020/
EXPLOIT-DB 45020
https://security.gentoo.org/glsa/201904-16
GENTOO GLSA-201904-16
https://www.exploit-db.com/exploits/44924/
EXPLOIT-DB 44924
http://www.securityfocus.com/bid/104532
BID 104532 phpMyAdmin CVE-2018-12613 Remote File Inclusion Vulnerability Release Date:2018-06-19

- Metasploit Modules Related To CVE-2018-12613

phpMyAdmin Authenticated Remote Code Execution
phpMyAdmin v4.8.0 and v4.8.1 are vulnerable to local file inclusion, which can be exploited post-authentication to execute PHP code by application. The module has been tested with phpMyAdmin v4.8.1.
Module type : exploit Rank : good Platforms : PHP


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.