CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2017-15944

Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and 8.0.x before 8.0.6 allows remote attackers to execute arbitrary code via vectors involving the management interface.
Publish Date : 2017-12-11 Last Update Date : 2018-05-10
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
7.5
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Execute Code
CWE ID 264

- Products Affected By CVE-2017-15944

# Product Type Vendor Product Version Update Edition Language
1 OS Paloaltonetworks Pan-os 3.1.9 Version Details Vulnerabilities
2 OS Paloaltonetworks Pan-os 3.1.10 Version Details Vulnerabilities
3 OS Paloaltonetworks Pan-os 3.1.11 Version Details Vulnerabilities
4 OS Paloaltonetworks Pan-os 3.1.12 Version Details Vulnerabilities
5 OS Paloaltonetworks Pan-os 4.0.0 Version Details Vulnerabilities
6 OS Paloaltonetworks Pan-os 4.0.1 Version Details Vulnerabilities
7 OS Paloaltonetworks Pan-os 4.0.2 Version Details Vulnerabilities
8 OS Paloaltonetworks Pan-os 4.0.3 Version Details Vulnerabilities
9 OS Paloaltonetworks Pan-os 4.0.4 Version Details Vulnerabilities
10 OS Paloaltonetworks Pan-os 4.0.5 Version Details Vulnerabilities
11 OS Paloaltonetworks Pan-os 4.0.6 Version Details Vulnerabilities
12 OS Paloaltonetworks Pan-os 4.0.7 Version Details Vulnerabilities
13 OS Paloaltonetworks Pan-os 4.0.8 Version Details Vulnerabilities
14 OS Paloaltonetworks Pan-os 4.0.9 Version Details Vulnerabilities
15 OS Paloaltonetworks Pan-os 4.0.10 Version Details Vulnerabilities
16 OS Paloaltonetworks Pan-os 4.0.11 Version Details Vulnerabilities
17 OS Paloaltonetworks Pan-os 4.0.12 Version Details Vulnerabilities
18 OS Paloaltonetworks Pan-os 4.0.13 Version Details Vulnerabilities
19 OS Paloaltonetworks Pan-os 4.1.0 Version Details Vulnerabilities
20 OS Paloaltonetworks Pan-os 4.1.1 Version Details Vulnerabilities
21 OS Paloaltonetworks Pan-os 4.1.2 Version Details Vulnerabilities
22 OS Paloaltonetworks Pan-os 4.1.3 Version Details Vulnerabilities
23 OS Paloaltonetworks Pan-os 4.1.4 Version Details Vulnerabilities
24 OS Paloaltonetworks Pan-os 4.1.5 Version Details Vulnerabilities
25 OS Paloaltonetworks Pan-os 4.1.6 Version Details Vulnerabilities
26 OS Paloaltonetworks Pan-os 4.1.7 Version Details Vulnerabilities
27 OS Paloaltonetworks Pan-os 4.1.8 Version Details Vulnerabilities
28 OS Paloaltonetworks Pan-os 4.1.8-h3 Version Details Vulnerabilities
29 OS Paloaltonetworks Pan-os 4.1.9 Version Details Vulnerabilities
30 OS Paloaltonetworks Pan-os 4.1.10 Version Details Vulnerabilities
31 OS Paloaltonetworks Pan-os 4.1.11 Version Details Vulnerabilities
32 OS Paloaltonetworks Pan-os 4.1.12 Version Details Vulnerabilities
33 OS Paloaltonetworks Pan-os 4.1.13 Version Details Vulnerabilities
34 OS Paloaltonetworks Pan-os 5.0.0 Version Details Vulnerabilities
35 OS Paloaltonetworks Pan-os 5.0.0-h1 Version Details Vulnerabilities
36 OS Paloaltonetworks Pan-os 5.0.2 Version Details Vulnerabilities
37 OS Paloaltonetworks Pan-os 5.0.3 Version Details Vulnerabilities
38 OS Paloaltonetworks Pan-os 5.0.4 Version Details Vulnerabilities
39 OS Paloaltonetworks Pan-os 5.0.5 Version Details Vulnerabilities
40 OS Paloaltonetworks Pan-os 5.0.14 Version Details Vulnerabilities
41 OS Paloaltonetworks Pan-os 5.0.15 Version Details Vulnerabilities
42 OS Paloaltonetworks Pan-os 5.0.17 Version Details Vulnerabilities
43 OS Paloaltonetworks Pan-os 5.1 Version Details Vulnerabilities
44 OS Paloaltonetworks Pan-os 5.1.1 Version Details Vulnerabilities
45 OS Paloaltonetworks Pan-os 5.1.2 Version Details Vulnerabilities
46 OS Paloaltonetworks Pan-os 5.1.3 Version Details Vulnerabilities
47 OS Paloaltonetworks Pan-os 5.1.4 Version Details Vulnerabilities
48 OS Paloaltonetworks Pan-os 5.1.5 Version Details Vulnerabilities
49 OS Paloaltonetworks Pan-os 5.1.6 Version Details Vulnerabilities
50 OS Paloaltonetworks Pan-os 5.1.7 Version Details Vulnerabilities
51 OS Paloaltonetworks Pan-os 5.1.8 Version Details Vulnerabilities
52 OS Paloaltonetworks Pan-os 5.1.9 Version Details Vulnerabilities
53 OS Paloaltonetworks Pan-os 5.1.10 Version Details Vulnerabilities
54 OS Paloaltonetworks Pan-os 6.0 Version Details Vulnerabilities
55 OS Paloaltonetworks Pan-os 6.0.1 Version Details Vulnerabilities
56 OS Paloaltonetworks Pan-os 6.0.2 Version Details Vulnerabilities
57 OS Paloaltonetworks Pan-os 6.0.3 Version Details Vulnerabilities
58 OS Paloaltonetworks Pan-os 6.0.4 Version Details Vulnerabilities
59 OS Paloaltonetworks Pan-os 6.0.5 Version Details Vulnerabilities
60 OS Paloaltonetworks Pan-os 6.0.6 Version Details Vulnerabilities
61 OS Paloaltonetworks Pan-os 6.0.7 Version Details Vulnerabilities
62 OS Paloaltonetworks Pan-os 6.0.8 Version Details Vulnerabilities
63 OS Paloaltonetworks Pan-os 6.0.9 Version Details Vulnerabilities
64 OS Paloaltonetworks Pan-os 6.0.10 Version Details Vulnerabilities
65 OS Paloaltonetworks Pan-os 6.0.11 Version Details Vulnerabilities
66 OS Paloaltonetworks Pan-os 6.0.12 Version Details Vulnerabilities
67 OS Paloaltonetworks Pan-os 6.1.0 Version Details Vulnerabilities
68 OS Paloaltonetworks Pan-os 6.1.1 Version Details Vulnerabilities
69 OS Paloaltonetworks Pan-os 6.1.2 Version Details Vulnerabilities
70 OS Paloaltonetworks Pan-os 6.1.3 Version Details Vulnerabilities
71 OS Paloaltonetworks Pan-os 6.1.4 Version Details Vulnerabilities
72 OS Paloaltonetworks Pan-os 6.1.5 Version Details Vulnerabilities
73 OS Paloaltonetworks Pan-os 6.1.6 Version Details Vulnerabilities
74 OS Paloaltonetworks Pan-os 6.1.7 Version Details Vulnerabilities
75 OS Paloaltonetworks Pan-os 6.1.8 Version Details Vulnerabilities
76 OS Paloaltonetworks Pan-os 6.1.9 Version Details Vulnerabilities
77 OS Paloaltonetworks Pan-os 6.1.10 Version Details Vulnerabilities
78 OS Paloaltonetworks Pan-os 6.1.12 Version Details Vulnerabilities
79 OS Paloaltonetworks Pan-os 6.1.13 Version Details Vulnerabilities
80 OS Paloaltonetworks Pan-os 6.1.15 Version Details Vulnerabilities
81 OS Paloaltonetworks Pan-os 7.0.4 Version Details Vulnerabilities
82 OS Paloaltonetworks Pan-os 7.0.5-h2 Version Details Vulnerabilities
83 OS Paloaltonetworks Pan-os 7.0.8 Version Details Vulnerabilities
84 OS Paloaltonetworks Pan-os 7.0.9 Version Details Vulnerabilities
85 OS Paloaltonetworks Pan-os 7.0.11 Version Details Vulnerabilities
86 OS Paloaltonetworks Pan-os 7.0.12 Version Details Vulnerabilities
87 OS Paloaltonetworks Pan-os 7.1.0 Version Details Vulnerabilities
88 OS Paloaltonetworks Pan-os 7.1.1 Version Details Vulnerabilities
89 OS Paloaltonetworks Pan-os 7.1.2 Version Details Vulnerabilities
90 OS Paloaltonetworks Pan-os 7.1.3 Version Details Vulnerabilities
91 OS Paloaltonetworks Pan-os 7.1.4 Version Details Vulnerabilities
92 OS Paloaltonetworks Pan-os 7.1.4-h2 Version Details Vulnerabilities
93 OS Paloaltonetworks Pan-os 7.1.6 Version Details Vulnerabilities
94 OS Paloaltonetworks Pan-os 7.1.7 Version Details Vulnerabilities
95 OS Paloaltonetworks Pan-os 7.1.8 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Paloaltonetworks Pan-os 95

- References For CVE-2017-15944

https://www.exploit-db.com/exploits/44597/
EXPLOIT-DB 44597
https://www.exploit-db.com/exploits/43342/
EXPLOIT-DB 43342
https://securityadvisories.paloaltonetworks.com/Home/Detail/102 CONFIRM
http://www.securitytracker.com/id/1040007
SECTRACK 1040007
http://www.securityfocus.com/bid/102079
BID 102079 Palo Alto Networks PAN-OS CVE-2017-15944 Remote Code Execution Vulnerability Release Date:2017-12-13

- Metasploit Modules Related To CVE-2017-15944

Palo Alto Networks readSessionVarsFromFile() Session Corruption
This module exploits a chain of vulnerabilities in Palo Alto Networks products running PAN-OS versions prior to 6.1.19, 7.0.19, 7.1.14, and 8.0.6. This chain starts by using an authentication bypass flaw to to exploit an XML injection issue, which is then abused to create an arbitrary directory, and finally gains root code execution by exploiting a vulnerable cron script. This module uses an initial reverse TLS callback to stage arbitrary payloads on the target appliance. The cron job used for the final payload runs every 15 minutes by default and exploitation can take up to 20 minutes.
Module type : exploit Rank : excellent Platforms : Unix


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.