CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2016-2107

The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session. NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.
Publish Date : 2016-05-04 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 310

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2016:0722: openssl security update (Important) oval:com.redhat.rhsa:def:20160722 unix
RHSA-2016:0996: openssl security update (Important) oval:com.redhat.rhsa:def:20160996 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2016-2107

# Product Type Vendor Product Version Update Edition Language
1 OS Google Android 4.0 Version Details Vulnerabilities
2 OS Google Android 4.0.1 Version Details Vulnerabilities
3 OS Google Android 4.0.2 Version Details Vulnerabilities
4 OS Google Android 4.0.3 Version Details Vulnerabilities
5 OS Google Android 4.0.4 Version Details Vulnerabilities
6 OS Google Android 4.1 Version Details Vulnerabilities
7 OS Google Android 4.1.2 Version Details Vulnerabilities
8 OS Google Android 4.2 Version Details Vulnerabilities
9 OS Google Android 4.2.1 Version Details Vulnerabilities
10 OS Google Android 4.2.2 Version Details Vulnerabilities
11 OS Google Android 4.3 Version Details Vulnerabilities
12 OS Google Android 4.3.1 Version Details Vulnerabilities
13 OS Google Android 4.4 Version Details Vulnerabilities
14 OS Google Android 4.4.1 Version Details Vulnerabilities
15 OS Google Android 4.4.2 Version Details Vulnerabilities
16 OS Google Android 4.4.3 Version Details Vulnerabilities
17 OS Google Android 5.0 Version Details Vulnerabilities
18 OS Google Android 5.0.1 Version Details Vulnerabilities
19 OS Google Android 5.1 Version Details Vulnerabilities
20 OS Google Android 5.1.0 Version Details Vulnerabilities
21 Application HP Helion Openstack 2.0 Version Details Vulnerabilities
22 Application HP Helion Openstack 2.1 Version Details Vulnerabilities
23 Application HP Helion Openstack 2.1.2 Version Details Vulnerabilities
24 Application HP Helion Openstack 2.1.4 Version Details Vulnerabilities
25 Application Openssl Openssl 1.0.1s Version Details Vulnerabilities
26 Application Openssl Openssl 1.0.2e Version Details Vulnerabilities
27 Application Openssl Openssl 1.0.2 Beta3 Version Details Vulnerabilities
28 Application Openssl Openssl 1.0.2f Version Details Vulnerabilities
29 Application Openssl Openssl 1.0.2a Version Details Vulnerabilities
30 Application Openssl Openssl 1.0.2g Version Details Vulnerabilities
31 Application Openssl Openssl 1.0.2b Version Details Vulnerabilities
32 Application Openssl Openssl 1.0.2 Version Details Vulnerabilities
33 Application Openssl Openssl 1.0.2c Version Details Vulnerabilities
34 Application Openssl Openssl 1.0.2 Beta1 Version Details Vulnerabilities
35 Application Openssl Openssl 1.0.2d Version Details Vulnerabilities
36 Application Openssl Openssl 1.0.2 Beta2 Version Details Vulnerabilities
37 OS Opensuse Leap 42.1 Version Details Vulnerabilities
38 OS Opensuse Opensuse 13.2 Version Details Vulnerabilities
39 OS Redhat Enterprise Linux Desktop 6.0 Version Details Vulnerabilities
40 OS Redhat Enterprise Linux Desktop 7.0 Version Details Vulnerabilities
41 OS Redhat Enterprise Linux Hpc Node 6.0 Version Details Vulnerabilities
42 OS Redhat Enterprise Linux Hpc Node 7.0 Version Details Vulnerabilities
43 OS Redhat Enterprise Linux Hpc Node Eus 7.2 Version Details Vulnerabilities
44 OS Redhat Enterprise Linux Server 6.0 Version Details Vulnerabilities
45 OS Redhat Enterprise Linux Server 7.0 Version Details Vulnerabilities
46 OS Redhat Enterprise Linux Server Aus 7.2 Version Details Vulnerabilities
47 OS Redhat Enterprise Linux Server Eus 7.2 Version Details Vulnerabilities
48 OS Redhat Enterprise Linux Workstation 6.0 Version Details Vulnerabilities
49 OS Redhat Enterprise Linux Workstation 7.0 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Google Android 20
HP Helion Openstack 4
Openssl Openssl 12
Opensuse Leap 1
Opensuse Opensuse 1
Redhat Enterprise Linux Desktop 2
Redhat Enterprise Linux Hpc Node 2
Redhat Enterprise Linux Hpc Node Eus 1
Redhat Enterprise Linux Server 2
Redhat Enterprise Linux Server Aus 1
Redhat Enterprise Linux Server Eus 1
Redhat Enterprise Linux Workstation 2

- References For CVE-2016-2107

https://www.openssl.org/news/secadv/20160503.txt CONFIRM
http://rhn.redhat.com/errata/RHSA-2016-0722.html
REDHAT RHSA-2016:0722
http://rhn.redhat.com/errata/RHSA-2016-0996.html
REDHAT RHSA-2016:0996
https://www.exploit-db.com/exploits/39768/
EXPLOIT-DB 39768
https://www.freebsd.org/security/advisories/FreeBSD-SA-16:17.openssl.asc
FREEBSD FreeBSD-SA-16:17
http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183607.html
FEDORA FEDORA-2016-1411324654
http://lists.fedoraproject.org/pipermail/package-announce/2016-May/184605.html
FEDORA FEDORA-2016-1e39d934ed
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00001.html
SUSE SUSE-SU-2016:1206
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03756en_us CONFIRM
https://www.tenable.com/security/tns-2016-18 CONFIRM
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05386804 CONFIRM
http://source.android.com/security/bulletin/2016-07-01.html CONFIRM
http://support.citrix.com/article/CTX212736 CONFIRM
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20160504-openssl
CISCO 20160504 Multiple Vulnerabilities in OpenSSL Affecting Cisco Products: May 2016
http://web-in-security.blogspot.ca/2016/05/curious-padding-oracle-in-openssl-cve.html
http://www.debian.org/security/2016/dsa-3566
DEBIAN DSA-3566
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html CONFIRM
http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html CONFIRM
http://www.oracle.com/technetwork/topics/security/linuxbulletinapr2016-2952096.html CONFIRM
http://www.securityfocus.com/bid/89760
BID 89760 OpenSSL Padding Oracle Incomplete Fix Information Disclosure Vulnerability Release Date:2018-10-17
http://www.securityfocus.com/bid/91787
BID 91787 Oracle July 2016 Critical Patch Update Multiple Vulnerabilities Release Date:2018-10-15
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00011.html
SUSE SUSE-SU-2016:1233
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00013.html
SUSE openSUSE-SU-2016:1237
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00014.html
SUSE openSUSE-SU-2016:1238
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03765en_us CONFIRM
http://www.securitytracker.com/id/1035721
SECTRACK 1035721
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.542103
SLACKWARE SSA:2016-124-01
https://security.gentoo.org/glsa/201612-16
GENTOO GLSA-201612-16
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722 CONFIRM
https://support.apple.com/HT206903 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00016.html
SUSE openSUSE-SU-2016:1240
https://kc.mcafee.com/corporate/index?page=content&id=SB10160 CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00019.html
SUSE openSUSE-SU-2016:1243
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05164862 CONFIRM
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05320149 CONFIRM
https://git.openssl.org/?p=openssl.git;a=commit;h=68595c0c2886e7942a14f98c17a55a88afb6c292 CONFIRM
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbgn03726en_us CONFIRM
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbgn03728en_us CONFIRM
https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA40202 CONFIRM
https://security.netapp.com/advisory/ntap-20160504-0001/ CONFIRM
http://www.ubuntu.com/usn/USN-2959-1
UBUNTU USN-2959-1
http://packetstormsecurity.com/files/136912/Slackware-Security-Advisory-openssl-Updates.html
https://blog.cloudflare.com/yet-another-padding-oracle-in-openssl-cbc-ciphersuites/
https://bto.bluecoat.com/security-advisory/sa123 CONFIRM
http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759 CONFIRM
http://lists.apple.com/archives/security-announce/2016/Jul/msg00000.html
APPLE APPLE-SA-2016-07-18-1
http://rhn.redhat.com/errata/RHSA-2016-2957.html
REDHAT RHSA-2016:2957
http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00019.html
SUSE openSUSE-SU-2016:1566
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00008.html
SUSE SUSE-SU-2016:1228
http://rhn.redhat.com/errata/RHSA-2016-2073.html
REDHAT RHSA-2016:2073
http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183457.html
FEDORA FEDORA-2016-05c567df1a

- Metasploit Modules Related To CVE-2016-2107

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.