CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-7975

The nextvar function in NTP before 4.2.8p6 and 4.3.x before 4.3.90 does not properly validate the length of its input, which allows an attacker to cause a denial of service (application crash).
Publish Date : 2017-01-30 Last Update Date : 2017-11-20
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.1
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact Partial (There is reduced performance or interruptions in resource availability.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s) Denial Of ServiceOverflow
CWE ID 119

- Products Affected By CVE-2015-7975

# Product Type Vendor Product Version Update Edition Language
1 Application NTP NTP 4.2.8 P5 Version Details Vulnerabilities
2 Application NTP NTP 4.3.0 Version Details Vulnerabilities
3 Application NTP NTP 4.3.1 Version Details Vulnerabilities
4 Application NTP NTP 4.3.2 Version Details Vulnerabilities
5 Application NTP NTP 4.3.3 Version Details Vulnerabilities
6 Application NTP NTP 4.3.4 Version Details Vulnerabilities
7 Application NTP NTP 4.3.5 Version Details Vulnerabilities
8 Application NTP NTP 4.3.6 Version Details Vulnerabilities
9 Application NTP NTP 4.3.7 Version Details Vulnerabilities
10 Application NTP NTP 4.3.8 Version Details Vulnerabilities
11 Application NTP NTP 4.3.10 Version Details Vulnerabilities
12 Application NTP NTP 4.3.11 Version Details Vulnerabilities
13 Application NTP NTP 4.3.12 Version Details Vulnerabilities
14 Application NTP NTP 4.3.13 Version Details Vulnerabilities
15 Application NTP NTP 4.3.14 Version Details Vulnerabilities
16 Application NTP NTP 4.3.15 Version Details Vulnerabilities
17 Application NTP NTP 4.3.16 Version Details Vulnerabilities
18 Application NTP NTP 4.3.17 Version Details Vulnerabilities
19 Application NTP NTP 4.3.18 Version Details Vulnerabilities
20 Application NTP NTP 4.3.19 Version Details Vulnerabilities
21 Application NTP NTP 4.3.20 Version Details Vulnerabilities
22 Application NTP NTP 4.3.21 Version Details Vulnerabilities
23 Application NTP NTP 4.3.22 Version Details Vulnerabilities
24 Application NTP NTP 4.3.23 Version Details Vulnerabilities
25 Application NTP NTP 4.3.24 Version Details Vulnerabilities
26 Application NTP NTP 4.3.25 Version Details Vulnerabilities
27 Application NTP NTP 4.3.26 Version Details Vulnerabilities
28 Application NTP NTP 4.3.27 Version Details Vulnerabilities
29 Application NTP NTP 4.3.28 Version Details Vulnerabilities
30 Application NTP NTP 4.3.29 Version Details Vulnerabilities
31 Application NTP NTP 4.3.30 Version Details Vulnerabilities
32 Application NTP NTP 4.3.31 Version Details Vulnerabilities
33 Application NTP NTP 4.3.32 Version Details Vulnerabilities
34 Application NTP NTP 4.3.33 Version Details Vulnerabilities
35 Application NTP NTP 4.3.34 Version Details Vulnerabilities
36 Application NTP NTP 4.3.35 Version Details Vulnerabilities
37 Application NTP NTP 4.3.36 Version Details Vulnerabilities
38 Application NTP NTP 4.3.37 Version Details Vulnerabilities
39 Application NTP NTP 4.3.38 Version Details Vulnerabilities
40 Application NTP NTP 4.3.39 Version Details Vulnerabilities
41 Application NTP NTP 4.3.40 Version Details Vulnerabilities
42 Application NTP NTP 4.3.41 Version Details Vulnerabilities
43 Application NTP NTP 4.3.42 Version Details Vulnerabilities
44 Application NTP NTP 4.3.43 Version Details Vulnerabilities
45 Application NTP NTP 4.3.44 Version Details Vulnerabilities
46 Application NTP NTP 4.3.45 Version Details Vulnerabilities
47 Application NTP NTP 4.3.46 Version Details Vulnerabilities
48 Application NTP NTP 4.3.47 Version Details Vulnerabilities
49 Application NTP NTP 4.3.48 Version Details Vulnerabilities
50 Application NTP NTP 4.3.49 Version Details Vulnerabilities
51 Application NTP NTP 4.3.50 Version Details Vulnerabilities
52 Application NTP NTP 4.3.51 Version Details Vulnerabilities
53 Application NTP NTP 4.3.52 Version Details Vulnerabilities
54 Application NTP NTP 4.3.53 Version Details Vulnerabilities
55 Application NTP NTP 4.3.54 Version Details Vulnerabilities
56 Application NTP NTP 4.3.55 Version Details Vulnerabilities
57 Application NTP NTP 4.3.56 Version Details Vulnerabilities
58 Application NTP NTP 4.3.57 Version Details Vulnerabilities
59 Application NTP NTP 4.3.58 Version Details Vulnerabilities
60 Application NTP NTP 4.3.59 Version Details Vulnerabilities
61 Application NTP NTP 4.3.60 Version Details Vulnerabilities
62 Application NTP NTP 4.3.61 Version Details Vulnerabilities
63 Application NTP NTP 4.3.62 Version Details Vulnerabilities
64 Application NTP NTP 4.3.63 Version Details Vulnerabilities
65 Application NTP NTP 4.3.64 Version Details Vulnerabilities
66 Application NTP NTP 4.3.65 Version Details Vulnerabilities
67 Application NTP NTP 4.3.66 Version Details Vulnerabilities
68 Application NTP NTP 4.3.67 Version Details Vulnerabilities
69 Application NTP NTP 4.3.68 Version Details Vulnerabilities
70 Application NTP NTP 4.3.69 Version Details Vulnerabilities
71 Application NTP NTP 4.3.70 Version Details Vulnerabilities
72 Application NTP NTP 4.3.71 Version Details Vulnerabilities
73 Application NTP NTP 4.3.72 Version Details Vulnerabilities
74 Application NTP NTP 4.3.73 Version Details Vulnerabilities
75 Application NTP NTP 4.3.74 Version Details Vulnerabilities
76 Application NTP NTP 4.3.75 Version Details Vulnerabilities
77 Application NTP NTP 4.3.76 Version Details Vulnerabilities
78 Application NTP NTP 4.3.77 Version Details Vulnerabilities
79 Application NTP NTP 4.3.78 Version Details Vulnerabilities
80 Application NTP NTP 4.3.79 Version Details Vulnerabilities
81 Application NTP NTP 4.3.80 Version Details Vulnerabilities
82 Application NTP NTP 4.3.81 Version Details Vulnerabilities
83 Application NTP NTP 4.3.82 Version Details Vulnerabilities
84 Application NTP NTP 4.3.83 Version Details Vulnerabilities
85 Application NTP NTP 4.3.84 Version Details Vulnerabilities
86 Application NTP NTP 4.3.85 Version Details Vulnerabilities
87 Application NTP NTP 4.3.86 Version Details Vulnerabilities
88 Application NTP NTP 4.3.87 Version Details Vulnerabilities
89 Application NTP NTP 4.3.88 Version Details Vulnerabilities
90 Application NTP NTP 4.3.89 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
NTP NTP 90

- References For CVE-2015-7975

http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20160127-ntpd
CISCO 20160120 Multiple Vulnerabilities in Network Time Protocol Daemon Affecting Cisco Products - January 2016
https://www.kb.cert.org/vuls/id/718152
CERT-VN VU#718152
https://security.netapp.com/advisory/ntap-20171031-0001/ CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00020.html
SUSE SUSE-SU-2016:1247
http://www.securityfocus.com/bid/81959
BID 81959 NTP CVE-2015-7975 Local Denial of Service Vulnerability Release Date:2016-10-10
http://www.securitytracker.com/id/1034782
SECTRACK 1034782
http://www.ubuntu.com/usn/USN-3096-1
UBUNTU USN-3096-1
https://bto.bluecoat.com/security-advisory/sa113 CONFIRM
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03750en_us CONFIRM
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03766en_us CONFIRM
https://security.FreeBSD.org/advisories/FreeBSD-SA-16:09.ntp.asc
FREEBSD FreeBSD-SA-16:09
https://security.gentoo.org/glsa/201607-15
GENTOO GLSA-201607-15
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00038.html
SUSE openSUSE-SU-2016:1292
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00048.html
SUSE SUSE-SU-2016:1311
http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00026.html
SUSE SUSE-SU-2016:1912
http://support.ntp.org/bin/view/Main/NtpBug2937 CONFIRM
http://lists.opensuse.org/opensuse-updates/2016-05/msg00114.html
SUSE openSUSE-SU-2016:1423
http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00042.html
SUSE SUSE-SU-2016:2094
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00059.html
SUSE SUSE-SU-2016:1175
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00060.html
SUSE SUSE-SU-2016:1177

- Metasploit Modules Related To CVE-2015-7975

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.