CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-7940

The Bouncy Castle Java library before 1.51 does not validate a point is withing the elliptic curve, which makes it easier for remote attackers to obtain private keys via a series of crafted elliptic curve Diffie Hellman (ECDH) key exchanges, aka an "invalid curve attack."
Publish Date : 2015-11-09 Last Update Date : 2019-01-16
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
5.0
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 310

- Products Affected By CVE-2015-7940

# Product Type Vendor Product Version Update Edition Language
1 Application Bouncycastle Bouncy Castle Crypto Package 1.50 Version Details Vulnerabilities
2 OS Opensuse Leap 42.1 Version Details Vulnerabilities
3 OS Opensuse Opensuse 13.1 Version Details Vulnerabilities
4 OS Opensuse Opensuse 13.2 Version Details Vulnerabilities
5 Application Oracle Application Testing Suite 12.5.0.1 Version Details Vulnerabilities
6 Application Oracle Application Testing Suite 12.5.0.2 Version Details Vulnerabilities
7 Application Oracle Application Testing Suite 12.5.0.3 Version Details Vulnerabilities
8 Application Oracle Enterprise Manager Ops Center 12.1.4 Version Details Vulnerabilities
9 Application Oracle Enterprise Manager Ops Center 12.2.2 Version Details Vulnerabilities
10 Application Oracle Peoplesoft Enterprise Peopletools 8.54 Version Details Vulnerabilities
11 Application Oracle Peoplesoft Enterprise Peopletools 8.55 Version Details Vulnerabilities
12 Application Oracle Virtual Desktop Infrastructure 3.5.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Bouncycastle Bouncy Castle Crypto Package 1
Opensuse Leap 1
Opensuse Opensuse 2
Oracle Application Testing Suite 3
Oracle Enterprise Manager Ops Center 2
Oracle Peoplesoft Enterprise Peopletools 2
Oracle Virtual Desktop Infrastructure 1

- References For CVE-2015-7940

http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00012.html
SUSE openSUSE-SU-2015:1911
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html CONFIRM
http://www.debian.org/security/2015/dsa-3417
DEBIAN DSA-3417
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html CONFIRM
https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html CONFIRM
http://rhn.redhat.com/errata/RHSA-2016-2036.html
REDHAT RHSA-2016:2036
http://www.securitytracker.com/id/1037036
SECTRACK 1037036
http://www.securityfocus.com/bid/79091
BID 79091 Bouncy Castle CVE-2015-7940 Information Disclosure Vulnerability Release Date:2018-04-18
http://www.securitytracker.com/id/1037053
SECTRACK 1037053
http://www.securitytracker.com/id/1037046
SECTRACK 1037046
http://www.oracle.com/technetwork/security-advisory/cpuoct2016-2881722.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html CONFIRM
http://www.openwall.com/lists/oss-security/2015/10/22/7
MLIST [oss-security] 20151022 CVE Request: invalid curve attack on bouncycastle
http://www.openwall.com/lists/oss-security/2015/10/22/9
MLIST [oss-security] 20151022 Re: CVE Request: invalid curve attack on bouncycastle
http://rhn.redhat.com/errata/RHSA-2016-2035.html
REDHAT RHSA-2016:2035
http://web-in-security.blogspot.ca/2015/09/practical-invalid-curve-attacks.html
http://lists.fedoraproject.org/pipermail/package-announce/2016-January/174915.html
FEDORA FEDORA-2015-7d95466eda
https://usn.ubuntu.com/3727-1/
UBUNTU USN-3727-1

- Metasploit Modules Related To CVE-2015-7940

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.