CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2015-7575

Mozilla Network Security Services (NSS) before 3.20.2, as used in Mozilla Firefox before 43.0.2 and Firefox ESR 38.x before 38.5.2, does not reject MD5 signatures in Server Key Exchange messages in TLS 1.2 Handshake Protocol traffic, which makes it easier for man-in-the-middle attackers to spoof servers by triggering a collision.
Publish Date : 2016-01-08 Last Update Date : 2018-10-30
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.3
Confidentiality Impact None (There is no impact to the confidentiality of the system.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 19

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2016:0007: nss security update (Moderate) oval:com.redhat.rhsa:def:20160007 unix
RHSA-2016:0008: openssl security update (Moderate) oval:com.redhat.rhsa:def:20160008 unix
RHSA-2016:0012: gnutls security update (Moderate) oval:com.redhat.rhsa:def:20160012 unix
RHSA-2016:0049: java-1.8.0-openjdk security update (Critical) oval:com.redhat.rhsa:def:20160049 unix
RHSA-2016:0050: java-1.8.0-openjdk security update (Important) oval:com.redhat.rhsa:def:20160050 unix
RHSA-2016:0053: java-1.7.0-openjdk security update (Critical) oval:com.redhat.rhsa:def:20160053 unix
RHSA-2016:0054: java-1.7.0-openjdk security update (Important) oval:com.redhat.rhsa:def:20160054 unix
RHSA-2016:0055: java-1.8.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20160055 unix
RHSA-2016:0056: java-1.7.0-oracle security update (Critical) oval:com.redhat.rhsa:def:20160056 unix
RHSA-2016:0099: java-1.7.1-ibm security update (Critical) oval:com.redhat.rhsa:def:20160099 unix
RHSA-2016:0100: java-1.7.0-ibm security update (Critical) oval:com.redhat.rhsa:def:20160100 unix
RHSA-2016:0101: java-1.6.0-ibm security update (Critical) oval:com.redhat.rhsa:def:20160101 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2015-7575

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 14.04 ~~lts~~~ Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 15.04 Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 15.10 Version Details Vulnerabilities
4 Application Mozilla Firefox 43.0.1 Version Details Vulnerabilities
5 Application Mozilla Firefox Esr 38.0 Version Details Vulnerabilities
6 Application Mozilla Firefox Esr 38.0.1 Version Details Vulnerabilities
7 Application Mozilla Firefox Esr 38.0.5 Version Details Vulnerabilities
8 Application Mozilla Firefox Esr 38.1.0 Version Details Vulnerabilities
9 Application Mozilla Firefox Esr 38.1.1 Version Details Vulnerabilities
10 Application Mozilla Firefox Esr 38.2.0 Version Details Vulnerabilities
11 Application Mozilla Firefox Esr 38.2.1 Version Details Vulnerabilities
12 Application Mozilla Firefox Esr 38.3.0 Version Details Vulnerabilities
13 Application Mozilla Firefox Esr 38.4.0 Version Details Vulnerabilities
14 Application Mozilla Firefox Esr 38.5.0 Version Details Vulnerabilities
15 Application Mozilla Firefox Esr 38.5.1 Version Details Vulnerabilities
16 Application Mozilla Network Security Services 3.20.1 Version Details Vulnerabilities
17 OS Opensuse Leap 42.1 Version Details Vulnerabilities
18 OS Opensuse Opensuse 13.1 Version Details Vulnerabilities
19 OS Opensuse Opensuse 13.2 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Mozilla Firefox 1
Mozilla Firefox Esr 11
Mozilla Network Security Services 1
Opensuse Leap 1
Opensuse Opensuse 2

- References For CVE-2015-7575

https://security.gentoo.org/glsa/201706-18
GENTOO GLSA-201706-18
https://security.gentoo.org/glsa/201701-46
GENTOO GLSA-201701-46
https://security.netapp.com/advisory/ntap-20160225-0001/ CONFIRM
https://security.gentoo.org/glsa/201801-15
GENTOO GLSA-201801-15
http://www.debian.org/security/2016/dsa-3436
DEBIAN DSA-3436
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00038.html
SUSE SUSE-SU-2016:0256
https://bugzilla.mozilla.org/show_bug.cgi?id=1158489 CONFIRM
http://www.ubuntu.com/usn/USN-2884-1
UBUNTU USN-2884-1
http://www.ubuntu.com/usn/USN-2904-1
UBUNTU USN-2904-1
https://developer.mozilla.org/docs/Mozilla/Projects/NSS/NSS_3.20.2_release_notes CONFIRM
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00048.html
SUSE openSUSE-SU-2016:0279
http://lists.opensuse.org/opensuse-updates/2016-02/msg00007.html
SUSE openSUSE-SU-2016:0307
http://lists.opensuse.org/opensuse-updates/2016-02/msg00008.html
SUSE openSUSE-SU-2016:0308
https://access.redhat.com/errata/RHSA-2016:1430
REDHAT RHSA-2016:1430
http://www.ubuntu.com/usn/USN-2865-1
UBUNTU USN-2865-1
http://www.ubuntu.com/usn/USN-2864-1
UBUNTU USN-2864-1
http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html CONFIRM
http://www.securitytracker.com/id/1036467
SECTRACK 1036467
http://www.ubuntu.com/usn/USN-2863-1
UBUNTU USN-2863-1
http://www.securityfocus.com/bid/91787
BID 91787 Oracle July 2016 Critical Patch Update Multiple Vulnerabilities Release Date:2018-10-15
http://www.securitytracker.com/id/1034541
SECTRACK 1034541
http://www.securityfocus.com/bid/79684
BID 79684 Mozilla Network Security Services CVE-2015-7575 Security Bypass Vulnerability Release Date:2016-10-11
http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html CONFIRM
http://www.debian.org/security/2016/dsa-3491
DEBIAN DSA-3491
http://www.debian.org/security/2016/dsa-3688
DEBIAN DSA-3688
http://www.mozilla.org/security/announce/2015/mfsa2015-150.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuapr2016v3-2985753.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpujul2016-2881720.html CONFIRM
http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html CONFIRM
http://www.debian.org/security/2016/dsa-3465
DEBIAN DSA-3465
http://www.debian.org/security/2016/dsa-3458
DEBIAN DSA-3458
http://www.debian.org/security/2016/dsa-3457
DEBIAN DSA-3457
http://www.debian.org/security/2016/dsa-3437
DEBIAN DSA-3437
http://rhn.redhat.com/errata/RHSA-2016-0049.html
REDHAT RHSA-2016:0049
http://rhn.redhat.com/errata/RHSA-2016-0050.html
REDHAT RHSA-2016:0050
http://rhn.redhat.com/errata/RHSA-2016-0053.html
REDHAT RHSA-2016:0053
http://rhn.redhat.com/errata/RHSA-2016-0056.html
REDHAT RHSA-2016:0056
http://rhn.redhat.com/errata/RHSA-2016-0055.html
REDHAT RHSA-2016:0055
http://rhn.redhat.com/errata/RHSA-2016-0054.html
REDHAT RHSA-2016:0054
http://www.ubuntu.com/usn/USN-2866-1
UBUNTU USN-2866-1
http://lists.opensuse.org/opensuse-updates/2016-02/msg00166.html
SUSE openSUSE-SU-2016:0605
http://lists.opensuse.org/opensuse-updates/2016-01/msg00059.html
SUSE openSUSE-SU-2016:0162
http://lists.opensuse.org/opensuse-updates/2016-02/msg00101.html
SUSE openSUSE-SU-2016:0488
http://lists.opensuse.org/opensuse-updates/2016-01/msg00005.html
SUSE openSUSE-SU-2016:0007
http://lists.opensuse.org/opensuse-updates/2016-01/msg00058.html
SUSE openSUSE-SU-2016:0161
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00045.html
SUSE openSUSE-SU-2016:0270
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00047.html
SUSE openSUSE-SU-2016:0272
http://lists.opensuse.org/opensuse-updates/2015-12/msg00139.html
SUSE openSUSE-SU-2015:2405
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00042.html
SUSE SUSE-SU-2016:0265
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00044.html
SUSE SUSE-SU-2016:0269
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00043.html
SUSE openSUSE-SU-2016:0268
http://lists.opensuse.org/opensuse-security-announce/2016-01/msg00041.html
SUSE openSUSE-SU-2016:0263

- Metasploit Modules Related To CVE-2015-7575

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.