CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2012-3488

The libxslt support in contrib/xml2 in PostgreSQL 8.3 before 8.3.20, 8.4 before 8.4.13, 9.0 before 9.0.9, and 9.1 before 9.1.5 does not properly restrict access to files and URLs, which allows remote authenticated users to modify data, obtain sensitive information, or trigger outbound traffic to arbitrary external hosts by leveraging (1) stylesheet commands that are permitted by the libxslt security options or (2) an xslt_process feature, related to an XML External Entity (aka XXE) issue.
Publish Date : 2012-10-03 Last Update Date : 2016-12-07
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
4.9
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact Partial (Modification of some system files or information is possible, but the attacker does not have control over what can be modified, or the scope of what the attacker can affect is limited.)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity Medium (The access conditions are somewhat specialized. Some preconditions must be satistified to exploit)
Authentication Single system (The vulnerability requires an attacker to be logged into the system (such as at a command line or via a desktop session or web interface).)
Gained Access None
Vulnerability Type(s) Obtain Information
CWE ID 264

- Additional Vendor Supplied Data

Vendor Impact CVSS Score CVSS Vector Report Date Publish Date
Redhat moderate
3.8
AV:A/AC:M/Au:S/C:P/I:P/A:N 2012-08-13 2012-08-17
If you are a vendor and you have additional data which can be automatically imported into our database, please contact admin @ cvedetails.com

- Related OVAL Definitions

Title Definition Id Class Family
DEPRECATED: ELSA-2012-1263 -- postgresql and postgresql84 security update (moderate) oval:org.mitre.oval:def:27787 unix
DEPRECATED: ELSA-2012-1264 -- postgresql security update (moderate) oval:org.mitre.oval:def:27283 unix
DEPRECATED: ELSA-2012:1263: postgresql and postgresql84 security update (Moderate) oval:org.mitre.oval:def:23390 unix
DSA-2534-1 postgresql-8.4 - several oval:org.mitre.oval:def:18474 unix
ELSA-2012:1263: postgresql and postgresql84 security update (Moderate) oval:org.mitre.oval:def:23579 unix
ELSA-2012:1264: postgresql security update (Moderate) oval:org.mitre.oval:def:23197 unix
RHSA-2012:1263: postgresql and postgresql84 security update (Moderate) oval:org.mitre.oval:def:21356 unix
RHSA-2012:1263: postgresql and postgresql84 security update (Moderate) oval:com.redhat.rhsa:def:20121263 unix
RHSA-2012:1264: postgresql security update (Moderate) oval:org.mitre.oval:def:21547 unix
RHSA-2012:1264: postgresql security update (Moderate) oval:com.redhat.rhsa:def:20121264 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2012-3488

# Product Type Vendor Product Version Update Edition Language
1 Application Postgresql Postgresql 8.3 Version Details Vulnerabilities
2 Application Postgresql Postgresql 8.3.1 Version Details Vulnerabilities
3 Application Postgresql Postgresql 8.3.2 Version Details Vulnerabilities
4 Application Postgresql Postgresql 8.3.3 Version Details Vulnerabilities
5 Application Postgresql Postgresql 8.3.4 Version Details Vulnerabilities
6 Application Postgresql Postgresql 8.3.5 Version Details Vulnerabilities
7 Application Postgresql Postgresql 8.3.6 Version Details Vulnerabilities
8 Application Postgresql Postgresql 8.3.7 Version Details Vulnerabilities
9 Application Postgresql Postgresql 8.3.8 Version Details Vulnerabilities
10 Application Postgresql Postgresql 8.3.9 Version Details Vulnerabilities
11 Application Postgresql Postgresql 8.3.10 Version Details Vulnerabilities
12 Application Postgresql Postgresql 8.3.11 Version Details Vulnerabilities
13 Application Postgresql Postgresql 8.3.12 Version Details Vulnerabilities
14 Application Postgresql Postgresql 8.3.13 Version Details Vulnerabilities
15 Application Postgresql Postgresql 8.3.14 Version Details Vulnerabilities
16 Application Postgresql Postgresql 8.3.15 Version Details Vulnerabilities
17 Application Postgresql Postgresql 8.3.16 Version Details Vulnerabilities
18 Application Postgresql Postgresql 8.3.17 Version Details Vulnerabilities
19 Application Postgresql Postgresql 8.3.18 Version Details Vulnerabilities
20 Application Postgresql Postgresql 8.3.19 Version Details Vulnerabilities
21 Application Postgresql Postgresql 8.4 Version Details Vulnerabilities
22 Application Postgresql Postgresql 8.4.1 Version Details Vulnerabilities
23 Application Postgresql Postgresql 8.4.2 Version Details Vulnerabilities
24 Application Postgresql Postgresql 8.4.3 Version Details Vulnerabilities
25 Application Postgresql Postgresql 8.4.4 Version Details Vulnerabilities
26 Application Postgresql Postgresql 8.4.5 Version Details Vulnerabilities
27 Application Postgresql Postgresql 8.4.6 Version Details Vulnerabilities
28 Application Postgresql Postgresql 8.4.7 Version Details Vulnerabilities
29 Application Postgresql Postgresql 8.4.8 Version Details Vulnerabilities
30 Application Postgresql Postgresql 8.4.9 Version Details Vulnerabilities
31 Application Postgresql Postgresql 8.4.10 Version Details Vulnerabilities
32 Application Postgresql Postgresql 8.4.11 Version Details Vulnerabilities
33 Application Postgresql Postgresql 8.4.12 Version Details Vulnerabilities
34 Application Postgresql Postgresql 9.0 Version Details Vulnerabilities
35 Application Postgresql Postgresql 9.0.1 Version Details Vulnerabilities
36 Application Postgresql Postgresql 9.0.2 Version Details Vulnerabilities
37 Application Postgresql Postgresql 9.0.3 Version Details Vulnerabilities
38 Application Postgresql Postgresql 9.0.4 Version Details Vulnerabilities
39 Application Postgresql Postgresql 9.0.5 Version Details Vulnerabilities
40 Application Postgresql Postgresql 9.0.6 Version Details Vulnerabilities
41 Application Postgresql Postgresql 9.0.7 Version Details Vulnerabilities
42 Application Postgresql Postgresql 9.0.8 Version Details Vulnerabilities
43 Application Postgresql Postgresql 9.1 Version Details Vulnerabilities
44 Application Postgresql Postgresql 9.1.1 Version Details Vulnerabilities
45 Application Postgresql Postgresql 9.1.2 Version Details Vulnerabilities
46 Application Postgresql Postgresql 9.1.3 Version Details Vulnerabilities
47 Application Postgresql Postgresql 9.1.4 Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Postgresql Postgresql 47

- References For CVE-2012-3488

http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10705 CONFIRM
http://lists.apple.com/archives/security-announce/2013/Mar/msg00002.html
APPLE APPLE-SA-2013-03-14-1
http://www.securityfocus.com/bid/55072
BID 55072 PostgreSQL 'xslt_process()' Function Arbitrary File Creation or Overwrite Vulnerability Release Date:2013-03-14
http://www.ubuntu.com/usn/USN-1542-1
UBUNTU USN-1542-1
https://blogs.oracle.com/sunsecurity/entry/multiple_vulnerabilities_in_postgresql2 CONFIRM
http://www.postgresql.org/support/security/ CONFIRM
http://www.postgresql.org/docs/9.1/static/release-9-1-5.html CONFIRM
http://www.postgresql.org/docs/9.0/static/release-9-0-9.html CONFIRM
http://www.mandriva.com/security/advisories?name=MDVSA-2012:139
MANDRIVA MDVSA-2012:139
https://bugzilla.redhat.com/show_bug.cgi?id=849172 CONFIRM
http://www.postgresql.org/docs/8.4/static/release-8-4-13.html CONFIRM
http://www.postgresql.org/docs/8.3/static/release-8-3-20.html CONFIRM
http://rhn.redhat.com/errata/RHSA-2012-1263.html
REDHAT RHSA-2012:1263
http://rhn.redhat.com/errata/RHSA-2012-1264.html
REDHAT RHSA-2012:1264
http://www.postgresql.org/about/news/1407/ CONFIRM
http://www.debian.org/security/2012/dsa-2534
DEBIAN DSA-2534
http://lists.opensuse.org/opensuse-updates/2012-09/msg00102.html
SUSE openSUSE-SU-2012:1251
http://lists.opensuse.org/opensuse-updates/2012-10/msg00024.html
SUSE openSUSE-SU-2012:1299
http://lists.opensuse.org/opensuse-updates/2012-10/msg00013.html
SUSE openSUSE-SU-2012:1288

- Metasploit Modules Related To CVE-2012-3488

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.