Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Published 2023-08-23 16:15:10
Updated 2023-08-29 15:48:58
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2023-39441

0.24%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 61 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2023-39441

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
5.9
MEDIUM CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
2.2
3.6
NIST

CWE ids for CVE-2023-39441

References for CVE-2023-39441

Products affected by CVE-2023-39441

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!