Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
Published 2023-09-19 05:17:10
Updated 2023-09-21 19:28:37
Source Snyk
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2023-26143

0.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 18 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2023-26143

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
9.1
CRITICAL CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
3.9
5.2
NIST
6.5
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
3.9
2.5
Snyk

CWE ids for CVE-2023-26143

References for CVE-2023-26143

Products affected by CVE-2023-26143

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!