An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff. To do so, an attacker would need write access to the repository and be able to correctly guess the target branch before it’s created by the code maintainer. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.
Published 2023-04-07 19:15:07
Updated 2023-04-13 19:17:57
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2023-23762

0.17%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 53 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2023-23762

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
5.3
MEDIUM CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
1.6
3.6
NIST
6.5
MEDIUM CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N
1.3
4.7
GitHub, Inc. (Products Only)

CWE ids for CVE-2023-23762

  • The product compares two entities in a security-relevant context, but the comparison is incorrect, which may lead to resultant weaknesses.
    Assigned by:
    • nvd@nist.gov (Primary)
    • product-cna@github.com (Secondary)

References for CVE-2023-23762

Products affected by CVE-2023-23762

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!