In Splunk Enterprise versions below 8.1.13, 8.2.10, and 9.0.4, a cross-site request forgery in the Splunk Secure Gateway (SSG) app in the ‘kvstore_client’ REST endpoint lets a potential attacker update SSG KV store collections using an HTTP GET request.
Published 2023-02-14 18:15:13
Updated 2024-02-16 16:49:54
Source Splunk Inc.
View at NVD,   CVE.org
Vulnerability category: Cross-site request forgery (CSRF)

Exploit prediction scoring system (EPSS) score for CVE-2023-22942

Probability of exploitation activity in the next 30 days: 0.05%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 14 % EPSS Score History EPSS FAQ

CVSS scores for CVE-2023-22942

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source
4.3
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
2.8
1.4
NIST
5.4
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
2.8
2.5
Splunk Inc.

CWE ids for CVE-2023-22942

  • The web application does not, or can not, sufficiently verify whether a well-formed, valid, consistent request was intentionally provided by the user who submitted the request.
    Assigned by:
    • nvd@nist.gov (Primary)
    • prodsec@splunk.com (Secondary)

References for CVE-2023-22942

Products affected by CVE-2023-22942

  • Splunk » Splunk » Enterprise Edition
    Versions from including (>=) 8.1.0 and before (<) 8.1.13
    cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:*
  • Splunk » Splunk » Enterprise Edition
    Versions from including (>=) 9.0.0 and before (<) 9.0.4
    cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:*
  • Splunk » Splunk » Enterprise Edition
    Versions from including (>=) 8.2.0 and before (<) 8.2.10
    cpe:2.3:a:splunk:splunk:*:*:*:*:enterprise:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!