Obsidian 0.14.x and 0.15.x before 0.15.5 allows obsidian://hook-get-address remote code execution because window.open is used without checking the URL.
Published 2022-07-25 07:15:08
Updated 2022-10-26 02:53:21
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Input validationExecute code

Exploit prediction scoring system (EPSS) score for CVE-2022-36450

0.74%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 81 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2022-36450

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
8.0
HIGH CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
2.1
5.9
MITRE
9.8
CRITICAL CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
3.9
5.9
NIST

CWE ids for CVE-2022-36450

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2022-36450

Products affected by CVE-2022-36450

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!