In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications.
Published 2022-09-28 23:15:11
Updated 2023-01-20 13:12:43
Source PHP Group
View at NVD,   CVE.org
Vulnerability category: Input validation

Threat overview for CVE-2022-31629

Top countries where our scanners detected CVE-2022-31629
Top open port discovered on systems with this issue 80
IPs affected by CVE-2022-31629 184,330
Threat actors abusing to this issue? Yes
Find out if you* are affected by CVE-2022-31629!
*Directly or indirectly through your vendors, service providers and 3rd parties. Powered by attack surface intelligence from SecurityScorecard.

Exploit prediction scoring system (EPSS) score for CVE-2022-31629

Probability of exploitation activity in the next 30 days: 0.13%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 48 % EPSS Score History EPSS FAQ

CVSS scores for CVE-2022-31629

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source
6.5
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
2.8
3.6
NIST

CWE ids for CVE-2022-31629

  • The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
    Assigned by: security@php.net (Secondary)

References for CVE-2022-31629

Products affected by CVE-2022-31629

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!