Vulnerability Details : CVE-2022-25931

All versions of package easy-static-server are vulnerable to Directory Traversal due to missing input sanitization and sandboxes being employed to the req.url user input that is passed to the server code.
Vulnerability category: Directory traversal
Published 2022-12-20 05:15:12
Updated 2022-12-29 18:45:09
Source Snyk
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2022-25931

Probability of exploitation activity in the next 30 days: 0.07%

Percentile, the proportion of vulnerabilities that are scored at or less: ~ 29 % EPSS Score History EPSS FAQ

CVSS scores for CVE-2022-25931

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Source
7.5
HIGH CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
3.9
3.6
[email protected]
7.5
HIGH CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
3.9
3.6
[email protected]

CWE ids for CVE-2022-25931

References for CVE-2022-25931

Products affected by CVE-2022-25931

This web site uses cookies for managing your session and website analytics (Google analytics) purposes as described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!