An improper privilege management vulnerability was identified in GitHub Enterprise Server that allowed users with improper privileges to create or delete pages via the API. To exploit this vulnerability, an attacker would need to be added to an organization's repo with write permissions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, and 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.
Published 2022-12-01 21:15:19
Updated 2022-12-05 15:23:08
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2022-23737

0.14%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 50 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2022-23737

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.5
MEDIUM CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
2.8
3.6
NIST

CWE ids for CVE-2022-23737

  • The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.
    Assigned by:
    • nvd@nist.gov (Primary)
    • product-cna@github.com (Secondary)

References for CVE-2022-23737

Products affected by CVE-2022-23737

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!