CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
  Take a third party risk management course for FREE
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2022-23307

CVE-2020-9493 identified a deserialization issue that was present in Apache Chainsaw. Prior to Chainsaw V2.0 Chainsaw was a component of Apache Log4j 1.2.x where the same issue exists.
Publish Date : 2022-01-18 Last Update Date : 2022-07-25
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
9.0
Confidentiality Impact Complete (There is total information disclosure, resulting in all system files being revealed.)
Integrity Impact Complete (There is a total compromise of system integrity. There is a complete loss of system protection, resulting in the entire system being compromised.)
Availability Impact Complete (There is a total shutdown of the affected resource. The attacker can render the resource completely unavailable.)
Access Complexity Low (Specialized access conditions or extenuating circumstances do not exist. Very little knowledge or skill is required to exploit. )
Authentication ???
Gained Access None
Vulnerability Type(s)
CWE ID 502

- Related OVAL Definitions

Title Definition Id Class Family
RHSA-2022:0290: parfait:0.5 security update (Important) oval:com.redhat.rhsa:def:20220290 unix
RHSA-2022:0442: log4j security update (Important) oval:com.redhat.rhsa:def:20220442 unix
OVAL (Open Vulnerability and Assessment Language) definitions define exactly what should be done to verify a vulnerability or a missing patch. Check out the OVAL definitions if you want to learn what you should do to verify a vulnerability.

- Products Affected By CVE-2022-23307

# Product Type Vendor Product Version Update Edition Language
1 Application Apache Chainsaw * * * * Version Details Vulnerabilities
2 Application Apache Log4j * * * * Version Details Vulnerabilities
3 Application Oracle Advanced Supply Chain Planning 12.1 * * * Version Details Vulnerabilities
4 Application Oracle Advanced Supply Chain Planning 12.2 * * * Version Details Vulnerabilities
5 Application Oracle Business Intelligence 5.9.0.0.0 * * * Version Details Vulnerabilities
6 Application Oracle Business Intelligence 12.2.1.3.0 * * * Version Details Vulnerabilities
7 Application Oracle Business Intelligence 12.2.1.4.0 * * * Version Details Vulnerabilities
8 Application Oracle Business Process Management Suite 12.2.1.3.0 * * * Version Details Vulnerabilities
9 Application Oracle Business Process Management Suite 12.2.1.4.0 * * * Version Details Vulnerabilities
10 Application Oracle Communications Eagle Ftp Table Base Retrieval 4.5 * * * Version Details Vulnerabilities
11 Application Oracle Communications Messaging Server 8.1 * * * Version Details Vulnerabilities
12 Application Oracle Communications Network Integrity 7.3.6 * * * Version Details Vulnerabilities
13 Application Oracle Communications Unified Inventory Management 7.4.1 * * * Version Details Vulnerabilities
14 Application Oracle Communications Unified Inventory Management 7.4.2 * * * Version Details Vulnerabilities
15 Application Oracle E-business Suite Cloud Manager And Cloud Backup Module * * * * Version Details Vulnerabilities
16 Application Oracle E-business Suite Cloud Manager And Cloud Backup Module 2.2.1.1.1 * * * Version Details Vulnerabilities
17 Application Oracle Enterprise Manager Base Platform 13.4.0.0 * * * Version Details Vulnerabilities
18 Application Oracle Enterprise Manager Base Platform 13.5.0.0 * * * Version Details Vulnerabilities
19 Application Oracle Financial Services Revenue Management And Billing Analytics 2.7.0.0 * * * Version Details Vulnerabilities
20 Application Oracle Financial Services Revenue Management And Billing Analytics 2.7.0.1 * * * Version Details Vulnerabilities
21 Application Oracle Financial Services Revenue Management And Billing Analytics 2.8.0.0 * * * Version Details Vulnerabilities
22 Application Oracle Healthcare Foundation 8.1.0 * * * Version Details Vulnerabilities
23 Application Oracle Hyperion Data Relationship Management * * * * Version Details Vulnerabilities
24 Application Oracle Hyperion Infrastructure Technology * * * * Version Details Vulnerabilities
25 Application Oracle Identity Management Suite 12.2.1.3.0 * * * Version Details Vulnerabilities
26 Application Oracle Identity Management Suite 12.2.1.4.0 * * * Version Details Vulnerabilities
27 Application Oracle Identity Manager Connector 11.1.1.5.0 * * * Version Details Vulnerabilities
28 Application Oracle Jdeveloper 12.2.1.3.0 * * * Version Details Vulnerabilities
29 Application Oracle Middleware Common Libraries And Tools 12.2.1.4.0 * * * Version Details Vulnerabilities
30 Application Oracle Mysql Enterprise Monitor * * * * Version Details Vulnerabilities
31 Application Oracle Tuxedo 12.2.2.0.0 * * * Version Details Vulnerabilities
32 Application Oracle Weblogic Server 12.2.1.3.0 * * * Version Details Vulnerabilities
33 Application Oracle Weblogic Server 12.2.1.4.0 * * * Version Details Vulnerabilities
34 Application Oracle Weblogic Server 14.1.1.0.0 * * * Version Details Vulnerabilities
35 Application QOS Reload4j * * * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Apache Chainsaw 1
Apache Log4j 1
Oracle Advanced Supply Chain Planning 2
Oracle Business Intelligence 3
Oracle Business Process Management Suite 2
Oracle Communications Eagle Ftp Table Base Retrieval 1
Oracle Communications Messaging Server 1
Oracle Communications Network Integrity 1
Oracle Communications Unified Inventory Management 2
Oracle E-business Suite Cloud Manager And Cloud Backup Module 2
Oracle Enterprise Manager Base Platform 2
Oracle Financial Services Revenue Management And Billing Analytics 3
Oracle Healthcare Foundation 1
Oracle Hyperion Data Relationship Management 1
Oracle Hyperion Infrastructure Technology 1
Oracle Identity Management Suite 2
Oracle Identity Manager Connector 1
Oracle Jdeveloper 1
Oracle Middleware Common Libraries And Tools 1
Oracle Mysql Enterprise Monitor 1
Oracle Tuxedo 1
Oracle Weblogic Server 3
QOS Reload4j 1

- References For CVE-2022-23307

https://www.oracle.com/security-alerts/cpujul2022.html
N/A N/A
https://www.oracle.com/security-alerts/cpuapr2022.html
https://logging.apache.org/log4j/1.2/index.html
https://lists.apache.org/thread/rg4yyc89vs3dw6kpy3r92xop9loywyhh

- Metasploit Modules Related To CVE-2022-23307

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.