TYPO3 is an open source PHP based web content management system released under the GNU GPL. In affected versions failing to properly parse, sanitize and encode malicious rich-text content, the content rendering process in the website frontend is vulnerable to cross-site scripting. Corresponding rendering instructions via TypoScript functionality HTMLparser does not consider all potentially malicious HTML tag & attribute combinations per default. In default scenarios, a valid backend user account is needed to exploit this vulnerability. In case custom plugins used in the website frontend accept and reflect rich-text content submitted by users, no authentication is required. Update to TYPO3 versions 7.6.53 ELTS, 8.7.42 ELTS, 9.5.29, 10.4.19, 11.3.2 that fix the problem described.
Published 2021-08-10 17:15:11
Updated 2021-08-19 15:52:00
Source GitHub, Inc.
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)

Exploit prediction scoring system (EPSS) score for CVE-2021-32768

0.08%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 35 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2021-32768

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.3
MEDIUM AV:N/AC:M/Au:N/C:N/I:P/A:N
8.6
2.9
NIST
6.1
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
2.8
2.7
NIST
6.1
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
2.8
2.7
GitHub, Inc.

CWE ids for CVE-2021-32768

References for CVE-2021-32768

Products affected by CVE-2021-32768

  • Typo3 » Typo3 » Elts Edition
    Versions from including (>=) 8.0.0 and up to, including, (<=) 8.7.41
    cpe:2.3:a:typo3:typo3:*:*:*:*:elts:*:*:*
  • Typo3 » Typo3
    Versions from including (>=) 11.0.0 and up to, including, (<=) 11.3.1
    cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:*
  • Typo3 » Typo3
    Versions from including (>=) 9.0.0 and up to, including, (<=) 9.5.28
    cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:*
  • Typo3 » Typo3 » Elts Edition
    Versions from including (>=) 7.0.0 and up to, including, (<=) 7.6.52
    cpe:2.3:a:typo3:typo3:*:*:*:*:elts:*:*:*
  • Typo3 » Typo3
    Versions from including (>=) 10.0.0 and up to, including, (<=) 10.4.18
    cpe:2.3:a:typo3:typo3:*:*:*:*:*:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!