Acrobat Reader DC versions 2021.005.20054 (and earlier), 2020.004.30005 (and earlier) and 2017.011.30197 (and earlier) are affected by a Heap-based Buffer overflow vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Published 2021-08-20 19:15:09
Updated 2021-08-31 16:40:06
View at NVD,   CVE.org
Vulnerability category: Overflow

Exploit prediction scoring system (EPSS) score for CVE-2021-28638

0.18%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 56 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2021-28638

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.8
MEDIUM AV:N/AC:M/Au:N/C:P/I:P/A:P
8.6
6.4
NIST
7.8
HIGH CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
1.8
5.9
Adobe Systems Incorporated

CWE ids for CVE-2021-28638

  • A heap overflow condition is a buffer overflow, where the buffer that can be overwritten is allocated in the heap portion of memory, generally meaning that the buffer was allocated using a routine such as malloc().
    Assigned by: psirt@adobe.com (Primary)

References for CVE-2021-28638

Products affected by CVE-2021-28638

  • Adobe » Acrobat Dc » Classic Edition
    Versions from including (>=) 20.001.30005 and up to, including, (<=) 20.004.30005
    cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:classic:*:*:*
  • Adobe » Acrobat Dc » Continuous Edition
    Versions from including (>=) 15.008.20082 and up to, including, (<=) 21.005.20054
    cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:continuous:*:*:*
  • Adobe » Acrobat Dc » Classic Edition
    Versions from including (>=) 17.011.30059 and up to, including, (<=) 17.011.30197
    cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:classic:*:*:*
  • Adobe » Acrobat Reader Dc » Continuous Edition
    Versions from including (>=) 15.008.20082 and up to, including, (<=) 21.005.20054
    cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:continuous:*:*:*
  • Adobe » Acrobat Reader Dc » Classic Edition
    Versions from including (>=) 20.001.30005 and up to, including, (<=) 20.004.30005
    cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:classic:*:*:*
  • Adobe » Acrobat Reader Dc » Classic Edition
    Versions from including (>=) 17.011.30059 and up to, including, (<=) 17.011.30197
    cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:classic:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!