CWE - CWE-287: Improper Authentication vulnerability in SUSE Linux Enterprise Server 15 SP 3; openSUSE Tumbleweed allows local attackers to execute arbitrary code via salt without the need to specify valid credentials. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions.
Published 2021-03-03 10:15:14
Updated 2023-06-22 09:15:10
Source SUSE
View at NVD,   CVE.org
Vulnerability category: Execute codeBypassGain privilege

Exploit prediction scoring system (EPSS) score for CVE-2021-25315

0.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 12 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2021-25315

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.6
MEDIUM AV:L/AC:L/Au:N/C:P/I:P/A:P
3.9
6.4
NIST
9.8
CRITICAL CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
3.9
5.9
SUSE
7.8
HIGH CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
1.8
5.9
NIST

CWE ids for CVE-2021-25315

  • When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
    Assigned by:
    • meissner@suse.de (Primary)
    • nvd@nist.gov (Secondary)
  • The requirements for the product dictate the use of an established authentication algorithm, but the implementation of the algorithm is incorrect.
    Assigned by: meissner@suse.de (Secondary)

References for CVE-2021-25315

Products affected by CVE-2021-25315

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!