This affects all versions of package osm-static-maps. User input given to the package is passed directly to a template without escaping ({{{ ... }}}). As such, it is possible for an attacker to inject arbitrary HTML/JS code and depending on the context. It will be outputted as an HTML on the page which gives opportunity for XSS or rendered on the server (puppeteer) which also gives opportunity for SSRF and Local File Read.
Published 2020-10-20 11:15:13
Updated 2021-07-21 11:39:24
Source Snyk
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)Server-side request forgery (SSRF)

Exploit prediction scoring system (EPSS) score for CVE-2020-7749

0.16%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 51 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-7749

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.5
MEDIUM AV:N/AC:L/Au:S/C:P/I:P/A:P
8.0
6.4
NIST
7.6
HIGH CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
2.8
4.7
Snyk

CWE ids for CVE-2020-7749

References for CVE-2020-7749

Products affected by CVE-2020-7749

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!