LearnPress Wordpress plugin version prior and including 3.2.6.7 is vulnerable to SQL Injection
Published 2020-04-30 15:15:12
Updated 2021-07-19 18:15:08
View at NVD,   CVE.org
Vulnerability category: Sql Injection

Exploit prediction scoring system (EPSS) score for CVE-2020-6010

11.83%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 95 %
Percentile, the proportion of vulnerabilities that are scored at or less

Metasploit modules for CVE-2020-6010

  • Wordpress LearnPress current_items Authenticated SQLi
    Disclosure Date: 2020-04-29
    First seen: 2022-12-23
    auxiliary/scanner/http/wp_learnpress_sqli
    LearnPress, a learning management plugin for WordPress, prior to 3.2.6.8 is affected by an authenticated SQL injection via the current_items parameter of the post-new.php page. Authors: - h00die - Omri Herscovici - Sagi Tzadik - nhattruong

CVSS scores for CVE-2020-6010

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.5
MEDIUM AV:N/AC:L/Au:S/C:P/I:P/A:P
8.0
6.4
NIST
8.8
HIGH CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
2.8
5.9
NIST

CWE ids for CVE-2020-6010

  • The product constructs all or part of an SQL command using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended SQL command when it is sent to a downstream component. Without sufficient removal or quoting of SQL syntax in user-controllable inputs, the generated SQL query can cause those inputs to be interpreted as SQL instead of ordinary user data.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2020-6010

Products affected by CVE-2020-6010

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!