Jenkins Skytap Cloud CI Plugin 2.07 and earlier transmits configured credentials in plain text as part of job configuration forms, potentially resulting in their exposure.
Published 2020-03-09 16:15:15
Updated 2023-10-25 18:16:33
View at NVD,   CVE.org

Exploit prediction scoring system (EPSS) score for CVE-2020-2157

0.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 20 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-2157

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.0
MEDIUM AV:N/AC:L/Au:S/C:P/I:N/A:N
8.0
2.9
NIST
4.3
MEDIUM CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
2.8
1.4
NIST

CWE ids for CVE-2020-2157

  • The product transmits sensitive or security-critical data in cleartext in a communication channel that can be sniffed by unauthorized actors.
    Assigned by:
    • jenkinsci-cert@googlegroups.com (Secondary)
    • nvd@nist.gov (Primary)

References for CVE-2020-2157

Products affected by CVE-2020-2157

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!