CVEdetails.com the ultimate security vulnerability data source
(e.g.: CVE-2009-1234 or 2010-1234 or 20101234)
Log In   Register
Vulnerability Feeds & WidgetsNew   www.itsecdb.com  

Vulnerability Details : CVE-2020-15157

In containerd (an industry-standard container runtime) before version 1.2.14 there is a credential leaking vulnerability. If a container image manifest in the OCI Image format or Docker Image V2 Schema 2 format includes a URL for the location of a specific image layer (otherwise known as a “foreign layer”), the default containerd resolver will follow that URL to attempt to download it. In v1.2.x but not 1.3.0 or later, the default containerd resolver will provide its authentication credentials if the server where the URL is located presents an HTTP 401 status code along with registry-specific HTTP headers. If an attacker publishes a public image with a manifest that directs one of the layers to be fetched from a web server they control and they trick a user or system into pulling the image, they can obtain the credentials used for pulling that image. In some cases, this may be the user's username and password for the registry. In other cases, this may be the credentials attached to the cloud virtual instance which can grant access to other cloud resources in the account. The default containerd resolver is used by the cri-containerd plugin (which can be used by Kubernetes), the ctr development tool, and other client programs that have explicitly linked against it. This vulnerability has been fixed in containerd 1.2.14. containerd 1.3 and later are not affected. If you are using containerd 1.3 or later, you are not affected. If you are using cri-containerd in the 1.2 series or prior, you should ensure you only pull images from trusted sources. Other container runtimes built on top of containerd but not using the default resolver (such as Docker) are not affected.
Publish Date : 2020-10-16 Last Update Date : 2021-03-17
Search Twitter   Search YouTube   Search Google

- CVSS Scores & Vulnerability Types

CVSS Score
2.6
Confidentiality Impact Partial (There is considerable informational disclosure.)
Integrity Impact None (There is no impact to the integrity of the system)
Availability Impact None (There is no impact to the availability of the system.)
Access Complexity High (Specialized access conditions exist. It is hard to exploit and several special conditions must be satisfied to exploit)
Authentication Not required (Authentication is not required to exploit the vulnerability.)
Gained Access None
Vulnerability Type(s)
CWE ID 522

- Products Affected By CVE-2020-15157

# Product Type Vendor Product Version Update Edition Language
1 OS Canonical Ubuntu Linux 16.04 * * * Version Details Vulnerabilities
2 OS Canonical Ubuntu Linux 18.04 * * * Version Details Vulnerabilities
3 OS Canonical Ubuntu Linux 20.04 * * * Version Details Vulnerabilities
4 OS Debian Debian Linux 10.0 * * * Version Details Vulnerabilities
5 Application Linuxfoundation Containerd * * * * Version Details Vulnerabilities
6 Application Linuxfoundation Containerd 1.3.0 RC3 * * Version Details Vulnerabilities
7 Application Linuxfoundation Containerd 1.3.0 Beta1 * * Version Details Vulnerabilities
8 Application Linuxfoundation Containerd 1.3.0 Beta2 * * Version Details Vulnerabilities
9 Application Linuxfoundation Containerd 1.3.0 RC0 * * Version Details Vulnerabilities
10 Application Linuxfoundation Containerd 1.3.0 RC1 * * Version Details Vulnerabilities
11 Application Linuxfoundation Containerd 1.3.0 - * * Version Details Vulnerabilities
12 Application Linuxfoundation Containerd 1.3.0 RC2 * * Version Details Vulnerabilities
13 Application Linuxfoundation Containerd 1.3.0 Beta0 * * Version Details Vulnerabilities

- Number Of Affected Versions By Product

Vendor Product Vulnerable Versions
Canonical Ubuntu Linux 3
Debian Debian Linux 1
Linuxfoundation Containerd 9

- References For CVE-2020-15157

https://github.com/containerd/containerd/security/advisories/GHSA-742w-89gc-8m9c CONFIRM
https://github.com/containerd/containerd/releases/tag/v1.2.14
https://usn.ubuntu.com/4589-1/
UBUNTU USN-4589-1
https://usn.ubuntu.com/4589-2/
UBUNTU USN-4589-2
https://www.debian.org/security/2021/dsa-4865
DEBIAN DSA-4865

- Metasploit Modules Related To CVE-2020-15157

There are not any metasploit modules related to this CVE entry (Please visit www.metasploit.com for more information)


CVE is a registred trademark of the MITRE Corporation and the authoritative source of CVE content is MITRE's CVE web site. CWE is a registred trademark of the MITRE Corporation and the authoritative source of CWE content is MITRE's CWE web site. OVAL is a registered trademark of The MITRE Corporation and the authoritative source of OVAL content is MITRE's OVAL web site.
Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. It is the responsibility of user to evaluate the accuracy, completeness or usefulness of any information, opinion, advice or other content. EACH USER WILL BE SOLELY RESPONSIBLE FOR ANY consequences of his or her direct or indirect use of this web site. ALL WARRANTIES OF ANY KIND ARE EXPRESSLY DISCLAIMED. This site will NOT BE LIABLE FOR ANY DIRECT, INDIRECT or any other kind of loss.