It was found that the AMQ Online console is vulnerable to a Cross-Site Request Forgery (CSRF) which is exploitable in cases where preflight checks are not instigated or bypassed. For example authorised users using an older browser with Adobe Flash are vulnerable when targeted by an attacker. This flaw affects all versions of AMQ-Online prior to 1.5.2 and Enmasse versions 0.31.0-rc1 up until but not including 0.32.2.
Published 2020-08-03 17:15:12
Updated 2020-08-12 14:16:48
Source Red Hat, Inc.
View at NVD,   CVE.org
Vulnerability category: Cross-site request forgery (CSRF)

Exploit prediction scoring system (EPSS) score for CVE-2020-14319

0.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 19 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-14319

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.0
MEDIUM AV:N/AC:H/Au:N/C:N/I:P/A:P
4.9
4.9
NIST
5.9
MEDIUM CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:H
1.6
4.2
NIST

CWE ids for CVE-2020-14319

  • The web application does not, or can not, sufficiently verify whether a well-formed, valid, consistent request was intentionally provided by the user who submitted the request.
    Assigned by: nvd@nist.gov (Primary)

References for CVE-2020-14319

Products affected by CVE-2020-14319

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!