The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.
Published 2022-02-11 16:15:08
Updated 2022-02-18 01:42:40
Source Drupal.org
View at NVD,   CVE.org
Vulnerability category: Cross-site request forgery (CSRF)

Exploit prediction scoring system (EPSS) score for CVE-2020-13674

0.05%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 19 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-13674

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.3
MEDIUM AV:N/AC:M/Au:N/C:N/I:P/A:N
8.6
2.9
NIST
6.5
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
2.8
3.6
NIST

CWE ids for CVE-2020-13674

  • The web application does not, or can not, sufficiently verify whether a well-formed, valid, consistent request was intentionally provided by the user who submitted the request.
    Assigned by:
    • mlhess@drupal.org (Secondary)
    • nvd@nist.gov (Primary)

References for CVE-2020-13674

Products affected by CVE-2020-13674

This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!