A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration of the underlying parsers used by GitHub Pages were not sufficiently restricted and made it possible to execute commands on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22.7 and was fixed in 2.22.7, 2.21.15, and 2.20.24. The underlying issues contributing to this vulnerability were identified through the GitHub Security Bug Bounty program.
Published 2021-03-03 04:15:13
Updated 2021-12-20 22:26:54
View at NVD,   CVE.org
Vulnerability category: Execute code

Exploit prediction scoring system (EPSS) score for CVE-2020-10519

0.71%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 78 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-10519

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
6.5
MEDIUM AV:N/AC:L/Au:S/C:P/I:P/A:P
8.0
6.4
NIST
8.8
HIGH CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
2.8
5.9
NIST

CWE ids for CVE-2020-10519

References for CVE-2020-10519

Products affected by CVE-2020-10519

  • Github » Github » Enterprise Edition
    Versions from including (>=) 2.21.0 and before (<) 2.21.15
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
  • Github » Github » Enterprise Edition
    Versions from including (>=) 2.22.0 and before (<) 2.22.7
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
  • Github » Github » Enterprise Edition
    Versions before (<) 2.20.24
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!