An improper access control vulnerability was identified in GitHub Enterprise Server that allowed authenticated users of the instance to determine the names of unauthorized private repositories given their numerical IDs. This vulnerability did not allow unauthorized access to any repository content besides the name. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22 and was fixed in versions 2.21.6, 2.20.15, and 2.19.21. This vulnerability was reported via the GitHub Bug Bounty program.
Published 2020-08-27 22:15:10
Updated 2021-10-07 17:07:22
View at NVD,   CVE.org
Vulnerability category: BypassGain privilege

Exploit prediction scoring system (EPSS) score for CVE-2020-10517

0.06%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 26 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-10517

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.0
MEDIUM AV:N/AC:L/Au:S/C:P/I:N/A:N
8.0
2.9
NIST
4.3
MEDIUM CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
2.8
1.4
NIST

CWE ids for CVE-2020-10517

  • The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
    Assigned by: product-cna@github.com (Secondary)

References for CVE-2020-10517

Products affected by CVE-2020-10517

  • Github » Github » Enterprise Edition
    Versions from including (>=) 2.21.0 and before (<) 2.21.6
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
  • Github » Github » Enterprise Edition
    Versions from including (>=) 2.20.0 and before (<) 2.20.15
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
  • Github » Github » Enterprise Edition
    Versions before (<) 2.19.21
    cpe:2.3:a:github:github:*:*:*:*:enterprise:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!