GitLab 12.1 through 12.8.1 allows XSS. A stored cross-site scripting vulnerability was discovered when displaying merge requests.
Published 2020-03-13 18:15:13
Updated 2020-03-17 20:24:56
Source MITRE
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)

Exploit prediction scoring system (EPSS) score for CVE-2020-10076

0.07%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 31 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2020-10076

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
4.3
MEDIUM AV:N/AC:M/Au:N/C:N/I:P/A:N
8.6
2.9
NIST
6.1
MEDIUM CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
2.8
2.7
NIST

CWE ids for CVE-2020-10076

References for CVE-2020-10076

Products affected by CVE-2020-10076

  • Gitlab » Gitlab » Community Edition
    Versions from including (>=) 12.1.0 and up to, including, (<=) 12.8.1
    cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
  • Gitlab » Gitlab » Enterprise Edition
    Versions from including (>=) 12.1.0 and up to, including, (<=) 12.8.1
    cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!