A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.
Published 2019-11-06 00:15:13
Updated 2019-11-07 18:52:56
View at NVD,   CVE.org
Vulnerability category: Cross site scripting (XSS)

Exploit prediction scoring system (EPSS) score for CVE-2019-8152

0.06%
Probability of exploitation activity in the next 30 days EPSS Score History
~ 26 %
Percentile, the proportion of vulnerabilities that are scored at or less

CVSS scores for CVE-2019-8152

Base Score Base Severity CVSS Vector Exploitability Score Impact Score Score Source First Seen
3.5
LOW AV:N/AC:M/Au:S/C:N/I:P/A:N
6.8
2.9
NIST
5.4
MEDIUM CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
2.3
2.7
NIST

CWE ids for CVE-2019-8152

References for CVE-2019-8152

Products affected by CVE-2019-8152

  • Magento » Magento » Commerce Edition
    Versions from including (>=) 2.2.0 and before (<) 2.2.10
    cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*
  • Magento » Magento » Open Source Edition
    Versions from including (>=) 2.3.0 and before (<) 2.3.2
    cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*
  • Magento » Magento » Commerce Edition
    Versions from including (>=) 1.9.0.0 and before (<) 1.14.4.3
    cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*
  • Magento » Magento » Open Source Edition
    Versions from including (>=) 2.2.0 and before (<) 2.2.10
    cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*
  • Magento » Magento » Commerce Edition
    Versions from including (>=) 2.3.0 and before (<) 2.3.2
    cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*
  • Magento » Magento » Open Source Edition
    Versions from including (>=) 1.5.0.0 and before (<) 1.9.4.3
    cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*
  • Magento » Magento » Version: 2.3.2 Open Source Edition
    cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:*
  • Magento » Magento » Version: 2.3.2 Commerce Edition
    cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:*
This web site uses cookies for managing your session, storing preferences, website analytics and additional purposes described in our privacy policy.
By using this web site you are agreeing to CVEdetails.com terms of use!